update to 20140323
This commit is contained in:
parent
3f4c9ef817
commit
ae698ba922
5
.gitignore
vendored
5
.gitignore
vendored
@ -1,4 +1,3 @@
|
|||||||
/ncurses-5.9.tar.gz
|
/ncurses-5.9.tar.gz
|
||||||
/ncurses-5.9-20120616-patch.sh.bz2
|
/ncurses-5.9-20140308-patch.sh.bz2
|
||||||
/ncurses-5.9-20120622-20130413.patch.xz
|
/ncurses-5.9-20140315-20140323.patch.xz
|
||||||
/ncurses-5.9-20130427-20130511.patch.xz
|
|
||||||
|
@ -1,34 +0,0 @@
|
|||||||
diff -up ncurses-5.9/man/clear.1.clear ncurses-5.9/man/clear.1
|
|
||||||
--- ncurses-5.9/man/clear.1.clear 2010-12-04 19:36:44.000000000 +0100
|
|
||||||
+++ ncurses-5.9/man/clear.1 2013-01-30 12:33:06.140568071 +0100
|
|
||||||
@@ -37,7 +37,10 @@
|
|
||||||
.SH DESCRIPTION
|
|
||||||
\fB@CLEAR@\fR clears your screen if this is possible. It looks in the
|
|
||||||
environment for the terminal type and then in the \fBterminfo\fR database to
|
|
||||||
-figure out how to clear the screen.
|
|
||||||
+figure out how to clear the screen. Some terminals can clear also their
|
|
||||||
+scrollback buffer to prevent access to potentially sensitive data. If the
|
|
||||||
+\fBterminfo\fR entry for the terminal type contains extended capability
|
|
||||||
+\fBE3\fR, \fB@CLEAR@\fR will use it to clear the scrollback buffer.
|
|
||||||
.PP
|
|
||||||
\fB@CLEAR@\fR ignores any command-line parameters that may be present.
|
|
||||||
.SH SEE ALSO
|
|
||||||
diff -up ncurses-5.9/progs/clear.c.clear ncurses-5.9/progs/clear.c
|
|
||||||
--- ncurses-5.9/progs/clear.c.clear 2007-10-14 00:16:02.000000000 +0200
|
|
||||||
+++ ncurses-5.9/progs/clear.c 2013-01-30 12:13:10.494509019 +0100
|
|
||||||
@@ -52,7 +52,15 @@ main(
|
|
||||||
int argc GCC_UNUSED,
|
|
||||||
char *argv[]GCC_UNUSED)
|
|
||||||
{
|
|
||||||
+ char *E3;
|
|
||||||
+
|
|
||||||
setupterm((char *) 0, STDOUT_FILENO, (int *) 0);
|
|
||||||
+
|
|
||||||
+ /* Clear the scrollback buffer if possible. */
|
|
||||||
+ E3 = tigetstr("E3");
|
|
||||||
+ if (E3 && E3 != CANCELLED_STRING)
|
|
||||||
+ tputs(E3, lines > 0 ? lines : 1, putch);
|
|
||||||
+
|
|
||||||
ExitProgram((tputs(clear_screen, lines > 0 ? lines : 1, putch) == ERR)
|
|
||||||
? EXIT_FAILURE
|
|
||||||
: EXIT_SUCCESS);
|
|
11
ncurses.spec
11
ncurses.spec
@ -1,18 +1,16 @@
|
|||||||
Summary: Ncurses support utilities
|
Summary: Ncurses support utilities
|
||||||
Name: ncurses
|
Name: ncurses
|
||||||
Version: 5.9
|
Version: 5.9
|
||||||
Release: 12.20130511%{?dist}
|
Release: 12.20140323%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://invisible-island.net/ncurses/ncurses.html
|
URL: http://invisible-island.net/ncurses/ncurses.html
|
||||||
Source0: ftp://invisible-island.net/ncurses/ncurses-%{version}.tar.gz
|
Source0: ftp://invisible-island.net/ncurses/ncurses-%{version}.tar.gz
|
||||||
|
|
||||||
Patch1: ncurses-5.9-20120616-patch.sh.bz2
|
Patch1: ncurses-5.9-20140308-patch.sh.bz2
|
||||||
Patch2: ncurses-5.9-20120622-20130413.patch.xz
|
Patch2: ncurses-5.9-20140315-20140323.patch.xz
|
||||||
Patch3: ncurses-5.9-20130427-20130511.patch.xz
|
|
||||||
Patch8: ncurses-config.patch
|
Patch8: ncurses-config.patch
|
||||||
Patch9: ncurses-libs.patch
|
Patch9: ncurses-libs.patch
|
||||||
Patch10: ncurses-clear.patch
|
|
||||||
Patch11: ncurses-urxvt.patch
|
Patch11: ncurses-urxvt.patch
|
||||||
Patch12: ncurses-kbs.patch
|
Patch12: ncurses-kbs.patch
|
||||||
BuildRequires: gpm-devel pkgconfig
|
BuildRequires: gpm-devel pkgconfig
|
||||||
@ -98,12 +96,9 @@ The ncurses-static package includes static libraries of the ncurses library.
|
|||||||
|
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
|
||||||
|
|
||||||
%patch8 -p1 -b .config
|
%patch8 -p1 -b .config
|
||||||
%patch9 -p1 -b .libs
|
%patch9 -p1 -b .libs
|
||||||
# -b would add the backup to rpm
|
|
||||||
%patch10 -p1
|
|
||||||
%patch11 -p1 -b .urxvt
|
%patch11 -p1 -b .urxvt
|
||||||
%patch12 -p1 -b .kbs
|
%patch12 -p1 -b .kbs
|
||||||
|
|
||||||
|
5
sources
5
sources
@ -1,4 +1,3 @@
|
|||||||
8cb9c412e5f2d96bc6f459aa8c6282a1 ncurses-5.9.tar.gz
|
8cb9c412e5f2d96bc6f459aa8c6282a1 ncurses-5.9.tar.gz
|
||||||
f54bf02a349f96a7c4f0d00922f3a0d4 ncurses-5.9-20120616-patch.sh.bz2
|
8bd412a9c9ac97a2c504780ae87aa5d8 ncurses-5.9-20140308-patch.sh.bz2
|
||||||
763bf7e9db104a0aacd677bf4029ff73 ncurses-5.9-20120622-20130413.patch.xz
|
982dc252b83336d817edc6a711d77e6f ncurses-5.9-20140315-20140323.patch.xz
|
||||||
228daf29293b2b74cca01eebbfe82a88 ncurses-5.9-20130427-20130511.patch.xz
|
|
||||||
|
Loading…
Reference in New Issue
Block a user