- update to patch 20100123
- remove AS_NEEDED from linker scripts
This commit is contained in:
parent
66532e6145
commit
3cb1c2e925
@ -1,3 +1,3 @@
|
||||
ncurses-5.7.tar.gz
|
||||
ncurses-5.7-20091107-patch.sh.bz2
|
||||
ncurses-5.7-20091114-20100116.patch.bz2
|
||||
ncurses-5.7-20091114-20100123.patch.bz2
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up ncurses-5.7/progs/modules.transformdeps ncurses-5.7/progs/modules
|
||||
--- ncurses-5.7/progs/modules.transformdeps 2010-01-18 16:52:31.000000000 +0100
|
||||
+++ ncurses-5.7/progs/modules 2010-01-18 17:07:27.000000000 +0100
|
||||
@@ -40,6 +40,6 @@ infocmp progs $(srcdir) $(HEADER_DEPS)
|
||||
tabs progs $(srcdir) $(HEADER_DEPS)
|
||||
tput progs $(srcdir) $(HEADER_DEPS) transform.h termsort.c
|
||||
tset progs $(srcdir) $(HEADER_DEPS) transform.h $(srcdir)/dump_entry.h ../include/termcap.h
|
||||
-transform progs $(srcdir) $(HEADER_DEPS)
|
||||
+transform progs $(srcdir) $(HEADER_DEPS) transform.h
|
||||
|
||||
# vile:makemode
|
@ -1,17 +0,0 @@
|
||||
diff -up ncurses-5.7/include/curses.h.in.wattrsetunused ncurses-5.7/include/curses.h.in
|
||||
--- ncurses-5.7/include/curses.h.in.wattrsetunused 2010-01-19 13:40:06.000000000 +0100
|
||||
+++ ncurses-5.7/include/curses.h.in 2010-01-19 14:18:35.000000000 +0100
|
||||
@@ -1104,11 +1104,9 @@ extern NCURSES_EXPORT(int) NCURSES_SP_NA
|
||||
#if !NCURSES_OPAQUE
|
||||
#if defined(_XOPEN_SOURCE_EXTENDED) && @NCURSES_EXT_COLORS@
|
||||
#define wattrset(win,at) ((win)->_color = PAIR_NUMBER(at), \
|
||||
- (win)->_attrs = (at), \
|
||||
- NCURSES_CAST(int, (win)->_attrs))
|
||||
+ NCURSES_CAST(int, (win)->_attrs = (at)))
|
||||
#else
|
||||
-#define wattrset(win,at) ((win)->_attrs = (at), \
|
||||
- NCURSES_CAST(int, (win)->_attrs))
|
||||
+#define wattrset(win,at) NCURSES_CAST(int, (win)->_attrs = (at))
|
||||
#endif
|
||||
#endif /* NCURSES_OPAQUE */
|
||||
|
@ -1,36 +0,0 @@
|
||||
diff -up ncurses-5.7/ncurses/curses.priv.h.windowlist ncurses-5.7/ncurses/curses.priv.h
|
||||
--- ncurses-5.7/ncurses/curses.priv.h.windowlist 2010-01-19 17:37:05.000000000 +0100
|
||||
+++ ncurses-5.7/ncurses/curses.priv.h 2010-01-19 17:41:59.000000000 +0100
|
||||
@@ -1098,9 +1098,9 @@ extern NCURSES_EXPORT_VAR(SCREEN *) _nc_
|
||||
extern NCURSES_EXPORT_VAR(SIG_ATOMIC_T) _nc_have_sigwinch;
|
||||
|
||||
WINDOWLIST {
|
||||
- WINDOW win; /* first, so WINDOW_EXT() works */
|
||||
WINDOWLIST *next;
|
||||
SCREEN *screen; /* screen containing the window */
|
||||
+ WINDOW win; /* WINDOW_EXT() needs to account for offset */
|
||||
#ifdef _XOPEN_SOURCE_EXTENDED
|
||||
char addch_work[(MB_LEN_MAX * 9) + 1];
|
||||
unsigned addch_used; /* number of bytes in addch_work[] */
|
||||
@@ -1109,7 +1109,7 @@ extern NCURSES_EXPORT_VAR(SIG_ATOMIC_T)
|
||||
#endif
|
||||
};
|
||||
|
||||
-#define WINDOW_EXT(win,field) (((WINDOWLIST *)(win))->field)
|
||||
+#define WINDOW_EXT(win,field) (((WINDOWLIST *)((void **)win - 2))->field)
|
||||
|
||||
#define SP_PRE_INIT(sp) \
|
||||
sp->_cursrow = -1; \
|
||||
diff -up ncurses-5.7/ncurses/tinfo/lib_data.c.windowlist ncurses-5.7/ncurses/tinfo/lib_data.c
|
||||
--- ncurses-5.7/ncurses/tinfo/lib_data.c.windowlist 2010-01-19 17:37:05.000000000 +0100
|
||||
+++ ncurses-5.7/ncurses/tinfo/lib_data.c 2010-01-19 17:45:24.000000000 +0100
|
||||
@@ -260,8 +260,7 @@ _nc_screen_of(WINDOW *win)
|
||||
SCREEN *sp = 0;
|
||||
|
||||
if (win != 0) {
|
||||
- WINDOWLIST *wp = (WINDOWLIST *) win;
|
||||
- sp = wp->screen;
|
||||
+ sp = WINDOW_EXT(win, screen);
|
||||
}
|
||||
return (sp);
|
||||
}
|
17
ncurses-5.7-20100123-headerdeps.patch
Normal file
17
ncurses-5.7-20100123-headerdeps.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff -up ncurses-5.7/ncurses/Makefile.in.headerdeps ncurses-5.7/ncurses/Makefile.in
|
||||
--- ncurses-5.7/ncurses/Makefile.in.headerdeps 2010-01-25 10:58:59.000000000 +0100
|
||||
+++ ncurses-5.7/ncurses/Makefile.in 2010-01-25 11:06:59.000000000 +0100
|
||||
@@ -157,10 +157,10 @@ AUTO_SRC = \
|
||||
HEADER_DEPS = \
|
||||
$(srcdir)/curses.priv.h \
|
||||
$(INCDIR)/ncurses_dll.h \
|
||||
- $(INCDIR)/ncurses_cfg.h \
|
||||
- $(INCDIR)/curses.h \
|
||||
+ ../include/ncurses_cfg.h \
|
||||
+ ../include/curses.h \
|
||||
$(INCDIR)/nc_panel.h \
|
||||
- $(INCDIR)/term.h \
|
||||
+ ../include/term.h \
|
||||
$(INCDIR)/term_entry.h \
|
||||
$(INCDIR)/nc_tparm.h \
|
||||
$(INCDIR)/nc_alloc.h \
|
18
ncurses.spec
18
ncurses.spec
@ -1,22 +1,20 @@
|
||||
Summary: Ncurses support utilities
|
||||
Name: ncurses
|
||||
Version: 5.7
|
||||
Release: 5.20100116%{?dist}
|
||||
Release: 6.20100123%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Base
|
||||
URL: http://invisible-island.net/ncurses/ncurses.html
|
||||
Source0: ftp://invisible-island.net/ncurses/ncurses-%{version}.tar.gz
|
||||
|
||||
Patch1: ncurses-5.7-20091107-patch.sh.bz2
|
||||
Patch2: ncurses-5.7-20091114-20100116.patch.bz2
|
||||
Patch2: ncurses-5.7-20091114-20100123.patch.bz2
|
||||
|
||||
Patch8: ncurses-5.7-20100116-config.patch
|
||||
Patch9: ncurses-5.6-20070612-libs.patch
|
||||
Patch11: ncurses-5.6-20080112-urxvt.patch
|
||||
Patch12: ncurses-5.6-20080628-kbs.patch
|
||||
Patch13: ncurses-5.7-20100116-transformdeps.patch
|
||||
Patch14: ncurses-5.7-20100116-wattrsetunused.patch
|
||||
Patch15: ncurses-5.7-20100116-windowlist.patch
|
||||
Patch13: ncurses-5.7-20100123-headerdeps.patch
|
||||
BuildRequires: gpm-devel pkgconfig
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -100,9 +98,7 @@ The ncurses-static package includes static libraries of the ncurses library.
|
||||
%patch9 -p1 -b .libs
|
||||
%patch11 -p1 -b .urxvt
|
||||
%patch12 -p1 -b .kbs
|
||||
%patch13 -p1 -b .transformdeps
|
||||
%patch14 -p1 -b .wattrsetunused
|
||||
%patch15 -p1 -b .windowlist
|
||||
%patch13 -p1 -b .headerdeps
|
||||
|
||||
# this will be in documentation, drop executable bits
|
||||
cp -p install-sh test
|
||||
@ -214,7 +210,7 @@ done
|
||||
for l in $RPM_BUILD_ROOT%{_libdir}/libncurses{,w}.so; do
|
||||
soname=$(basename $(readlink $l))
|
||||
rm -f $l
|
||||
echo "INPUT(AS_NEEDED($soname -ltinfo))" > $l
|
||||
echo "INPUT($soname -ltinfo)" > $l
|
||||
done
|
||||
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libcurses{,w}.so
|
||||
@ -280,6 +276,10 @@ bzip2 NEWS
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%changelog
|
||||
* Mon Jan 25 2010 Miroslav Lichvar <mlichvar@redhat.com> 5.7-6.20100123
|
||||
- update to patch 20100123
|
||||
- remove AS_NEEDED from linker scripts
|
||||
|
||||
* Wed Jan 20 2010 Miroslav Lichvar <mlichvar@redhat.com> 5.7-5.20100116
|
||||
- fix narrow/wide libtinfo compatibility
|
||||
- fix wattrset macro to not produce warning with current gcc (#556645)
|
||||
|
Loading…
Reference in New Issue
Block a user