49 lines
1.3 KiB
Diff
49 lines
1.3 KiB
Diff
From 5ccf1068703d300c8b5579b3a6ef0e409b5a713e Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Tue, 19 Jul 2022 11:56:47 +0100
|
|
Subject: [PATCH] tests: Hoist some EXTRA_DIST out of automake conditionals
|
|
|
|
We can fail to add some test files (test.tcl, test.lua) to the tarball
|
|
if compiling with those languages disabled, which would cause knock-on
|
|
failures when the tarball was used with the languages enabled. We
|
|
already fixed this for Ruby etc, this commit fixes it for Tcl and Lua.
|
|
|
|
(cherry picked from commit 3b6763c82909c95431ff57c2fe9be1b98316b057)
|
|
---
|
|
tests/Makefile.am | 6 ++++--
|
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
index 0f4b0746..2667be32 100644
|
|
--- a/tests/Makefile.am
|
|
+++ b/tests/Makefile.am
|
|
@@ -1203,10 +1203,11 @@ EXTRA_DIST += \
|
|
$(NULL)
|
|
|
|
# Tcl plugin test.
|
|
+EXTRA_DIST += test.tcl
|
|
+
|
|
if HAVE_TCL
|
|
|
|
LIBGUESTFS_TESTS += test-tcl
|
|
-EXTRA_DIST += test.tcl
|
|
|
|
test_tcl_SOURCES = test-lang-plugins.c test.h
|
|
test_tcl_CFLAGS = \
|
|
@@ -1219,10 +1220,11 @@ test_tcl_LDADD = libtest.la $(LIBGUESTFS_LIBS)
|
|
endif HAVE_TCL
|
|
|
|
# Lua plugin test.
|
|
+EXTRA_DIST += test.lua
|
|
+
|
|
if HAVE_LUA
|
|
|
|
LIBGUESTFS_TESTS += test-lua
|
|
-EXTRA_DIST += test.lua
|
|
|
|
test_lua_SOURCES = test-lang-plugins.c test.h
|
|
test_lua_CFLAGS = \
|
|
--
|
|
2.31.1
|
|
|