55 lines
1.4 KiB
Diff
55 lines
1.4 KiB
Diff
From 07ecff1613b73f32b5954bd3a3d46bef6a39e396 Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Sat, 9 Jun 2018 14:56:13 +0100
|
|
Subject: [PATCH] =?UTF-8?q?tests:=20If=20guestfish=20isn't=20available,=20?=
|
|
=?UTF-8?q?=E2=80=98disk=E2=80=99=20is=20not=20created=20so=20disable=20te?=
|
|
=?UTF-8?q?sts=20which=20need=20it.?=
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Fixes commit 02f27adc50ed5b83021df4edc84f4dbf8b03a0e3.
|
|
---
|
|
tests/Makefile.am | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
index 850240b..64a758e 100644
|
|
--- a/tests/Makefile.am
|
|
+++ b/tests/Makefile.am
|
|
@@ -279,6 +279,7 @@ test_file_LDADD = libtest.la $(LIBGUESTFS_LIBS)
|
|
|
|
# gzip plugin test.
|
|
if HAVE_ZLIB
|
|
+if HAVE_GUESTFISH
|
|
|
|
LIBGUESTFS_TESTS += test-gzip
|
|
check_DATA += disk.gz
|
|
@@ -292,6 +293,7 @@ disk.gz: disk
|
|
rm -f $@
|
|
gzip -9 -c disk > $@
|
|
|
|
+endif HAVE_GUESTFISH
|
|
endif HAVE_ZLIB
|
|
|
|
# memory plugin test.
|
|
@@ -347,6 +349,7 @@ test_streaming_LDADD = libtest.la $(LIBGUESTFS_LIBS)
|
|
|
|
# xz plugin test.
|
|
if HAVE_LIBLZMA
|
|
+if HAVE_GUESTFISH
|
|
|
|
LIBGUESTFS_TESTS += test-xz
|
|
check_DATA += disk.xz
|
|
@@ -360,6 +363,7 @@ disk.xz: disk
|
|
rm -f $@
|
|
xz --best --block-size=16777216 -c disk > $@
|
|
|
|
+endif HAVE_GUESTFISH
|
|
endif HAVE_LIBLZMA
|
|
|
|
#----------------------------------------------------------------------
|
|
--
|
|
2.16.2
|
|
|