Add support for VDDK 8.0.0
resolves: rhbz#2143889
This commit is contained in:
parent
d7e3d19b6a
commit
f013103704
53
0024-vddk-Add-support-for-VDDK-8.0.0.patch
Normal file
53
0024-vddk-Add-support-for-VDDK-8.0.0.patch
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
From b1023cdc159ed852baf1b43e58e95b011df09182 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||||
|
Date: Fri, 18 Nov 2022 09:43:19 +0000
|
||||||
|
Subject: [PATCH] vddk: Add support for VDDK 8.0.0
|
||||||
|
|
||||||
|
There are no changes in any of the structures or enums that we rely on.
|
||||||
|
|
||||||
|
Reported-by: Ming Xie
|
||||||
|
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=2143889
|
||||||
|
(cherry picked from commit dbe12ed499baeea94d603db55cad9e971e0ebcf0)
|
||||||
|
---
|
||||||
|
plugins/vddk/nbdkit-vddk-plugin.pod | 2 +-
|
||||||
|
plugins/vddk/vddk.c | 4 +++-
|
||||||
|
2 files changed, 4 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/plugins/vddk/nbdkit-vddk-plugin.pod b/plugins/vddk/nbdkit-vddk-plugin.pod
|
||||||
|
index 3991e86b..4d6040be 100644
|
||||||
|
--- a/plugins/vddk/nbdkit-vddk-plugin.pod
|
||||||
|
+++ b/plugins/vddk/nbdkit-vddk-plugin.pod
|
||||||
|
@@ -526,7 +526,7 @@ by this build.
|
||||||
|
|
||||||
|
=item C<vddk_library_version=...>
|
||||||
|
|
||||||
|
-The VDDK major library version: 6, 7, ...
|
||||||
|
+The VDDK major library version: 6, 7, 8, ...
|
||||||
|
If this is omitted it means the library could not be loaded.
|
||||||
|
|
||||||
|
=item C<vddk_dll=...>
|
||||||
|
diff --git a/plugins/vddk/vddk.c b/plugins/vddk/vddk.c
|
||||||
|
index 35697bc1..9e29075f 100644
|
||||||
|
--- a/plugins/vddk/vddk.c
|
||||||
|
+++ b/plugins/vddk/vddk.c
|
||||||
|
@@ -77,7 +77,7 @@ NBDKIT_DLL_PUBLIC int vddk_debug_datapath = 1;
|
||||||
|
void *dl; /* dlopen handle */
|
||||||
|
bool init_called; /* was InitEx called */
|
||||||
|
__thread int error_suppression; /* threadlocal error suppression */
|
||||||
|
-int library_version; /* VDDK major: 6, 7, ... */
|
||||||
|
+int library_version; /* VDDK major: 6, 7, 8, ... */
|
||||||
|
bool is_remote; /* true if remote connection */
|
||||||
|
|
||||||
|
enum compression_type compression; /* compression */
|
||||||
|
@@ -403,6 +403,8 @@ load_library (bool load_error_is_fatal)
|
||||||
|
* our testsuite is easier to write if we point libdir directly to
|
||||||
|
* a stub .so.
|
||||||
|
*/
|
||||||
|
+ { "lib64/libvixDiskLib.so.8", 8 },
|
||||||
|
+ { "libvixDiskLib.so.8", 8 },
|
||||||
|
{ "lib64/libvixDiskLib.so.7", 7 },
|
||||||
|
{ "libvixDiskLib.so.7", 7 },
|
||||||
|
{ "lib64/libvixDiskLib.so.6", 6 },
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
30
0025-vddk-Document-that-8.0.0-has-now-been-tested.patch
Normal file
30
0025-vddk-Document-that-8.0.0-has-now-been-tested.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From 750e4c9e4ba438c2092dc66046d7a87df3886457 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||||
|
Date: Tue, 29 Nov 2022 08:26:46 +0000
|
||||||
|
Subject: [PATCH] vddk: Document that 8.0.0 has now been tested
|
||||||
|
|
||||||
|
I forgot to update the man page.
|
||||||
|
|
||||||
|
Thanks: Alice Frosi
|
||||||
|
Fixes: commit dbe12ed499baeea94d603db55cad9e971e0ebcf0
|
||||||
|
(cherry picked from commit f0ed40307a2a0b873e4271e90f6e9c2e50c75017)
|
||||||
|
---
|
||||||
|
plugins/vddk/nbdkit-vddk-plugin.pod | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/plugins/vddk/nbdkit-vddk-plugin.pod b/plugins/vddk/nbdkit-vddk-plugin.pod
|
||||||
|
index 4d6040be..988413cf 100644
|
||||||
|
--- a/plugins/vddk/nbdkit-vddk-plugin.pod
|
||||||
|
+++ b/plugins/vddk/nbdkit-vddk-plugin.pod
|
||||||
|
@@ -672,7 +672,7 @@ server, which can also be very slow.
|
||||||
|
This plugin requires VDDK E<ge> 6.5 (released Nov 2016). It is only
|
||||||
|
supported on the x64-64 archtecture.
|
||||||
|
|
||||||
|
-It has been tested with all versions up to 7.0.3 (but should work with
|
||||||
|
+It has been tested with all versions up to 8.0.0 (but should work with
|
||||||
|
future versions).
|
||||||
|
|
||||||
|
VDDK 6.7 was the first version that supported the
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
@ -6,7 +6,7 @@ set -e
|
|||||||
# directory. Use it like this:
|
# directory. Use it like this:
|
||||||
# ./copy-patches.sh
|
# ./copy-patches.sh
|
||||||
|
|
||||||
rhel_version=9.1
|
rhel_version=9.2
|
||||||
|
|
||||||
# Check we're in the right directory.
|
# Check we're in the right directory.
|
||||||
if [ ! -f nbdkit.spec ]; then
|
if [ ! -f nbdkit.spec ]; then
|
||||||
|
10
nbdkit.spec
10
nbdkit.spec
@ -53,7 +53,7 @@ ExclusiveArch: x86_64
|
|||||||
|
|
||||||
Name: nbdkit
|
Name: nbdkit
|
||||||
Version: 1.30.8
|
Version: 1.30.8
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: NBD server
|
Summary: NBD server
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -75,7 +75,7 @@ Source2: libguestfs.keyring
|
|||||||
Source3: copy-patches.sh
|
Source3: copy-patches.sh
|
||||||
|
|
||||||
# Patches come from the upstream repository:
|
# Patches come from the upstream repository:
|
||||||
# https://gitlab.com/nbdkit/nbdkit/-/commits/rhel-9.1/
|
# https://gitlab.com/nbdkit/nbdkit/-/commits/rhel-9.2/
|
||||||
|
|
||||||
# Patches.
|
# Patches.
|
||||||
Patch0001: 0001-ssh-Allow-the-remote-file-to-be-created.patch
|
Patch0001: 0001-ssh-Allow-the-remote-file-to-be-created.patch
|
||||||
@ -101,6 +101,8 @@ Patch0020: 0020-luks-Check-return-values-from-malloc-more-carefully.patch
|
|||||||
Patch0021: 0021-luks-Avoid-potential-overflow-when-computing-key-mat.patch
|
Patch0021: 0021-luks-Avoid-potential-overflow-when-computing-key-mat.patch
|
||||||
Patch0022: 0022-luks-Avoid-memory-leak-on-error-path.patch
|
Patch0022: 0022-luks-Avoid-memory-leak-on-error-path.patch
|
||||||
Patch0023: 0023-tests-Hoist-some-EXTRA_DIST-out-of-automake-conditio.patch
|
Patch0023: 0023-tests-Hoist-some-EXTRA_DIST-out-of-automake-conditio.patch
|
||||||
|
Patch0024: 0024-vddk-Add-support-for-VDDK-8.0.0.patch
|
||||||
|
Patch0025: 0025-vddk-Document-that-8.0.0-has-now-been-tested.patch
|
||||||
|
|
||||||
# For automatic RPM Provides generation.
|
# For automatic RPM Provides generation.
|
||||||
# See: https://rpm-software-management.github.io/rpm/manual/dependency_generators.html
|
# See: https://rpm-software-management.github.io/rpm/manual/dependency_generators.html
|
||||||
@ -1208,6 +1210,10 @@ export LIBGUESTFS_TRACE=1
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 29 2022 Richard W.M. Jones <rjones@redhat.com> - 1.30.8-2
|
||||||
|
- Add support for VDDK 8.0.0
|
||||||
|
resolves: rhbz#2143889
|
||||||
|
|
||||||
* Tue Jul 19 2022 Richard W.M. Jones <rjones@redhat.com> - 1.30.8-1
|
* Tue Jul 19 2022 Richard W.M. Jones <rjones@redhat.com> - 1.30.8-1
|
||||||
- Rebase to new stable branch version 1.30.8
|
- Rebase to new stable branch version 1.30.8
|
||||||
resolves: rhbz#2059289
|
resolves: rhbz#2059289
|
||||||
|
Loading…
Reference in New Issue
Block a user