New upstream version 1.11.2.
Drop patches included in upstream tarball.
This commit is contained in:
parent
fcff8d2bb2
commit
e9f944b4e7
@ -1,38 +0,0 @@
|
|||||||
From 1a0c80cbe9f561fd6a8801c3bfda1783ce40080f Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
||||||
Date: Tue, 22 Jan 2019 23:22:55 +0000
|
|
||||||
Subject: [PATCH 1/2] =?UTF-8?q?tests:=20Make=20test-partition2.sh=20depend?=
|
|
||||||
=?UTF-8?q?=20on=20=E2=80=98disk=E2=80=99=20file=20being=20created.?=
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
This requires guestfish, so make the test depend on that (although it
|
|
||||||
does not really need it).
|
|
||||||
|
|
||||||
Fixes commit bf41e6b04b683570e8b059527ef604add2d42705.
|
|
||||||
---
|
|
||||||
tests/Makefile.am | 7 ++++---
|
|
||||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
||||||
index 5e8b53c..859b6ed 100644
|
|
||||||
--- a/tests/Makefile.am
|
|
||||||
+++ b/tests/Makefile.am
|
|
||||||
@@ -798,9 +798,10 @@ test_offset_LDADD = libtest.la $(LIBGUESTFS_LIBS)
|
|
||||||
TESTS += test-offset2.sh
|
|
||||||
|
|
||||||
# partition filter test.
|
|
||||||
-TESTS += \
|
|
||||||
- test-partition1.sh \
|
|
||||||
- test-partition2.sh
|
|
||||||
+TESTS += test-partition1.sh
|
|
||||||
+if HAVE_GUESTFISH
|
|
||||||
+TESTS += test-partition2.sh
|
|
||||||
+endif
|
|
||||||
|
|
||||||
# truncate filter tests.
|
|
||||||
TESTS += \
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
@ -1,31 +0,0 @@
|
|||||||
From cfd884c1ad379a5127fca72d2305ae3373bcb989 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
||||||
Date: Wed, 23 Jan 2019 09:36:44 +0000
|
|
||||||
Subject: [PATCH 2/2] tests: Name endif HAVE_GUESTFISH.
|
|
||||||
|
|
||||||
The Fedora build removes if HAVE_GUESTFISH / endif HAVE_GUESTFISH on
|
|
||||||
some architectures, but it does this by matching the reminder comment
|
|
||||||
on the endif. If this is missing it gets confused.
|
|
||||||
|
|
||||||
Fixes commit 1a0c80cbe9f561fd6a8801c3bfda1783ce40080f
|
|
||||||
and commit bf41e6b04b683570e8b059527ef604add2d42705.
|
|
||||||
---
|
|
||||||
tests/Makefile.am | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
||||||
index 859b6ed..948f14b 100644
|
|
||||||
--- a/tests/Makefile.am
|
|
||||||
+++ b/tests/Makefile.am
|
|
||||||
@@ -801,7 +801,7 @@ TESTS += test-offset2.sh
|
|
||||||
TESTS += test-partition1.sh
|
|
||||||
if HAVE_GUESTFISH
|
|
||||||
TESTS += test-partition2.sh
|
|
||||||
-endif
|
|
||||||
+endif HAVE_GUESTFISH
|
|
||||||
|
|
||||||
# truncate filter tests.
|
|
||||||
TESTS += \
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
13
nbdkit.spec
13
nbdkit.spec
@ -25,14 +25,14 @@
|
|||||||
%global verify_tarball_signature 1
|
%global verify_tarball_signature 1
|
||||||
|
|
||||||
# If there are patches which touch autotools files, set this to 1.
|
# If there are patches which touch autotools files, set this to 1.
|
||||||
%global patches_touch_autotools 1
|
%global patches_touch_autotools %{nil}
|
||||||
|
|
||||||
# The source directory.
|
# The source directory.
|
||||||
%global source_directory 1.11-development
|
%global source_directory 1.11-development
|
||||||
|
|
||||||
Name: nbdkit
|
Name: nbdkit
|
||||||
Version: 1.11.1
|
Version: 1.11.2
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: NBD server
|
Summary: NBD server
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -45,9 +45,6 @@ Source1: http://libguestfs.org/download/nbdkit/%{source_directory}/%{name
|
|||||||
Source2: libguestfs.keyring
|
Source2: libguestfs.keyring
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Patch1: 0001-tests-Make-test-partition2.sh-depend-on-disk-file-be.patch
|
|
||||||
Patch2: 0002-tests-Name-endif-HAVE_GUESTFISH.patch
|
|
||||||
|
|
||||||
%if 0%{patches_touch_autotools}
|
%if 0%{patches_touch_autotools}
|
||||||
BuildRequires: autoconf, automake, libtool
|
BuildRequires: autoconf, automake, libtool
|
||||||
%endif
|
%endif
|
||||||
@ -962,6 +959,10 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 24 2019 Richard W.M. Jones <rjones@redhat.com> - 1.11.2-1
|
||||||
|
- New upstream version 1.11.2.
|
||||||
|
- Drop patches included in upstream tarball.
|
||||||
|
|
||||||
* Thu Jan 24 2019 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.11.1-2
|
* Thu Jan 24 2019 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.11.1-2
|
||||||
- F-30: rebuild again against ruby26
|
- F-30: rebuild again against ruby26
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user