New upstream version 1.5.10.
Remove upstream patches.
This commit is contained in:
parent
f123f78660
commit
cdd1bda62e
@ -1,42 +0,0 @@
|
||||
From 5fe11d518d97a22668b5a42e6865b5b5a06958fb Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 26 Aug 2018 20:31:04 +0100
|
||||
Subject: [PATCH 1/2] tests: Fix comment describing largest size supported by
|
||||
qemu.
|
||||
|
||||
Fixes commit ce1aed4ee811c234795d3c1f272a03b4105bf7ec
|
||||
and commit 99136752e5de4d526df49051667311d87ff1e9a2.
|
||||
---
|
||||
tests/test-memory-largest-for-qemu.sh | 2 +-
|
||||
tests/test-pattern-largest-for-qemu.sh | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/test-memory-largest-for-qemu.sh b/tests/test-memory-largest-for-qemu.sh
|
||||
index e85abad..9bc498d 100755
|
||||
--- a/tests/test-memory-largest-for-qemu.sh
|
||||
+++ b/tests/test-memory-largest-for-qemu.sh
|
||||
@@ -46,7 +46,7 @@ if ! qemu-io --help >/dev/null; then
|
||||
fi
|
||||
|
||||
# Run nbdkit with memory plugin.
|
||||
-# size = (2^63-1) & 511 which is the largest supported by qemu.
|
||||
+# size = (2^63-1) & ~511 which is the largest supported by qemu.
|
||||
nbdkit -f -v -D memory.dir=1 \
|
||||
-P memory-largest-for-qemu.pid -U memory-largest-for-qemu.sock \
|
||||
memory size=9223372036854775296 &
|
||||
diff --git a/tests/test-pattern-largest-for-qemu.sh b/tests/test-pattern-largest-for-qemu.sh
|
||||
index ae1ba71..cf70354 100755
|
||||
--- a/tests/test-pattern-largest-for-qemu.sh
|
||||
+++ b/tests/test-pattern-largest-for-qemu.sh
|
||||
@@ -46,7 +46,7 @@ if ! qemu-io --help >/dev/null; then
|
||||
fi
|
||||
|
||||
# Run nbdkit with pattern plugin.
|
||||
-# size = (2^63-1) & 511 which is the largest supported by qemu.
|
||||
+# size = (2^63-1) & ~511 which is the largest supported by qemu.
|
||||
nbdkit -P pattern-largest-for-qemu.pid -U pattern-largest-for-qemu.sock \
|
||||
pattern size=9223372036854775296
|
||||
|
||||
--
|
||||
2.18.0
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 5de18b3764e86414325bbfdb6dc297462598072f Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 26 Aug 2018 20:46:52 +0100
|
||||
Subject: [PATCH 2/2] memory: Fix parsing of size= parameter on 32 bit
|
||||
platforms.
|
||||
|
||||
---
|
||||
plugins/memory/memory.c | 11 ++---------
|
||||
1 file changed, 2 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/plugins/memory/memory.c b/plugins/memory/memory.c
|
||||
index 0b7fced..f175792 100644
|
||||
--- a/plugins/memory/memory.c
|
||||
+++ b/plugins/memory/memory.c
|
||||
@@ -272,17 +272,10 @@ memory_unload (void)
|
||||
static int
|
||||
memory_config (const char *key, const char *value)
|
||||
{
|
||||
- int64_t r;
|
||||
-
|
||||
if (strcmp (key, "size") == 0) {
|
||||
- r = nbdkit_parse_size (value);
|
||||
- if (r == -1)
|
||||
+ size = nbdkit_parse_size (value);
|
||||
+ if (size == -1)
|
||||
return -1;
|
||||
- if (r > SIZE_MAX) {
|
||||
- nbdkit_error ("size > SIZE_MAX");
|
||||
- return -1;
|
||||
- }
|
||||
- size = (ssize_t) r;
|
||||
}
|
||||
else {
|
||||
nbdkit_error ("unknown parameter '%s'", key);
|
||||
--
|
||||
2.18.0
|
||||
|
12
nbdkit.spec
12
nbdkit.spec
@ -31,8 +31,8 @@
|
||||
%global source_directory 1.5-development
|
||||
|
||||
Name: nbdkit
|
||||
Version: 1.5.9
|
||||
Release: 2%{?dist}
|
||||
Version: 1.5.10
|
||||
Release: 1%{?dist}
|
||||
Summary: NBD server
|
||||
|
||||
License: BSD
|
||||
@ -45,10 +45,6 @@ Source1: http://libguestfs.org/download/nbdkit/%{source_directory}/%{name
|
||||
Source2: libguestfs.keyring
|
||||
%endif
|
||||
|
||||
# All upstream patches since 1.5.9 was released.
|
||||
Patch1: 0001-tests-Fix-comment-describing-largest-size-supported-.patch
|
||||
Patch2: 0002-memory-Fix-parsing-of-size-parameter-on-32-bit-platf.patch
|
||||
|
||||
%if 0%{patches_touch_autotools}
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
%endif
|
||||
@ -954,6 +950,10 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 27 2018 Richard W.M. Jones <rjones@redhat.com> - 1.5.10-1
|
||||
- New upstream version 1.5.10.
|
||||
- Remove upstream patches.
|
||||
|
||||
* Sun Aug 26 2018 Richard W.M. Jones <rjones@redhat.com> - 1.5.9-2
|
||||
- New upstream version 1.5.9.
|
||||
- Add upstream patches since 1.5.9 was released.
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (nbdkit-1.5.9.tar.gz) = 3142fd69d203e0c9caff64089a27ad20af03e8782c4af5477aea4f844158d27a74d538e83993cc4abbab48a41da72655c5cd8a07f9d06fde01665cf4714f00b9
|
||||
SHA512 (nbdkit-1.5.9.tar.gz.sig) = 6d103a7ad91441ba0aaf116e52c51caf339c5173ffa75b8b750d7fb0d030f248a36bb7c68876a7d795cc75c0d842337575cce383fc829167a8ec644aa32ada9d
|
||||
SHA512 (nbdkit-1.5.10.tar.gz) = 342a9d2e0f91b31767a2d522237054a238bd903b8c49f3ccc6f7652d9a011395ca874adfb9ebda9cc150b62d9293f16d67b7d116d0cc7bcf7835608e0289737f
|
||||
SHA512 (nbdkit-1.5.10.tar.gz.sig) = 3af2258227c16b78c3ffeb8ab915f7f21a2dc43577fa2199403a412901be210776815a8c5a9b0f9eea5becdad1c95de8453def764c40edab07d9856c1a43cac4
|
||||
|
Loading…
Reference in New Issue
Block a user