Rebase to 1.38.5 (along stable branch)

This commit is contained in:
Richard W.M. Jones 2024-09-28 09:48:38 +01:00
parent 6dcd8b25aa
commit a8a97713f1
9 changed files with 19 additions and 63 deletions

View File

@ -1,46 +0,0 @@
From 14a2646d4221d50b4b194d5dd2d6010808ea642b Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sun, 14 Jul 2024 09:50:31 +0100
Subject: [PATCH] nbdkit 1.38: Fix inclusion of <gnutls/socket.h> with old
gnutls
Development branch commit 8ce65bac5a ("build: Move to minimum gnutls
>= 3.5.18") changed the way that <gnutls/socket.h> is included. I
didn't cherry pick this commit to the stable-1.38 branch since we
don't want to force people to update gnutls.
However when I cherry picked commit 47987e43bd ("server/crypto.c:
Check <gnutls/socket.h> works before including it"), I missed that
there was still a place where <gnutls/socket.h> was included (which
would have been fixed by the commit above).
The upshot is that compilation of nbdkit 1.38.3 fails on mingw:
In file included from ../../server/crypto.c:69:
/usr/i686-w64-mingw32/sys-root/mingw/include/gnutls/socket.h:32:10: fatal error: sys/socket.h: No such file or directory
32 | #include <sys/socket.h>
| ^~~~~~~~~~~~~~
compilation terminated.
Fixes: commit f889d822dd96bcf8c0427bd541d730d58b166d83
---
server/crypto.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/server/crypto.c b/server/crypto.c
index 83970282..86843192 100644
--- a/server/crypto.c
+++ b/server/crypto.c
@@ -65,9 +65,6 @@
#else
#define TRY_KTLS 0
#endif
-#if TRY_KTLS
-#include <gnutls/socket.h>
-#endif
static int crypto_auth;
#define CRYPTO_AUTH_CERTIFICATES 1
--
2.43.0

View File

@ -1,4 +1,4 @@
From f39c63a79ffb888bd565eb49b0ee2590fad8fbb9 Mon Sep 17 00:00:00 2001
From e97b5ec6e7e7406688f68a5828e66ef46046fd9f Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 23 Jul 2024 14:46:41 +0100
Subject: [PATCH] server: log: Move preserve errno to log_verror function

View File

@ -1,4 +1,4 @@
From 179227c7d6b0677dcd1dced55881e0d024745424 Mon Sep 17 00:00:00 2001
From ae28c97079cce7792c5954f67a418402a48ed0cf Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 24 Jul 2024 10:29:13 +0100
Subject: [PATCH] server: Rename threadlocal_{set,get}_error to .._errno

View File

@ -1,4 +1,4 @@
From 334ab902477a0e1db4d70a5c809eafe49ab1fc6e Mon Sep 17 00:00:00 2001
From 00107f9d36fc6a1b33a1bde25e3239c520b82ab1 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 24 Jul 2024 10:37:58 +0100
Subject: [PATCH] server: Introduce threadlocal_{set,get}_last_error

View File

@ -1,4 +1,4 @@
From a0e3f9d58142b8c5e7bcc9b73da60778e6503d0b Mon Sep 17 00:00:00 2001
From 4cde9d78c4293e294f80376266cfce420f15a6ff Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 23 Jul 2024 15:28:06 +0100
Subject: [PATCH] server: Take a thread-local copy of the last call to

View File

@ -1,4 +1,4 @@
From 7128144273f5355d7705e09a99aa1b2359e7e823 Mon Sep 17 00:00:00 2001
From e121d8e1d39605043317cbdf28f60056e6681d56 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 23 Jul 2024 15:45:04 +0100
Subject: [PATCH] server: Send the last error to the NBD client
@ -92,7 +92,7 @@ index 6b3bc76f..c18d32e5 100644
/* Reply to NBD_OPT_LIST with the plugin's list of export names.
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0664e109..9c321fcb 100644
index b670fbf9..d510807c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -276,6 +276,7 @@ TESTS += \

View File

@ -6,7 +6,7 @@ set -e
# directory. Use it like this:
# ./copy-patches.sh
rhel_version=9.5
rhel_version=9.6
# Check we're in the right directory.
if [ ! -f nbdkit.spec ]; then

View File

@ -55,7 +55,7 @@
%global source_directory 1.38-stable
Name: nbdkit
Version: 1.38.3
Version: 1.38.5
Release: 1%{?dist}
Summary: NBD server
@ -78,15 +78,14 @@ Source2: libguestfs.keyring
Source3: copy-patches.sh
# Patches come from the upstream repository:
# https://gitlab.com/nbdkit/nbdkit/-/commits/rhel-9.5/
# https://gitlab.com/nbdkit/nbdkit/-/commits/rhel-9.6/
# Patches.
Patch0001: 0001-nbdkit-1.38-Fix-inclusion-of-gnutls-socket.h-with-ol.patch
Patch0002: 0002-server-log-Move-preserve-errno-to-log_verror-functio.patch
Patch0003: 0003-server-Rename-threadlocal_-set-get-_error-to-._errno.patch
Patch0004: 0004-server-Introduce-threadlocal_-set-get-_last_error.patch
Patch0005: 0005-server-Take-a-thread-local-copy-of-the-last-call-to-.patch
Patch0006: 0006-server-Send-the-last-error-to-the-NBD-client.patch
Patch0001: 0001-server-log-Move-preserve-errno-to-log_verror-functio.patch
Patch0002: 0002-server-Rename-threadlocal_-set-get-_error-to-._errno.patch
Patch0003: 0003-server-Introduce-threadlocal_-set-get-_last_error.patch
Patch0004: 0004-server-Take-a-thread-local-copy-of-the-last-call-to-.patch
Patch0005: 0005-server-Send-the-last-error-to-the-NBD-client.patch
# For automatic RPM Provides generation.
# See: https://rpm-software-management.github.io/rpm/manual/dependency_generators.html
@ -1505,6 +1504,9 @@ fi
%changelog
* Sat Sep 28 2024 Richard W.M. Jones <rjones@redhat.com> - 1.38.5-1
- Rebase to 1.38.5 (along stable branch)
* Fri Jul 26 2024 Richard W.M. Jones <rjones@redhat.com> - 1.38.3-1
- Rebase to 1.38.3 (along stable branch)
- Send the last error to the NBD client

View File

@ -1,2 +1,2 @@
SHA512 (nbdkit-1.38.3.tar.gz) = 573c16da6df8b9ce83dc29392758a080952e32c4680e44cb0b53f395741ab296917967a4f89d9e89b339c324726af201b52f1502e92e8012e02dd86c517e8983
SHA512 (nbdkit-1.38.3.tar.gz.sig) = 8b3a50620414ee0568d4be57b720082b57b28ae123611237226ce26bf0eaa7ef906c1237e0cb37d9ea5eb8a4eae5d6c8e9ccf757c4efbe51f42f6653737db186
SHA512 (nbdkit-1.38.5.tar.gz) = 86e3160e46f8a571e2d18378987066abb3365aea76db4610b478b7d29bf510f1114132a23c149e7a211920be42274606aa05a42e15576a97915582d07077bc4e
SHA512 (nbdkit-1.38.5.tar.gz.sig) = 3be02420dae81472892980ea35087c23838321766cbe3e2b77238fbd9a2be79538c8d92f1ee471c2ee9983b56f19e59385962e6bd79b5c9efc072f7e1c682c49