New upstream development version 1.17.4.
New filter: nofilter. Remove upstream patches.
This commit is contained in:
parent
7fc80c32df
commit
8187fd3c26
@ -1,73 +0,0 @@
|
||||
From 8e22f1e40510252aa329eb102a0e24b0f755c29e Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 10 Dec 2019 10:21:14 +0000
|
||||
Subject: [PATCH] tests: Fix test for IPv6 support.
|
||||
|
||||
Remove bogus existing tests, and add a new test that IPv6
|
||||
loopback is working through qemu-img.
|
||||
---
|
||||
tests/functions.sh.in | 18 ++++++++++++++++++
|
||||
tests/test-ip-filter.sh | 5 +----
|
||||
tests/test-ip.sh | 1 +
|
||||
3 files changed, 20 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/tests/functions.sh.in b/tests/functions.sh.in
|
||||
index 9a19167..e62fb51 100644
|
||||
--- a/tests/functions.sh.in
|
||||
+++ b/tests/functions.sh.in
|
||||
@@ -71,6 +71,24 @@ requires ()
|
||||
}
|
||||
}
|
||||
|
||||
+# qemu cannot connect to ::1 if IPv6 is disabled because of
|
||||
+# the way it uses getaddrinfo. See:
|
||||
+# https://bugzilla.redhat.com/show_bug.cgi?id=808147
|
||||
+# https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/SXDLSZ3GKXL6NDAKP4MPJ25IMHKN67X3/
|
||||
+requires_ipv6_loopback ()
|
||||
+{
|
||||
+ requires qemu-img --version
|
||||
+
|
||||
+ # This should fail with "Connection refused". If IPv6 is broken
|
||||
+ # then it fails with "Address family for hostname not supported"
|
||||
+ # instead. It's very unlikely that port 1 is open.
|
||||
+ if LANG=C qemu-img info "nbd:[::1]:1" |& \
|
||||
+ grep -sq "Address family for hostname not supported"; then
|
||||
+ echo "$0: IPv6 loopback is not available, skipping this test"
|
||||
+ exit 77
|
||||
+ fi
|
||||
+}
|
||||
+
|
||||
# start_nbdkit -P pidfile args...
|
||||
#
|
||||
# Run nbdkit with args and wait for it to start up. If it fails to
|
||||
diff --git a/tests/test-ip-filter.sh b/tests/test-ip-filter.sh
|
||||
index 31aad88..a3100a4 100755
|
||||
--- a/tests/test-ip-filter.sh
|
||||
+++ b/tests/test-ip-filter.sh
|
||||
@@ -38,10 +38,7 @@ set -e
|
||||
|
||||
requires ip -V
|
||||
requires qemu-img --version
|
||||
-
|
||||
-# Check we have IPv4 and IPv6, skip the test otherwise.
|
||||
-requires ip -o -4 addr show scope host
|
||||
-requires ip -o -6 addr show scope host
|
||||
+requires_ipv6_loopback
|
||||
|
||||
rm -f ip-filter.pid
|
||||
cleanup_fn rm -f ip-filter.pid
|
||||
diff --git a/tests/test-ip.sh b/tests/test-ip.sh
|
||||
index a0f1862..61675c2 100755
|
||||
--- a/tests/test-ip.sh
|
||||
+++ b/tests/test-ip.sh
|
||||
@@ -39,6 +39,7 @@ set -e
|
||||
requires ip -V
|
||||
requires qemu-img --version
|
||||
requires qemu-img info --image-opts driver=file,filename=functions.sh
|
||||
+requires_ipv6_loopback
|
||||
|
||||
rm -f ip.pid ipv4.out ipv6.out
|
||||
cleanup_fn rm -f ip.pid ipv4.out ipv6.out
|
||||
--
|
||||
2.23.0
|
||||
|
13
nbdkit.spec
13
nbdkit.spec
@ -51,9 +51,6 @@ Source1: http://libguestfs.org/download/nbdkit/%{source_directory}/%{name
|
||||
Source2: libguestfs.keyring
|
||||
%endif
|
||||
|
||||
# Upstream patch to fix IPv6 support in tests.
|
||||
Patch1: 0001-tests-Fix-test-for-IPv6-support.patch
|
||||
|
||||
%if 0%{patches_touch_autotools}
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
%endif
|
||||
@ -458,6 +455,7 @@ Provides: %{name}-ip-filter = %{version}-%{release}
|
||||
Provides: %{name}-log-filter = %{version}-%{release}
|
||||
Provides: %{name}-nocache-filter = %{version}-%{release}
|
||||
Provides: %{name}-noextents-filter = %{version}-%{release}
|
||||
Provides: %{name}-nofilter-filter = %{version}-%{release}
|
||||
Provides: %{name}-noparallel-filter = %{version}-%{release}
|
||||
Provides: %{name}-nozero-filter = %{version}-%{release}
|
||||
Provides: %{name}-offset-filter = %{version}-%{release}
|
||||
@ -495,6 +493,8 @@ nbdkit-nocache-filter Disable cache requests in the underlying plugin.
|
||||
|
||||
nbdkit-noextents-filter Disable extents in the underlying plugin.
|
||||
|
||||
nbdkit-nofilter-filter Passthrough filter.
|
||||
|
||||
nbdkit-noparallel-filter Serialize requests to the underlying plugin.
|
||||
|
||||
nbdkit-nozero-filter Adjust handling of zero requests by plugins.
|
||||
@ -842,6 +842,7 @@ make %{?_smp_mflags} check || {
|
||||
%{_libdir}/%{name}/filters/nbdkit-log-filter.so
|
||||
%{_libdir}/%{name}/filters/nbdkit-nocache-filter.so
|
||||
%{_libdir}/%{name}/filters/nbdkit-noextents-filter.so
|
||||
%{_libdir}/%{name}/filters/nbdkit-nofilter-filter.so
|
||||
%{_libdir}/%{name}/filters/nbdkit-noparallel-filter.so
|
||||
%{_libdir}/%{name}/filters/nbdkit-nozero-filter.so
|
||||
%{_libdir}/%{name}/filters/nbdkit-offset-filter.so
|
||||
@ -862,6 +863,7 @@ make %{?_smp_mflags} check || {
|
||||
%{_mandir}/man1/nbdkit-log-filter.1*
|
||||
%{_mandir}/man1/nbdkit-nocache-filter.1*
|
||||
%{_mandir}/man1/nbdkit-noextents-filter.1*
|
||||
%{_mandir}/man1/nbdkit-nofilter-filter.1*
|
||||
%{_mandir}/man1/nbdkit-noparallel-filter.1*
|
||||
%{_mandir}/man1/nbdkit-nozero-filter.1*
|
||||
%{_mandir}/man1/nbdkit-offset-filter.1*
|
||||
@ -913,6 +915,11 @@ make %{?_smp_mflags} check || {
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Dec 13 2019 Richard W.M. Jones <rjones@redhat.com> - 1.17.4-1
|
||||
- New upstream development version 1.17.4.
|
||||
- New filter: nofilter.
|
||||
- Remove upstream patches.
|
||||
|
||||
* Tue Dec 10 2019 Richard W.M. Jones <rjones@redhat.com> - 1.17.3-2
|
||||
- New upstream development version 1.17.3.
|
||||
- Add upstream patch to fix IPv6 support in tests.
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (nbdkit-1.17.3.tar.gz) = 87d0c35dd201d5e558bf9d3bfe3f937fb7360f5dc208ed43f0ed98e4690c52178bee01e97781359764c38224fad531a7cccc9565ed5e3c5fef7550c04db497cc
|
||||
SHA512 (nbdkit-1.17.3.tar.gz.sig) = 2db0f1756764b3587217e09fc71828e180d32ef43dc23441e4ca511ae473c7b8bc8993bf8c5f097182b2db9180e841669dd2df59f63f6a64b372b7e3e59179f2
|
||||
SHA512 (nbdkit-1.17.4.tar.gz) = 580cdfd4b28ee1d8e7b467b6d4d3e02f2c802667661f6c361407dc20f92f8b7f31fe4bc0f0e7a7bfc10122e43b5fcf2c8cab005c475c1f06e133165acce90af1
|
||||
SHA512 (nbdkit-1.17.4.tar.gz.sig) = 64bc6074f9f3cd2b16ed5aea999a8b1ff7baed0b74dc3c31892bbe09926b354fc70745c83d4c4e7ffb5689154101c1b9967553cf5a71032f5694bb3abfebc15b
|
||||
|
Loading…
Reference in New Issue
Block a user