Remove no longer needed patches from dist-git.

Fixes commit 6d9d5e1cc9.
This commit is contained in:
Richard W.M. Jones 2018-06-09 14:41:31 +01:00
parent ce21b0dd4b
commit 7d26a63592
2 changed files with 0 additions and 109 deletions

View File

@ -1,57 +0,0 @@
From 974f6aba15d71984b5f05dc8b5f10bb7a5cec082 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 6 Jun 2018 19:29:35 +0100
Subject: [PATCH 1/2] tests: Provide full path to Unix domain sockets.
See also this thread:
https://www.redhat.com/archives/libvir-list/2018-June/msg00490.html
---
tests/test-cache.sh | 3 ++-
tests/test-cow.sh | 3 ++-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/tests/test-cache.sh b/tests/test-cache.sh
index e5e9e82..c46e7be 100755
--- a/tests/test-cache.sh
+++ b/tests/test-cache.sh
@@ -32,6 +32,7 @@
# SUCH DAMAGE.
set -e
+set -x
files="cache.img cache.sock cache.pid"
rm -f $files
@@ -69,7 +70,7 @@ cleanup ()
trap cleanup INT QUIT TERM EXIT ERR
# Open the overlay and perform some operations.
-guestfish --format=raw -a 'nbd://?socket=cache.sock' <<'EOF'
+guestfish --format=raw -a "nbd://?socket=$PWD/cache.sock" <<'EOF'
run
part-disk /dev/sda gpt
mkfs ext4 /dev/sda1
diff --git a/tests/test-cow.sh b/tests/test-cow.sh
index 443ba38..01d2d04 100755
--- a/tests/test-cow.sh
+++ b/tests/test-cow.sh
@@ -32,6 +32,7 @@
# SUCH DAMAGE.
set -e
+set -x
files="cow-base.img cow-diff.qcow2 cow.sock cow.pid"
rm -f $files
@@ -70,7 +71,7 @@ cleanup ()
trap cleanup INT QUIT TERM EXIT ERR
# Write some data into the overlay.
-guestfish --format=raw -a 'nbd://?socket=cow.sock' -m /dev/sda1 <<EOF
+guestfish --format=raw -a "nbd://?socket=$PWD/cow.sock" -m /dev/sda1 <<EOF
fill-dir / 10000
fill-pattern "abcde" 5M /large
write /hello "hello, world"
--
2.16.2

View File

@ -1,52 +0,0 @@
From 013a3a96a102d1b1481a08b6d37bdf958d123985 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 6 Jun 2018 20:06:39 +0100
Subject: [PATCH 2/2] tests: xz: Use 16M block size when preparing disk for xz
plugin test.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
In a recent commit guestfish changed the default size for disk images
prepared using the -N parameter from 100M to 1G:
https://github.com/libguestfs/libguestfs/commit/adc23829e4b128562c2c29d984654528bd259644
For the xz plugin test we prepared a disk image using guestfish and
then xz-compressing the output, but we did not take our own advice and
use the --block-size parameter to limit the xz block size. Because of
the increased size of the disk as a whole, this pushed the block size
beyond the limit that the xz plugin can handle, and the test would
fail with:
nbdkit: error: /var/tmp/nbdkit-1.3.1/tests/disk.xz: xz file largest block is bigger than maxblock
Either recompress the xz file with smaller blocks (see nbdkit-xz-plugin(1))
or make maxblock parameter bigger.
maxblock = 536870912 (bytes)
largest block in xz file = 1073741824 (bytes)
Simple fix by adding the --block-size parameter.
Note that to see the effect of this change you will need to make
maintainer-clean or remove the files tests/disk and tests/disk.xz
by hand.
---
tests/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4582120..0cc2618 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -328,7 +328,7 @@ test_xz_LDADD = libtest.la $(LIBGUESTFS_LIBS)
disk.xz: disk
rm -f $@
- xz --best -c disk > $@
+ xz --best --block-size=16777216 -c disk > $@
endif HAVE_GUESTFISH
endif HAVE_LIBLZMA
--
2.16.2