New upstream development version 1.37.6
This commit is contained in:
parent
d89cffce88
commit
5f12965c1f
@ -1,24 +0,0 @@
|
||||
From 93a1538808ac7f9788336a7e35168d851e8b2c72 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 23 Jan 2024 13:24:48 +0000
|
||||
Subject: [PATCH 1/4] common/bitmaps: Fix tests when srcdir != builddir
|
||||
|
||||
---
|
||||
common/bitmap/Makefile.am | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/common/bitmap/Makefile.am b/common/bitmap/Makefile.am
|
||||
index 3b7f4b44f..93ca1ee43 100644
|
||||
--- a/common/bitmap/Makefile.am
|
||||
+++ b/common/bitmap/Makefile.am
|
||||
@@ -52,6 +52,7 @@ check_PROGRAMS = test-bitmap
|
||||
test_bitmap_SOURCES = test-bitmap.c bitmap.c bitmap.h
|
||||
test_bitmap_CPPFLAGS = \
|
||||
-I$(top_srcdir)/include \
|
||||
+ -I$(top_builddir)/include \
|
||||
-I$(top_srcdir)/common/include \
|
||||
$(NULL)
|
||||
test_bitmap_CFLAGS = $(WARNINGS_CFLAGS)
|
||||
--
|
||||
2.43.0
|
||||
|
@ -1,284 +0,0 @@
|
||||
From ac60163ceba1b951e1d2f0625552e6a45d85f666 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 23 Jan 2024 13:35:02 +0000
|
||||
Subject: [PATCH 2/4] tests: Fix tests to work with srcdir != builddir
|
||||
|
||||
---
|
||||
tests/test-cc-cpp.sh | 2 +-
|
||||
tests/test-cc-ocaml.sh | 2 +-
|
||||
tests/test-cc.sh | 2 +-
|
||||
tests/test-curl-header-script-fail.sh | 2 +-
|
||||
tests/test-linuxdisk-copy-out.sh | 4 ++--
|
||||
tests/test-multi-conn-name.sh | 6 ++++--
|
||||
tests/test-multi-conn.sh | 20 +++++++++++---------
|
||||
tests/test-plugin-docs.sh | 2 +-
|
||||
tests/test-shebang-cc.sh | 3 +++
|
||||
tests/test-tar.sh | 2 +-
|
||||
tests/cc-shebang.c | 4 +++-
|
||||
tests/test-read-password-plugin.c | 4 +++-
|
||||
12 files changed, 32 insertions(+), 21 deletions(-)
|
||||
|
||||
diff --git a/tests/test-cc-cpp.sh b/tests/test-cc-cpp.sh
|
||||
index ebbdab31d..dd9bf58d8 100755
|
||||
--- a/tests/test-cc-cpp.sh
|
||||
+++ b/tests/test-cc-cpp.sh
|
||||
@@ -55,6 +55,6 @@ rm -f $out
|
||||
|
||||
nbdkit cc $script \
|
||||
CC="$CXX" \
|
||||
- EXTRA_CFLAGS="-I$abs_top_srcdir/include" \
|
||||
+ EXTRA_CFLAGS="-I$abs_top_srcdir/include -I../include" \
|
||||
--run 'nbdinfo --size $uri' > $out
|
||||
test "$(cat $out)" -eq $((100 * 1024 * 1024))
|
||||
diff --git a/tests/test-cc-ocaml.sh b/tests/test-cc-ocaml.sh
|
||||
index 68972fce0..79eb678df 100755
|
||||
--- a/tests/test-cc-ocaml.sh
|
||||
+++ b/tests/test-cc-ocaml.sh
|
||||
@@ -57,6 +57,6 @@ cleanup_fn rm -f $out
|
||||
rm -f $out
|
||||
|
||||
nbdkit -v cc $script a=1 b=2 c=3 d=4 \
|
||||
- CC="$OCAMLOPT" CFLAGS="-output-obj -runtime-variant _pic -I $abs_top_srcdir/plugins/ocaml $OCAML_PLUGIN_LIBRARIES NBDKit.cmx -cclib -L../plugins/ocaml/.libs -cclib -lnbdkitocaml" \
|
||||
+ CC="$OCAMLOPT" CFLAGS="-output-obj -runtime-variant _pic -I $abs_top_srcdir/plugins/ocaml -I ../plugins/ocaml $OCAML_PLUGIN_LIBRARIES NBDKit.cmx -cclib -L../plugins/ocaml/.libs -cclib -lnbdkitocaml" \
|
||||
--run 'nbdinfo --size $uri' > $out
|
||||
test "$(cat $out)" -eq $((512 * 2048))
|
||||
diff --git a/tests/test-cc.sh b/tests/test-cc.sh
|
||||
index 2646704be..5c1db8b96 100755
|
||||
--- a/tests/test-cc.sh
|
||||
+++ b/tests/test-cc.sh
|
||||
@@ -53,6 +53,6 @@ cleanup_fn rm -f $out
|
||||
rm -f $out
|
||||
|
||||
nbdkit cc $script \
|
||||
- EXTRA_CFLAGS="-I$abs_top_srcdir/include" \
|
||||
+ EXTRA_CFLAGS="-I$abs_top_srcdir/include -I../include" \
|
||||
--run 'nbdinfo --size $uri' > $out
|
||||
test "$(cat $out)" -eq $((100 * 1024 * 1024))
|
||||
diff --git a/tests/test-curl-header-script-fail.sh b/tests/test-curl-header-script-fail.sh
|
||||
index cf9614f96..282e0ddf0 100755
|
||||
--- a/tests/test-curl-header-script-fail.sh
|
||||
+++ b/tests/test-curl-header-script-fail.sh
|
||||
@@ -50,7 +50,7 @@ cleanup_fn rm -f $errors
|
||||
# This command is expected to fail.
|
||||
nbdkit -rfv \
|
||||
curl file:$PWD/disk protocols=file \
|
||||
- header-script=$PWD/test-curl-header-script-fail.script \
|
||||
+ header-script=$abs_top_srcdir/tests/test-curl-header-script-fail.script \
|
||||
--run 'nbdinfo --no-content $uri' >$errors 2>&1 ||:
|
||||
|
||||
cat $errors
|
||||
diff --git a/tests/test-linuxdisk-copy-out.sh b/tests/test-linuxdisk-copy-out.sh
|
||||
index 8c2f44bad..81b5b7439 100755
|
||||
--- a/tests/test-linuxdisk-copy-out.sh
|
||||
+++ b/tests/test-linuxdisk-copy-out.sh
|
||||
@@ -65,14 +65,14 @@ guestfish --ro -a linuxdisk-copy-out.img -m /dev/sda <<EOF
|
||||
tar-out / - | cat >/dev/null
|
||||
|
||||
# Download some files and compare to local copies.
|
||||
- download /Makefile linuxdisk-copy-out.test1
|
||||
+ download /virtual-disk.c linuxdisk-copy-out.test1
|
||||
download /Makefile.am linuxdisk-copy-out.test2
|
||||
download /nbdkit-linuxdisk-plugin.pod linuxdisk-copy-out.test3
|
||||
download /filesystem.c linuxdisk-copy-out.test4
|
||||
EOF
|
||||
|
||||
# Compare downloaded files to local versions.
|
||||
-cmp linuxdisk-copy-out.test1 $srcdir/../plugins/linuxdisk/Makefile
|
||||
+cmp linuxdisk-copy-out.test1 $srcdir/../plugins/linuxdisk/virtual-disk.c
|
||||
cmp linuxdisk-copy-out.test2 $srcdir/../plugins/linuxdisk/Makefile.am
|
||||
cmp linuxdisk-copy-out.test3 $srcdir/../plugins/linuxdisk/nbdkit-linuxdisk-plugin.pod
|
||||
cmp linuxdisk-copy-out.test4 $srcdir/../plugins/linuxdisk/filesystem.c
|
||||
diff --git a/tests/test-multi-conn-name.sh b/tests/test-multi-conn-name.sh
|
||||
index 6a180db72..2d2072925 100755
|
||||
--- a/tests/test-multi-conn-name.sh
|
||||
+++ b/tests/test-multi-conn-name.sh
|
||||
@@ -42,6 +42,8 @@ requires_nbdsh_uri
|
||||
requires nbdsh -c 'print(h.set_opt_mode)'
|
||||
requires dd iflag=count_bytes </dev/null
|
||||
|
||||
+plugin=$srcdir/../tests/test-multi-conn-plugin.sh
|
||||
+
|
||||
files="test-multi-conn-name.out"
|
||||
rm -f $files
|
||||
cleanup_fn rm -f $files
|
||||
@@ -69,7 +71,7 @@ print(bytes(h["b1"].pread(1, 0)))
|
||||
'
|
||||
|
||||
# Without the knob we flush all exports
|
||||
-nbdkit -vf sh test-multi-conn-plugin.sh --filter=multi-conn \
|
||||
+nbdkit -vf sh $plugin --filter=multi-conn \
|
||||
--run 'export uri; nbdsh -c "$script"' > test-multi-conn-name.out || fail=1
|
||||
diff -u <(cat <<\EOF
|
||||
b'A'
|
||||
@@ -77,7 +79,7 @@ b'B'
|
||||
EOF
|
||||
) test-multi-conn-name.out || fail=1
|
||||
# But with the knob, our flush is specific to the correct export
|
||||
-nbdkit -vf sh test-multi-conn-plugin.sh --filter=multi-conn \
|
||||
+nbdkit -vf sh $plugin --filter=multi-conn \
|
||||
multi-conn-exportname=true \
|
||||
--run 'export uri; nbdsh -c "$script"' > test-multi-conn-name.out || fail=1
|
||||
diff -u <(cat <<\EOF
|
||||
diff --git a/tests/test-multi-conn.sh b/tests/test-multi-conn.sh
|
||||
index 3383cd246..eec225c2a 100755
|
||||
--- a/tests/test-multi-conn.sh
|
||||
+++ b/tests/test-multi-conn.sh
|
||||
@@ -41,6 +41,8 @@ requires_plugin sh
|
||||
requires_nbdsh_uri
|
||||
requires dd iflag=count_bytes </dev/null
|
||||
|
||||
+plugin=$srcdir/../tests/test-multi-conn-plugin.sh
|
||||
+
|
||||
files="test-multi-conn.out test-multi-conn.stat"
|
||||
rm -f $files
|
||||
cleanup_fn rm -f $files
|
||||
@@ -63,7 +65,7 @@ print(h[0].can_multi_conn())
|
||||
|
||||
# Demonstrate the caching present without use of filter
|
||||
for filter in '' '--filter=multi-conn multi-conn-mode=plugin'; do
|
||||
- nbdkit -vf sh test-multi-conn-plugin.sh $filter \
|
||||
+ nbdkit -vf sh $plugin $filter \
|
||||
--run 'handles=4 nbdsh -c "$preamble" -c "
|
||||
# Without flush, reads cache, and writes do not affect persistent data
|
||||
print(bytes(h[0].pread(4, 0)))
|
||||
@@ -109,7 +111,7 @@ done
|
||||
|
||||
# Demonstrate specifics of FUA flag
|
||||
for filter in '' '--filter=multi-conn multi-conn-mode=plugin'; do
|
||||
- nbdkit -vf sh test-multi-conn-plugin.sh $filter \
|
||||
+ nbdkit -vf sh $plugin $filter \
|
||||
--run 'nbdsh -c "$preamble" -c "
|
||||
# Some servers let FUA flush all outstanding requests
|
||||
h[0].pwrite(b'\''hello '\'', 0)
|
||||
@@ -123,7 +125,7 @@ EOF
|
||||
) test-multi-conn.out || fail=1
|
||||
done
|
||||
for filter in '' '--filter=multi-conn multi-conn-mode=plugin'; do
|
||||
- nbdkit -vf sh test-multi-conn-plugin.sh strictfua=1 $filter \
|
||||
+ nbdkit -vf sh $plugin strictfua=1 $filter \
|
||||
--run 'nbdsh -c "$preamble" -c "
|
||||
# But it is also compliant for a server that only flushes the exact request
|
||||
h[0].pwrite(b'\''hello '\'', 0)
|
||||
@@ -155,7 +157,7 @@ done
|
||||
# mode is also able to supply multi-conn by a different technique.
|
||||
for filter in '--filter=multi-conn' 'strictfua=1 --filter=multi-conn' \
|
||||
'--filter=multi-conn multi-conn-mode=plugin --filter=cache' ; do
|
||||
- nbdkit -vf sh test-multi-conn-plugin.sh $filter \
|
||||
+ nbdkit -vf sh $plugin $filter \
|
||||
--run 'nbdsh -c "$preamble" -c "
|
||||
# FUA writes are immediately visible on all connections
|
||||
h[0].cache(12, 0)
|
||||
@@ -175,7 +177,7 @@ EOF
|
||||
done
|
||||
|
||||
# unsafe mode intentionally lacks consistency, use at your own risk
|
||||
-nbdkit -vf sh test-multi-conn-plugin.sh \
|
||||
+nbdkit -vf sh $plugin \
|
||||
--filter=multi-conn multi-conn-mode=unsafe \
|
||||
--run 'nbdsh -c "$preamble" -c "
|
||||
h[0].cache(12, 0)
|
||||
@@ -193,7 +195,7 @@ EOF
|
||||
) test-multi-conn.out || fail=1
|
||||
|
||||
# auto mode devolves to multi-conn disable when connections are serialized
|
||||
-nbdkit -vf sh test-multi-conn-plugin.sh --filter=noparallel \
|
||||
+nbdkit -vf sh $plugin --filter=noparallel \
|
||||
serialize=connections --filter=multi-conn --filter=cache \
|
||||
--run 'handles=1 nbdsh -c "$preamble"
|
||||
' > test-multi-conn.out || fail=1
|
||||
@@ -208,7 +210,7 @@ for level in off connection fast; do
|
||||
plugin 'plugin --filter=cache'; do
|
||||
echo "setup: $level $mode" >> test-multi-conn.stat
|
||||
# Flush with no activity
|
||||
- nbdkit -vf sh test-multi-conn-plugin.sh --filter=multi-conn \
|
||||
+ nbdkit -vf sh $plugin --filter=multi-conn \
|
||||
--filter=stats statsfile=test-multi-conn.stat statsappend=true \
|
||||
multi-conn-track-dirty=$level multi-conn-mode=$mode \
|
||||
--run 'nbdsh -c "$preamble" -c "
|
||||
@@ -217,7 +219,7 @@ h[0].pread(1, 0)
|
||||
h[0].flush()
|
||||
"' > test-multi-conn.out || fail=1
|
||||
# Client that flushes assuming multi-conn semantics
|
||||
- nbdkit -vf sh test-multi-conn-plugin.sh --filter=multi-conn \
|
||||
+ nbdkit -vf sh $plugin --filter=multi-conn \
|
||||
--filter=stats statsfile=test-multi-conn.stat statsappend=true \
|
||||
multi-conn-track-dirty=$level multi-conn-mode=$mode \
|
||||
--run 'handles=4 nbdsh -c "$preamble" -c "
|
||||
@@ -230,7 +232,7 @@ h[3].flush()
|
||||
h[3].flush()
|
||||
"' > test-multi-conn.out || fail=1
|
||||
# Client that flushes assuming inconsistent semantics
|
||||
- nbdkit -vf sh test-multi-conn-plugin.sh --filter=multi-conn \
|
||||
+ nbdkit -vf sh $plugin --filter=multi-conn \
|
||||
--filter=stats statsfile=test-multi-conn.stat statsappend=true \
|
||||
multi-conn-track-dirty=$level multi-conn-mode=$mode \
|
||||
--run 'nbdsh -c "$preamble" -c "
|
||||
diff --git a/tests/test-plugin-docs.sh b/tests/test-plugin-docs.sh
|
||||
index 772cfff07..e329035da 100755
|
||||
--- a/tests/test-plugin-docs.sh
|
||||
+++ b/tests/test-plugin-docs.sh
|
||||
@@ -59,7 +59,7 @@ run_test ()
|
||||
{
|
||||
plugin="$1"
|
||||
|
||||
- pod=../plugins/$plugin/nbdkit-$plugin-plugin.pod
|
||||
+ pod=$srcdir/../plugins/$plugin/nbdkit-$plugin-plugin.pod
|
||||
test -f "$pod"
|
||||
|
||||
# Get the key=value lines from the help output.
|
||||
diff --git a/tests/test-shebang-cc.sh b/tests/test-shebang-cc.sh
|
||||
index b25b789f7..674d0fcef 100755
|
||||
--- a/tests/test-shebang-cc.sh
|
||||
+++ b/tests/test-shebang-cc.sh
|
||||
@@ -45,6 +45,9 @@ requires_run
|
||||
requires_plugin cc
|
||||
requires guestfish --version
|
||||
|
||||
+# This variable is used by $script.
|
||||
+export abs_top_srcdir
|
||||
+
|
||||
$script -fv \
|
||||
EXTRA_CFLAGS="-I$abs_top_srcdir/include" \
|
||||
--run '
|
||||
diff --git a/tests/test-tar.sh b/tests/test-tar.sh
|
||||
index 9c9b3974f..d1a602b99 100755
|
||||
--- a/tests/test-tar.sh
|
||||
+++ b/tests/test-tar.sh
|
||||
@@ -45,7 +45,7 @@ cleanup_fn rm -f $files
|
||||
|
||||
# Create a tar file containing the disk image plus some other random
|
||||
# files that hopefully will be ignored.
|
||||
-tar cf tar.tar test-tar.sh Makefile disk Makefile.am
|
||||
+tar cf tar.tar Makefile disk functions.sh
|
||||
tar tvvf tar.tar
|
||||
|
||||
# Run nbdkit.
|
||||
diff --git a/tests/cc-shebang.c b/tests/cc-shebang.c
|
||||
index de2730f67..882fa2c1c 100755
|
||||
--- a/tests/cc-shebang.c
|
||||
+++ b/tests/cc-shebang.c
|
||||
@@ -1,5 +1,7 @@
|
||||
#if 0
|
||||
-exec nbdkit cc "$0" "$@"
|
||||
+exec nbdkit cc "$0" "$@" \
|
||||
+ EXTRA_CFLAGS="-I.. -I../include \
|
||||
+ -I$abs_top_srcdir/include"
|
||||
#endif
|
||||
#include <stdint.h>
|
||||
#include <string.h>
|
||||
diff --git a/tests/test-read-password-plugin.c b/tests/test-read-password-plugin.c
|
||||
index 3f0a95153..703fc724d 100755
|
||||
--- a/tests/test-read-password-plugin.c
|
||||
+++ b/tests/test-read-password-plugin.c
|
||||
@@ -1,5 +1,7 @@
|
||||
#if 0
|
||||
-exec nbdkit cc "$0" "$@" EXTRA_CFLAGS="-I.. -I$abs_top_srcdir/include"
|
||||
+exec nbdkit cc "$0" "$@" \
|
||||
+ EXTRA_CFLAGS="-I.. -I../include \
|
||||
+ -I$abs_top_srcdir/include"
|
||||
#endif
|
||||
/* nbdkit
|
||||
* Copyright Red Hat
|
||||
--
|
||||
2.43.0
|
||||
|
@ -1,48 +0,0 @@
|
||||
From 774465bb9e3444f23709deabeb39cc91490001a5 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 23 Jan 2024 18:08:12 +0000
|
||||
Subject: [PATCH 3/4] common/replacements/win32: Only build nbdkit-cat.mc
|
||||
derived files once
|
||||
|
||||
Previously parallel builds caused multiple instances of windmc to run.
|
||||
Use a stamp file to avoid this.
|
||||
---
|
||||
common/replacements/win32/Makefile.am | 9 +++++++--
|
||||
.gitignore | 1 +
|
||||
2 files changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/common/replacements/win32/Makefile.am b/common/replacements/win32/Makefile.am
|
||||
index 9b5a68db0..b8c7c639e 100644
|
||||
--- a/common/replacements/win32/Makefile.am
|
||||
+++ b/common/replacements/win32/Makefile.am
|
||||
@@ -38,8 +38,13 @@ if IS_WINDOWS
|
||||
# Build the message catalog.
|
||||
noinst_DATA = MSG00001.bin nbdkit-cat.h nbdkit-cat.rc
|
||||
|
||||
-$(noinst_DATA): nbdkit-cat.mc
|
||||
- rm -f $@
|
||||
+CLEANFILES += stamp-data
|
||||
+
|
||||
+$(noinst_DATA): stamp-data
|
||||
+
|
||||
+stamp-data: nbdkit-cat.mc
|
||||
+ rm -f $@ $(noinst_DATA)
|
||||
$(MC) $<
|
||||
+ touch $@
|
||||
|
||||
endif
|
||||
diff --git a/.gitignore b/.gitignore
|
||||
index 04fdcd723..14f816c93 100644
|
||||
--- a/.gitignore
|
||||
+++ b/.gitignore
|
||||
@@ -55,6 +55,7 @@ plugins/*/*.3
|
||||
/common/replacements/win32/MSG00001.bin
|
||||
/common/replacements/win32/nbdkit-cat.h
|
||||
/common/replacements/win32/nbdkit-cat.rc
|
||||
+/common/replacements/win32/stamp-data
|
||||
/common/utils/test-quotes
|
||||
/common/utils/test-vector
|
||||
/common/utils/windows-errors.c
|
||||
--
|
||||
2.43.0
|
||||
|
@ -1,192 +0,0 @@
|
||||
From 617f950de1d18d5ddd146c32d700afd81470a284 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Wed, 24 Jan 2024 10:46:26 +0000
|
||||
Subject: [PATCH 4/4] common/replacements/win32: Make windmc tool optional
|
||||
|
||||
Make the windmc (mc.exe) tool option even on Windows.
|
||||
|
||||
Distribute the generated message catalogs, but regenerate them if
|
||||
windmc is found at compile time.
|
||||
|
||||
I also changed mc -> mc.exe since "mc" on Linux is a program called
|
||||
Midnight Commander and mc.exe would only be the name when compiling on
|
||||
Windows. (If there's any confusion here, you can always define the
|
||||
right binary to use by doing: ./configure MC=/path/to/mc.exe)
|
||||
---
|
||||
configure.ac | 10 ++--
|
||||
common/replacements/win32/Makefile.am | 13 +++--
|
||||
common/replacements/win32/nbdkit-cat.h | 68 ++++++++++++++++++++++++
|
||||
common/replacements/win32/MSG00001.bin | Bin 0 -> 28 bytes
|
||||
common/replacements/win32/nbdkit-cat.rc | 9 ++++
|
||||
.gitignore | 3 --
|
||||
6 files changed, 89 insertions(+), 14 deletions(-)
|
||||
create mode 100644 common/replacements/win32/nbdkit-cat.h
|
||||
create mode 100644 common/replacements/win32/MSG00001.bin
|
||||
create mode 100644 common/replacements/win32/nbdkit-cat.rc
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 08ba6287c..03c655638 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -584,13 +584,11 @@ AC_DEFINE_UNQUOTED([DIR_SEPARATOR_STR],["$DIR_SEPARATOR_STR"],
|
||||
[String that separates path elements.])
|
||||
AM_CONDITIONAL([IS_WINDOWS],[test "x$is_windows" = "xyes"])
|
||||
|
||||
+dnl Look for the mc/windmc utility (optional).
|
||||
+AC_CHECK_TOOLS([MC],[windmc mc.exe],[no])
|
||||
+AM_CONDITIONAL([HAVE_MC],[test "x$MC" != "xno"])
|
||||
+
|
||||
AS_IF([test "x$is_windows" = "xyes"],[
|
||||
- dnl For Windows, look for the mc/windmc utility.
|
||||
- dnl XXX Do we need to check for mc.exe as well?
|
||||
- AC_CHECK_TOOLS([MC],[windmc mc],[no])
|
||||
- AS_IF([test "x$MC" = "xno"],
|
||||
- [AC_MSG_ERROR([mc/windmc utility must be available when compiling for Windows])])
|
||||
-
|
||||
dnl On Windows look for dlltool.
|
||||
AC_CHECK_TOOLS([DLLTOOL],[dlltool],[no])
|
||||
AS_IF([test "x$DLLTOOL" = "xno"],
|
||||
diff --git a/common/replacements/win32/Makefile.am b/common/replacements/win32/Makefile.am
|
||||
index b8c7c639e..45dcd6ac2 100644
|
||||
--- a/common/replacements/win32/Makefile.am
|
||||
+++ b/common/replacements/win32/Makefile.am
|
||||
@@ -29,15 +29,18 @@
|
||||
# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
# SUCH DAMAGE.
|
||||
|
||||
+# The Windows message catalog.
|
||||
+
|
||||
include $(top_srcdir)/common-rules.mk
|
||||
|
||||
-EXTRA_DIST = nbdkit-cat.mc
|
||||
-
|
||||
-if IS_WINDOWS
|
||||
-
|
||||
-# Build the message catalog.
|
||||
noinst_DATA = MSG00001.bin nbdkit-cat.h nbdkit-cat.rc
|
||||
|
||||
+# We distribute the generated message catalog files to save people
|
||||
+# needing to install the windmc tool, but they are regenerated (below)
|
||||
+# if windmc is found at configure time.
|
||||
+EXTRA_DIST = nbdkit-cat.mc $(noinst_DATA)
|
||||
+
|
||||
+if HAVE_MC
|
||||
CLEANFILES += stamp-data
|
||||
|
||||
$(noinst_DATA): stamp-data
|
||||
diff --git a/common/replacements/win32/nbdkit-cat.h b/common/replacements/win32/nbdkit-cat.h
|
||||
new file mode 100644
|
||||
index 000000000..8081e453d
|
||||
--- /dev/null
|
||||
+++ b/common/replacements/win32/nbdkit-cat.h
|
||||
@@ -0,0 +1,68 @@
|
||||
+/* Do not edit this file manually.
|
||||
+ This file is autogenerated by windmc. */
|
||||
+
|
||||
+//
|
||||
+// The values are 32 bit layed out as follows:
|
||||
+//
|
||||
+// 3 3 2 2 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 1 1 1
|
||||
+// 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0
|
||||
+// +---+-+-+-----------------------+-------------------------------+
|
||||
+// |Sev|C|R| Facility | Code |
|
||||
+// +---+-+-+-----------------------+-------------------------------+
|
||||
+//
|
||||
+// where
|
||||
+//
|
||||
+// C - is the Customer code flag
|
||||
+//
|
||||
+// R - is a reserved bit
|
||||
+//
|
||||
+// Code - is the facility's status code
|
||||
+//
|
||||
+// Sev - is the severity code
|
||||
+//
|
||||
+// Success - 00
|
||||
+// Informational - 01
|
||||
+// Warning - 02
|
||||
+// Error - 03
|
||||
+//
|
||||
+// Facility - is the facility code
|
||||
+//
|
||||
+// System - 00ff
|
||||
+// Application - 0fff
|
||||
+//
|
||||
+
|
||||
+// nbdkit
|
||||
+// Copyright Red Hat
|
||||
+//
|
||||
+// Redistribution and use in source and binary forms, with or without
|
||||
+// modification, are permitted provided that the following conditions are
|
||||
+// met:
|
||||
+//
|
||||
+// * Redistributions of source code must retain the above copyright
|
||||
+// notice, this list of conditions and the following disclaimer.
|
||||
+//
|
||||
+// * Redistributions in binary form must reproduce the above copyright
|
||||
+// notice, this list of conditions and the following disclaimer in the
|
||||
+// documentation and/or other materials provided with the distribution.
|
||||
+//
|
||||
+// * Neither the name of Red Hat nor the names of its contributors may be
|
||||
+// used to endorse or promote products derived from this software without
|
||||
+// specific prior written permission.
|
||||
+//
|
||||
+// THIS SOFTWARE IS PROVIDED BY RED HAT AND CONTRIBUTORS ''AS IS'' AND
|
||||
+// ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
|
||||
+// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
|
||||
+// PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL RED HAT OR
|
||||
+// CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
+// SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
+// LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
|
||||
+// USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
|
||||
+// ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
|
||||
+// OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
|
||||
+// OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
+// SUCH DAMAGE.
|
||||
+//
|
||||
+// MessageId: NBDKIT_SYSLOG_ERROR
|
||||
+//
|
||||
+#define NBDKIT_SYSLOG_ERROR 0xc0000001
|
||||
+
|
||||
diff --git a/common/replacements/win32/MSG00001.bin b/common/replacements/win32/MSG00001.bin
|
||||
new file mode 100644
|
||||
index 0000000000000000000000000000000000000000..f642ff3a4079b4b8b3b60b9ecefebe7c136a404b
|
||||
GIT binary patch
|
||||
literal 28
|
||||
dcmZQ%U|?WmU^oE60zftokf+LE$iM|;0{|fO0s#O3
|
||||
|
||||
literal 0
|
||||
HcmV?d00001
|
||||
|
||||
diff --git a/common/replacements/win32/nbdkit-cat.rc b/common/replacements/win32/nbdkit-cat.rc
|
||||
new file mode 100644
|
||||
index 000000000..6f6ce3344
|
||||
--- /dev/null
|
||||
+++ b/common/replacements/win32/nbdkit-cat.rc
|
||||
@@ -0,0 +1,9 @@
|
||||
+/* Do not edit this file manually.
|
||||
+ This file is autogenerated by windmc. */
|
||||
+
|
||||
+
|
||||
+// Country: United States
|
||||
+// Language: English
|
||||
+#pragma code_page(1252)
|
||||
+LANGUAGE 0x9, 0x1
|
||||
+1 MESSAGETABLE "MSG00001.bin"
|
||||
diff --git a/.gitignore b/.gitignore
|
||||
index 14f816c93..cce2de79b 100644
|
||||
--- a/.gitignore
|
||||
+++ b/.gitignore
|
||||
@@ -52,9 +52,6 @@ plugins/*/*.3
|
||||
/common/protocol/protostrings.c
|
||||
/common/replacements/libcompat.a
|
||||
/common/replacements/test-current-dir-name
|
||||
-/common/replacements/win32/MSG00001.bin
|
||||
-/common/replacements/win32/nbdkit-cat.h
|
||||
-/common/replacements/win32/nbdkit-cat.rc
|
||||
/common/replacements/win32/stamp-data
|
||||
/common/utils/test-quotes
|
||||
/common/utils/test-vector
|
||||
--
|
||||
2.43.0
|
||||
|
14
nbdkit.spec
14
nbdkit.spec
@ -57,8 +57,8 @@
|
||||
%global source_directory 1.37-development
|
||||
|
||||
Name: nbdkit
|
||||
Version: 1.37.5
|
||||
Release: 3%{?dist}
|
||||
Version: 1.37.6
|
||||
Release: 1%{?dist}
|
||||
Summary: NBD server
|
||||
|
||||
License: BSD-3-Clause
|
||||
@ -89,13 +89,6 @@ Source6: %{modulename}.te
|
||||
Source7: %{modulename}.if
|
||||
Source8: %{modulename}.fc
|
||||
|
||||
# Upstream patches to fix srcdir != builddir
|
||||
Patch: 0001-common-bitmaps-Fix-tests-when-srcdir-builddir.patch
|
||||
Patch: 0002-tests-Fix-tests-to-work-with-srcdir-builddir.patch
|
||||
# Upstream patches to fix mingw builds
|
||||
Patch: 0003-common-replacements-win32-Only-build-nbdkit-cat.mc-d.patch
|
||||
Patch: 0004-common-replacements-win32-Make-windmc-tool-optional.patch
|
||||
|
||||
# For applying the patches:
|
||||
BuildRequires: git
|
||||
|
||||
@ -1478,6 +1471,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 01 2024 Richard W.M. Jones <rjones@redhat.com> - 1.37.6-1
|
||||
- New upstream development version 1.37.6
|
||||
|
||||
* Tue Jan 23 2024 Richard W.M. Jones <rjones@redhat.com> - 1.37.5-3
|
||||
- Add mingw{32,64}-nbdkit subpackages
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (nbdkit-1.37.5.tar.gz) = 7f246fe0665a30d04641c8181d408d50859bf96c251dceb37c797057f2c32316174e7d293d2090d3b9979ff28edf337cedf4f5305e901054eebe7b97a0804e67
|
||||
SHA512 (nbdkit-1.37.5.tar.gz.sig) = 78be5c0f05ef20d4a651416799faeec180a3c48aeea547bb174bebf1b87dadac927e99faf8dcfdb27998f1747c6f7519d96e8d6f895f448ff9120b74a8a3e121
|
||||
SHA512 (nbdkit-1.37.6.tar.gz) = 3f16d523a76b50db0cfdd48bb07271d0588d04807600ee6d5eebe8e91a96611f12fd8ab2ffce161f0334ed26c51a33053a7c2edbaed9610194445bbdc5e27280
|
||||
SHA512 (nbdkit-1.37.6.tar.gz.sig) = 894e73e55cefb7d71337f40300230dab3b32d938ca5d9f44b50a6f15d108e07e58537776c4faeab4ce9f1b3e2722cd319bb795695f9cf92d844ccd2fd8d75873
|
||||
|
Loading…
Reference in New Issue
Block a user