New upstream development version 1.35.12
This commit is contained in:
parent
bbec0865fb
commit
57aa128eb0
@ -1,37 +0,0 @@
|
||||
From 47aebc247e6553ffb593512b65296b4e2a8eac0a Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Wed, 30 Aug 2023 15:53:16 +0000
|
||||
Subject: [PATCH] partition: Byte-swap partition_entries_lba in test
|
||||
|
||||
Fixes: commit 7b9301a4c569456a4f96784229a2cd48e8957662
|
||||
Fixes: https://gitlab.com/nbdkit/nbdkit/-/merge_requests/38#note_1535695896
|
||||
---
|
||||
filters/partition/partition-gpt.c | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/filters/partition/partition-gpt.c b/filters/partition/partition-gpt.c
|
||||
index ea02e504c..80acddb44 100644
|
||||
--- a/filters/partition/partition-gpt.c
|
||||
+++ b/filters/partition/partition-gpt.c
|
||||
@@ -59,12 +59,12 @@ get_gpt_header (uint8_t *sector,
|
||||
* the header, rather than looking in the header to see what LBA
|
||||
* they actually start at. Let's at least check for that now.
|
||||
*/
|
||||
- if (header->partition_entries_lba != 2) {
|
||||
- nbdkit_error ("non-standard GPT layout: "
|
||||
- "partition entries are not adjacent to header");
|
||||
- return -1;
|
||||
- }
|
||||
- return 0;
|
||||
+ if (le64toh (header->partition_entries_lba) != 2) {
|
||||
+ nbdkit_error ("non-standard GPT layout: "
|
||||
+ "partition entries are not adjacent to header");
|
||||
+ return -1;
|
||||
+ }
|
||||
+ return 0;
|
||||
}
|
||||
|
||||
static void
|
||||
--
|
||||
2.41.0
|
||||
|
10
nbdkit.spec
10
nbdkit.spec
@ -59,8 +59,8 @@ ExclusiveArch: x86_64
|
||||
%global source_directory 1.35-development
|
||||
|
||||
Name: nbdkit
|
||||
Version: 1.35.11
|
||||
Release: 2%{?dist}
|
||||
Version: 1.35.12
|
||||
Release: 1%{?dist}
|
||||
Summary: NBD server
|
||||
|
||||
License: BSD-3-Clause
|
||||
@ -86,9 +86,6 @@ Source3: copy-patches.sh
|
||||
Source4: nbdkit.attr
|
||||
Source5: nbdkit-find-provides
|
||||
|
||||
# Upstream patch to fix partition filter on s390x
|
||||
Patch1: 0001-partition-Byte-swap-partition_entries_lba-in-test.patch
|
||||
|
||||
BuildRequires: make
|
||||
%if 0%{patches_touch_autotools}
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
@ -1253,6 +1250,9 @@ export LIBGUESTFS_TRACE=1
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Sep 08 2023 Richard W.M. Jones <rjones@redhat.com> - 1.35.12-1
|
||||
- New upstream development version 1.35.12
|
||||
|
||||
* Wed Aug 30 2023 Richard W.M. Jones <rjones@redhat.com> - 1.35.11-2
|
||||
- New upstream development version 1.35.11
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (nbdkit-1.35.11.tar.gz) = ab1db494592aa62fe3f9362e3fcfde74a246aa4e120bbebefb9ade6a5d81ae31080d8e3db09971b06f2a34400f1419f42750d5beddbba3b1802f124ab9a083da
|
||||
SHA512 (nbdkit-1.35.11.tar.gz.sig) = 7e6af76a90faa59e11101b4f567c2f943bf7c9e6241d29023142846fe65b76eb5ef555907bab591816bceaea0c0798c8d570b26b953f728c38f3eca7682a339e
|
||||
SHA512 (nbdkit-1.35.12.tar.gz) = 2c0beb53952d1c569c48be6fdb8457410821498fdf9fc33038b6b3ce90fd81015d7b1639bcc474aadaaec7520099dd2812b03f152112a3fd57ac77bf212311bf
|
||||
SHA512 (nbdkit-1.35.12.tar.gz.sig) = 2aa61b49200ecbb531d2004574378bb4bd663ac002c166750d554d7c3ac0c3fea29b657e78470cd6be34e07470168a369c199d701be7ab64fbb3c23be3088f17
|
||||
|
Loading…
Reference in New Issue
Block a user