New upstream development version 1.37.4
This commit is contained in:
parent
4a47463228
commit
0d1a9e2d82
@ -1,43 +0,0 @@
|
|||||||
From 32a9ee6650654469cd591a3ae26842c54f898392 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
||||||
Date: Mon, 4 Dec 2023 10:23:29 +0000
|
|
||||||
Subject: [PATCH] configure: Fix initialization from incompatible pointer type
|
|
||||||
|
|
||||||
With GCC 14:
|
|
||||||
|
|
||||||
configure:20816: checking if environ is declared in header files
|
|
||||||
configure:20833: gcc -c -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grec
|
|
||||||
ord-gcc-switches -pipe -Wall -Werror=format-security
|
|
||||||
-Werror=implicit-function-declaration -Werror=implicit-int
|
|
||||||
-Wp,-U_FORTIFY_SOURCE,-D_FORTIFY_SOURCE=3 -Wp,-D_GLIBCXX_ASSERTIONS
|
|
||||||
-specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong
|
|
||||||
-specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic
|
|
||||||
-fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection
|
|
||||||
-fno-omit-frame-pointer -mno-omit-leaf-frame-pointer conftest.c >&5
|
|
||||||
conftest.c: In function 'test':
|
|
||||||
conftest.c:62:22: error: initialization of 'const char **' from incompatible p
|
|
||||||
ointer type 'char **'
|
|
||||||
62 | const char **env = environ;
|
|
||||||
| ^~~~~~~
|
|
||||||
|
|
||||||
Thanks: Florian Weimer
|
|
||||||
---
|
|
||||||
configure.ac | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 602cdc5cb..e7d58dcc8 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -336,7 +336,7 @@ AC_LANG_SOURCE([[
|
|
||||||
static int
|
|
||||||
test (void)
|
|
||||||
{
|
|
||||||
- const char **env = environ;
|
|
||||||
+ char **env = environ;
|
|
||||||
return env ? 1 : 0; // this just forces env to be used
|
|
||||||
}
|
|
||||||
]])
|
|
||||||
--
|
|
||||||
2.43.0
|
|
||||||
|
|
12
nbdkit.spec
12
nbdkit.spec
@ -54,14 +54,14 @@ ExclusiveArch: x86_64
|
|||||||
%global verify_tarball_signature 1
|
%global verify_tarball_signature 1
|
||||||
|
|
||||||
# If there are patches which touch autotools files, set this to 1.
|
# If there are patches which touch autotools files, set this to 1.
|
||||||
%global patches_touch_autotools 1
|
%global patches_touch_autotools %{nil}
|
||||||
|
|
||||||
# The source directory.
|
# The source directory.
|
||||||
%global source_directory 1.37-development
|
%global source_directory 1.37-development
|
||||||
|
|
||||||
Name: nbdkit
|
Name: nbdkit
|
||||||
Version: 1.37.3
|
Version: 1.37.4
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: NBD server
|
Summary: NBD server
|
||||||
|
|
||||||
License: BSD-3-Clause
|
License: BSD-3-Clause
|
||||||
@ -92,9 +92,6 @@ Source6: %{modulename}.te
|
|||||||
Source7: %{modulename}.if
|
Source7: %{modulename}.if
|
||||||
Source8: %{modulename}.fc
|
Source8: %{modulename}.fc
|
||||||
|
|
||||||
# Upstream fix for GCC 14
|
|
||||||
Patch: 0001-configure-Fix-initialization-from-incompatible-point.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
%if 0%{patches_touch_autotools}
|
%if 0%{patches_touch_autotools}
|
||||||
BuildRequires: autoconf, automake, libtool
|
BuildRequires: autoconf, automake, libtool
|
||||||
@ -1329,6 +1326,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 19 2023 Richard W.M. Jones <rjones@redhat.com> - 1.37.4-1
|
||||||
|
- New upstream development version 1.37.4
|
||||||
|
|
||||||
* Mon Dec 18 2023 Richard W.M. Jones <rjones@redhat.com> - 1.37.3-4
|
* Mon Dec 18 2023 Richard W.M. Jones <rjones@redhat.com> - 1.37.3-4
|
||||||
- OCaml 5.1.1 + s390x code gen fix for Fedora 40
|
- OCaml 5.1.1 + s390x code gen fix for Fedora 40
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (nbdkit-1.37.3.tar.gz) = 6f3a78e24a93776623a3209cf4c2e4824c8ab78c761186d13964be7af06ffaab34a550d89be5ea297b1d25c81b3646e8ff2d42389d1b1a0281577fa5bf319445
|
SHA512 (nbdkit-1.37.4.tar.gz) = 6acc7afd7733744d8cfdaff6e76fc3184fc06369d70ee2aee9f4e2b8b42f01509a230ec65b7d7df5bfa31fe9008d3b879593f02a3a88bcb8d7958f0829ca1429
|
||||||
SHA512 (nbdkit-1.37.3.tar.gz.sig) = b1c833b46c0eb488dfc831f1b554c094dd63f1f8aad97eaa054c61579ed5262a674370e46ca21b4d3843d8f24c6d713c956842d7217bb7949097f58168a205c2
|
SHA512 (nbdkit-1.37.4.tar.gz.sig) = 1f0a0a2d38383d33b23ed32f3dd4301bb17a659113cc31f9f86c046b6b5e2c38cb439ed0abfad61ab0f33db11e50576593fc438cc464b3abd5c3eef5a6e60a89
|
||||||
|
Loading…
Reference in New Issue
Block a user