New upstream version.
- Enable now working OCaml plugin (requires OCaml >= 4.02.2).
This commit is contained in:
parent
e1c7016119
commit
0865b1bd63
@ -1,25 +0,0 @@
|
|||||||
From b40717749648b972585cba04b69dc398e1e8e9fd Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
||||||
Date: Tue, 14 Oct 2014 16:13:36 +0200
|
|
||||||
Subject: [PATCH] streaming: Update the buf pointer when doing partial writes.
|
|
||||||
|
|
||||||
This fixes commit 72070d1ba15a45ce06519074846a612b97a4e54f.
|
|
||||||
---
|
|
||||||
plugins/streaming/streaming.c | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/plugins/streaming/streaming.c b/plugins/streaming/streaming.c
|
|
||||||
index 619c452..2381e60 100644
|
|
||||||
--- a/plugins/streaming/streaming.c
|
|
||||||
+++ b/plugins/streaming/streaming.c
|
|
||||||
@@ -202,6 +202,7 @@ streaming_pwrite (void *handle, const void *buf,
|
|
||||||
errorstate = 1;
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
+ buf += r;
|
|
||||||
highestwrite += r;
|
|
||||||
count -= r;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.0.4
|
|
||||||
|
|
57
nbdkit.spec
57
nbdkit.spec
@ -5,16 +5,14 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: nbdkit
|
Name: nbdkit
|
||||||
Version: 1.1.9
|
Version: 1.1.10
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: NBD server
|
Summary: NBD server
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: https://github.com/libguestfs/nbdkit
|
URL: https://github.com/libguestfs/nbdkit
|
||||||
Source0: http://libguestfs.org/download/nbdkit/%{name}-%{version}.tar.gz
|
Source0: http://libguestfs.org/download/nbdkit/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
Patch1: 0001-streaming-Update-the-buf-pointer-when-doing-partial-.patch
|
|
||||||
|
|
||||||
BuildRequires: /usr/bin/pod2man
|
BuildRequires: /usr/bin/pod2man
|
||||||
%if 0%{?have_libguestfs}
|
%if 0%{?have_libguestfs}
|
||||||
BuildRequires: libguestfs-devel
|
BuildRequires: libguestfs-devel
|
||||||
@ -26,6 +24,11 @@ BuildRequires: libcurl-devel
|
|||||||
BuildRequires: perl-devel
|
BuildRequires: perl-devel
|
||||||
BuildRequires: perl(ExtUtils::Embed)
|
BuildRequires: perl(ExtUtils::Embed)
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
|
%ifarch %{ocaml_native_compiler}
|
||||||
|
# Requires OCaml 4.02.2 which contains fix for
|
||||||
|
# http://caml.inria.fr/mantis/view.php?id=6693
|
||||||
|
BuildRequires: ocaml >= 4.02.2
|
||||||
|
%endif
|
||||||
|
|
||||||
# For complicated reasons, this is required so that
|
# For complicated reasons, this is required so that
|
||||||
# /bin/kernel-install puts the kernel directly into /boot, instead of
|
# /bin/kernel-install puts the kernel directly into /boot, instead of
|
||||||
@ -126,6 +129,34 @@ libvirt guest disks readonly. It is implemented using the libvirt
|
|||||||
virDomainBlockPeek API.
|
virDomainBlockPeek API.
|
||||||
|
|
||||||
|
|
||||||
|
%ifarch %{ocaml_native_compiler}
|
||||||
|
%package plugin-ocaml
|
||||||
|
Summary: OCaml plugin for %{name}
|
||||||
|
License: BSD
|
||||||
|
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
|
||||||
|
%description plugin-ocaml
|
||||||
|
This package lets you run OCaml plugins for %{name}.
|
||||||
|
|
||||||
|
To compile OCaml plugins you will also need to install
|
||||||
|
%{name}-plugin-ocaml-devel.
|
||||||
|
|
||||||
|
|
||||||
|
%package plugin-ocaml-devel
|
||||||
|
Summary: OCaml development environment for %{name}
|
||||||
|
License: BSD
|
||||||
|
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: %{name}-plugin-ocaml%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
|
||||||
|
%description plugin-ocaml-devel
|
||||||
|
This package lets you write OCaml plugins for %{name}.
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%package plugin-perl
|
%package plugin-perl
|
||||||
Summary: Perl plugin for %{name}
|
Summary: Perl plugin for %{name}
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -186,8 +217,6 @@ plugins for %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Force immediate binding for hardened build for plugins.
|
# Force immediate binding for hardened build for plugins.
|
||||||
@ -269,6 +298,18 @@ make check
|
|||||||
%{_mandir}/man1/nbdkit-libvirt-plugin.1*
|
%{_mandir}/man1/nbdkit-libvirt-plugin.1*
|
||||||
|
|
||||||
|
|
||||||
|
%ifarch %{ocaml_native_compiler}
|
||||||
|
%files plugin-ocaml
|
||||||
|
%doc LICENSE README
|
||||||
|
%{_libdir}/libnbdkitocaml.so.*
|
||||||
|
|
||||||
|
%files plugin-ocaml-devel
|
||||||
|
%{_libdir}/libnbdkitocaml.so
|
||||||
|
%{_libdir}/ocaml/NBDKit.*
|
||||||
|
%{_mandir}/man3/nbdkit-ocaml-plugin.3*
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%files plugin-perl
|
%files plugin-perl
|
||||||
%doc LICENSE README
|
%doc LICENSE README
|
||||||
%{_libdir}/%{name}/plugins/nbdkit-perl-plugin.so
|
%{_libdir}/%{name}/plugins/nbdkit-perl-plugin.so
|
||||||
@ -304,6 +345,10 @@ make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 19 2015 Richard W.M. Jones <rjones@redhat.com> - 1.1.10-1
|
||||||
|
- New upstream version.
|
||||||
|
- Enable now working OCaml plugin (requires OCaml >= 4.02.2).
|
||||||
|
|
||||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-6
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user