- Update to 2.29.92.1
- Fix eel2 obsoletion
This commit is contained in:
parent
9801295922
commit
76b7342f79
@ -953,7 +953,7 @@ diff -up nautilus-2.25.91-wrk/src/file-manager/fm-properties-window.c.selinux na
|
||||
+ g_assert (NAUTILUS_IS_ENTRY (entry));
|
||||
+ g_assert (FM_IS_PROPERTIES_WINDOW (cb_data));
|
||||
+
|
||||
+ if (GTK_WIDGET_SENSITIVE (entry)) {
|
||||
+ if (gtk_widget_get_state (entry)) {
|
||||
+ char *tmp;
|
||||
+
|
||||
+ tmp = gtk_editable_get_chars (GTK_EDITABLE (entry), 0, -1);
|
||||
@ -1151,7 +1151,7 @@ diff -up nautilus-2.25.91-wrk/src/file-manager/fm-properties-window.c.selinux na
|
||||
+ dattr_t = NULL;
|
||||
+ }
|
||||
+
|
||||
+ if (attr_t && GTK_WIDGET_SENSITIVE (entry)) {
|
||||
+ if (attr_t && gtk_widget_get_state (entry)) {
|
||||
+ /* highlight just the type to the end, so we can easily change it
|
||||
+ * FIXME: we also highlight any Sensitivity/MCS but completion will
|
||||
+ * let people put it back, and that's the only way we get completion
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up nautilus-2.29.90/configure.in.bak nautilus-2.29.90/configure.in
|
||||
--- nautilus-2.29.90/configure.in.bak 2010-02-09 17:10:08.000000000 +0100
|
||||
+++ nautilus-2.29.90/configure.in 2010-02-09 17:17:21.000000000 +0100
|
||||
@@ -329,7 +329,7 @@ dnl libnautilus-extension
|
||||
LIBNAUTILUS_EXTENSION_MODULES="glib-2.0 gtk+-2.0"
|
||||
LIBNAUTILUS_EXTENSION_CFLAGS="`$PKG_CONFIG --cflags $LIBNAUTILUS_EXTENSION_MODULES` $WARNING_CFLAGS"
|
||||
AC_SUBST(LIBNAUTILUS_EXTENSION_CFLAGS)
|
||||
-LIBNAUTILUS_EXTENSION_LIBS="`$PKG_CONFIG --libs $LIBNAUTILUS_EXTENSION_MODULES`"
|
||||
+LIBNAUTILUS_EXTENSION_LIBS="`$PKG_CONFIG --libs $LIBNAUTILUS_EXTENSION_MODULES` -lm"
|
||||
AC_SUBST(LIBNAUTILUS_EXTENSION_LIBS)
|
||||
|
||||
dnl core nautilus
|
@ -14,7 +14,7 @@
|
||||
|
||||
Name: nautilus
|
||||
Summary: File manager for GNOME
|
||||
Version: 2.29.92
|
||||
Version: 2.29.92.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: User Interface/Desktops
|
||||
@ -69,8 +69,10 @@ Obsoletes: nautilus-suggested
|
||||
Obsoletes: nautilus-mozilla < 2.0
|
||||
Obsoletes: nautilus-media
|
||||
|
||||
Obsoletes: gnome-volume-manager < 2.24.0-2.fc10
|
||||
Obsoletes: eel2 < 2.25.1-4.fc10
|
||||
Obsoletes: gnome-volume-manager < 2.24.0-2
|
||||
Provides: gnome-volume-manager = 2.24.0-2
|
||||
Obsoletes: eel2 < eel2-2.26.0-3
|
||||
Provides: eel2 = eel2-2.26.0-3
|
||||
|
||||
# Some changes to default config
|
||||
Patch1: nautilus-config.patch
|
||||
@ -85,9 +87,6 @@ Patch10: nautilus-gvfs-desktop-key-2.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=519743
|
||||
Patch17: nautilus-filetype-symlink-fix.patch
|
||||
|
||||
# https://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking
|
||||
Patch18: nautilus-2.29.90-DSO-linking.patch
|
||||
|
||||
|
||||
%description
|
||||
Nautilus is the file manager and graphical shell for the GNOME desktop
|
||||
@ -125,7 +124,6 @@ for developing nautilus extensions.
|
||||
# %patch8 -p1 -b .hide-white-screen
|
||||
%patch10 -p1 -b .gvfs-desktop-key
|
||||
%patch17 -p0 -b .symlink
|
||||
%patch18 -p1 -b .dso
|
||||
|
||||
%build
|
||||
|
||||
@ -258,6 +256,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Mar 15 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.92.1-1
|
||||
- Update to 2.29.92.1
|
||||
- Fix eel2 obsoletion
|
||||
|
||||
* Mon Mar 8 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.92-1
|
||||
- Update to 2.29.92
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user