Fix compilation with DSO linking

This commit is contained in:
Tomas Bzatek 2010-02-09 16:34:59 +00:00
parent c6a7e9535b
commit 29f454f495
2 changed files with 16 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -up nautilus-2.29.90/configure.in.bak nautilus-2.29.90/configure.in
--- nautilus-2.29.90/configure.in.bak 2010-02-09 17:10:08.000000000 +0100
+++ nautilus-2.29.90/configure.in 2010-02-09 17:17:21.000000000 +0100
@@ -329,7 +329,7 @@ dnl libnautilus-extension
LIBNAUTILUS_EXTENSION_MODULES="glib-2.0 gtk+-2.0"
LIBNAUTILUS_EXTENSION_CFLAGS="`$PKG_CONFIG --cflags $LIBNAUTILUS_EXTENSION_MODULES` $WARNING_CFLAGS"
AC_SUBST(LIBNAUTILUS_EXTENSION_CFLAGS)
-LIBNAUTILUS_EXTENSION_LIBS="`$PKG_CONFIG --libs $LIBNAUTILUS_EXTENSION_MODULES`"
+LIBNAUTILUS_EXTENSION_LIBS="`$PKG_CONFIG --libs $LIBNAUTILUS_EXTENSION_MODULES` -lm"
AC_SUBST(LIBNAUTILUS_EXTENSION_LIBS)
dnl core nautilus

View File

@ -85,6 +85,9 @@ Patch10: nautilus-gvfs-desktop-key-2.patch
# http://bugzilla.gnome.org/show_bug.cgi?id=519743
Patch17: nautilus-filetype-symlink-fix.patch
# https://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking
Patch18: nautilus-2.29.90-DSO-linking.patch
%description
Nautilus is the file manager and graphical shell for the GNOME desktop
@ -123,6 +126,7 @@ for developing nautilus extensions.
# %patch8 -p1 -b .hide-white-screen
%patch10 -p1 -b .gvfs-desktop-key
%patch17 -p0 -b .symlink
%patch18 -p1 -b .dso
%build