new upstream release - 2.9.6
This commit is contained in:
parent
6b7673569e
commit
d9cbab6109
@ -1,35 +0,0 @@
|
||||
From ce8fd571c139b6f3096c802ce919b9b3ba6ecfa0 Mon Sep 17 00:00:00 2001
|
||||
From: Benno Schulenberg <bensberg@telfort.nl>
|
||||
Date: Mon, 23 Apr 2018 16:37:55 +0200
|
||||
Subject: [PATCH] completion: correctly do a signed comparison, to avoid a
|
||||
segfault
|
||||
|
||||
Bug existed since commit 30fc197b (a month ago) which changed the
|
||||
type of 'i' from int to size_t, causing the comparison to do the
|
||||
wrong thing when 'threshold' is negative.
|
||||
|
||||
This fixes https://savannah.gnu.org/bugs/?53722.
|
||||
Reported-by: Devin Hussey <husseydevin@gmail.com>
|
||||
|
||||
Upstream-commit: d53086d38dcf11280ecc628a6d6b88109f1553ab
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
src/text.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/text.c b/src/text.c
|
||||
index a454a9a..d625456 100644
|
||||
--- a/src/text.c
|
||||
+++ b/src/text.c
|
||||
@@ -3640,7 +3640,7 @@ void complete_a_word(void)
|
||||
/* The point where we can stop searching for shard. */
|
||||
|
||||
/* Traverse the whole line, looking for shard. */
|
||||
- for (i = pletion_x; i < threshold; i++) {
|
||||
+ for (i = pletion_x; (int)i < threshold; i++) {
|
||||
/* If the first byte doesn't match, run on. */
|
||||
if (pletion_line->data[i] != shard[0])
|
||||
continue;
|
||||
--
|
||||
2.14.3
|
||||
|
@ -1,16 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQIzBAABCAAdFiEEv9AJBh5TUFKtDfIVDSjU0qCs6IQFAlq8oSQACgkQDSjU0qCs
|
||||
6IRtDw/+N/dg4msyK/snJ6gBx2rRob4VdIcQSNdUwcZAJXJR1edmn4Wg8+lFQi73
|
||||
pZHVvCiS3DZkYo1S+Da3VHr3PgygkD8bX0dHgir31/Cip+Et/jF9uyu+OhpecIEs
|
||||
RCaHMGn3UjvRKqhyX8j1NBdh+pkTRoJdjgswyhRLFtT0aFy55EePY7xE38yBb60B
|
||||
2q1GC0pptaVtPBdL/Efk4IDLL9IVZI3Nh3eU+ZnVKjfw8iAVETEo2n/ZNW1iNTI9
|
||||
Svnoj/Fap4Jb+qMeTKKCb75dhVin0ZIBmmagQ0xrSVPIhTBceWwQRoDI88ZPrhVU
|
||||
JjRsE5OiA+kq/rXSB1oxu3cWuRTxkOjXPmDzeW1V8wQFFbWy+z7U5RM1PciimN1p
|
||||
qokPJ21lzyQJTkDOsK0rgSlipzhbOdLITpXF9cXxU8HDk0RrmZeQYC6c+yndX7bi
|
||||
hzvEe3wj9LgEEsVzVZ4/qG/VYxENbFbhBOj2Zx2i5uJLfzQQQ3MDID6CcPm5L+0/
|
||||
UmkzUsqtNzEBGb/Hjz9AVHIYx2vm+Rfo+DTPNYQ5oj9H3wyN7WDnSJQIvGqM9h2c
|
||||
17hN0QLIzMIHt87Bs/BNrrYmDCy1DBC3qpQKL6qcVaQ7Wl1BPGo8g7qCJ4vVqhON
|
||||
IuVCLWVGQ9ALLJyMwyONVOgkvdQ97A7WKroxacrYvtTXQJUPkIE=
|
||||
=aCxy
|
||||
-----END PGP SIGNATURE-----
|
16
nano-2.9.6.tar.gz.asc
Normal file
16
nano-2.9.6.tar.gz.asc
Normal file
@ -0,0 +1,16 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQIzBAABCAAdFiEEv9AJBh5TUFKtDfIVDSjU0qCs6IQFAlri6rsACgkQDSjU0qCs
|
||||
6ITxyw/+MnIGGdJJOKxhqM7R3gB/sto7YHda4iho9KvQLOBlOY501xuLFXrMNB94
|
||||
mp+7F4Ga2qigjgQnYb5awNtnToObFeO3TUOPwKfyifeLHhwuBMS4mKOCVMqxUqmz
|
||||
Yw31+0aMLHlEtebchubRGJyZGGsCRT0XzCvlwrFiYiiaMf7REcjyB0nirHwHz/Rl
|
||||
jyHb69aHnUm5sh8GFtX9XmOV1RWftXufqllJ6vI/kcLSud15fJJkWDX/l223sVrV
|
||||
8WaIlvBG5ubbSwHMbvYnfbQMPJ15x1si4rd4GgiEOjS3SayoOf+Mms/gusCfJqy7
|
||||
9+Y3KX+oapLbzouCx4yjQpP06ujj1ygdqSSRkYtLGhDCAuBkVTIhqNWK5sknd9Xx
|
||||
6bSkXKAluY/Y94xUo61JFXd2Ljx08MlTLn4lfGRL7rDBRYnxWg1+S6g/rX7wNCI/
|
||||
lvHQSF40yT0di9CNeF8wme1I46MaRQR05lNZko27E7b83HPLg4ehNeVdW93Lc32i
|
||||
Yoknjnzs8uyi09PksEAmUGUlBz172vjEWLUwnCprLouWJLPmSV0i51AGvEqah4po
|
||||
Xuqekdqw7afiR/GN90zCnUxJ6PeIAPC3Zj+uXbLNlS8MoGFZDmoMxjwK3ZqV9fwg
|
||||
XUHLr/n9VN7gKq8Y1TEfPEU5fy/Ug0ouhwDy+qeIDngsA20z104=
|
||||
=RBc1
|
||||
-----END PGP SIGNATURE-----
|
11
nano.spec
11
nano.spec
@ -1,16 +1,12 @@
|
||||
Summary: A small text editor
|
||||
Name: nano
|
||||
Version: 2.9.5
|
||||
Release: 2%{?dist}
|
||||
Version: 2.9.6
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
URL: https://www.nano-editor.org
|
||||
Source: https://www.nano-editor.org/dist/v2.9/%{name}-%{version}.tar.gz
|
||||
Source2: nanorc
|
||||
|
||||
# fix crash when using word completion
|
||||
# https://savannah.gnu.org/bugs/?53722
|
||||
Patch1: 0001-nano-2.9.5-word-completion-crash.patch
|
||||
|
||||
BuildRequires: file-devel
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: gcc
|
||||
@ -84,6 +80,9 @@ exit 0
|
||||
%{_datadir}/nano
|
||||
|
||||
%changelog
|
||||
* Fri Apr 27 2018 Kamil Dudka <kdudka@redhat.com> - 2.9.6-1
|
||||
- new upstream release
|
||||
|
||||
* Wed Apr 25 2018 Kamil Dudka <kdudka@redhat.com> - 2.9.5-2
|
||||
- fix crash when using word completion
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (nano-2.9.5.tar.gz) = 623a1d142f5aff62186314d84ea8461e10ab7eb2e11c8a57497736bc5ad432e39d48086d17eb80bdbf9b33adc41e9d77db5416281138993dbea795afd96dbfc0
|
||||
SHA512 (nano-2.9.6.tar.gz) = 360802c3d772e8159e729803d5307575b348f779623e49401752984201b6b874df1582fe79ed6552a524db64ae6d8a1bfb449b525f7354cbd5cd9941432a2dff
|
||||
|
Loading…
Reference in New Issue
Block a user