new upstream release - 4.1
This commit is contained in:
parent
07cd450144
commit
b49fcbd4c3
@ -1,42 +0,0 @@
|
||||
From d1d0b8a5a3ceff069f144a5f8ac01a175d96b511 Mon Sep 17 00:00:00 2001
|
||||
From: Devin Hussey <husseydevin@gmail.com>
|
||||
Date: Thu, 28 Mar 2019 17:28:47 -0400
|
||||
Subject: [PATCH] files: initialize a variable before referencing it
|
||||
|
||||
The lack of initialization caused a nasty bug on some targets (such as
|
||||
ARMv7) which would make it so that ^S would just say "Cancelled".
|
||||
|
||||
While x86 (both 64 and 32 bits) seems to initialize 'response' to zero or
|
||||
a positive number, ARM does not, and there is usually a negative value in
|
||||
its place, which triggers the 'if (response < 0)' check and, as a result,
|
||||
the code says "Cancelled".
|
||||
|
||||
This fixes https://savannah.gnu.org/bugs/?56023.
|
||||
Reported-by: Devin Hussey <husseydevin@gmail.com>
|
||||
|
||||
Bug existed since version 4.0, commit 0f9d60a3.
|
||||
|
||||
Signed-off-by: Devin Hussey <husseydevin@gmail.com>
|
||||
|
||||
Upstream-commit: 7ad232d71470cd8c4dc63aeb02f11c9e8df9ecdb
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
src/files.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/files.c b/src/files.c
|
||||
index 84e3f68..fd54c16 100644
|
||||
--- a/src/files.c
|
||||
+++ b/src/files.c
|
||||
@@ -2101,7 +2101,7 @@ int do_writeout(bool exiting, bool withprompt)
|
||||
|
||||
while (TRUE) {
|
||||
const char *msg;
|
||||
- int response, choice;
|
||||
+ int response = 0, choice = 0;
|
||||
functionptrtype func;
|
||||
#ifndef NANO_TINY
|
||||
const char *formatstr, *backupstr;
|
||||
--
|
||||
2.17.2
|
||||
|
@ -1,16 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQIzBAABCAAdFiEEv9AJBh5TUFKtDfIVDSjU0qCs6IQFAlyXbmwACgkQDSjU0qCs
|
||||
6IQLHA/+M/3oN4OpsX11S30qaJx+/82dbPd1Sju757TY7eMcjyEL2GxKIc601gf/
|
||||
ioNEU44J2MiKR0uX167ePYr7ZgplkD+P1L5DzHIYz0KglLk539gq3rDwu0vQiUqG
|
||||
DqmMCW1SQR6wVSHrpX692O/vn8QhmQL17yiZ10IKweGphy4WiD+62kMnC05wKUf/
|
||||
cRKmY9fCYwIgQUWBBnTympnprACK8TY51LcTtK21tZBqJ6lTt07FxZQ1vVm2eYgL
|
||||
/+p5c7jmNFqNsL2Mj0dSPRrfdX0I4prmXVDJx0QX4bIcCkUr7AHtjbNEaQ9emhCd
|
||||
wcamn1NVAiU0fyy3bKEW5dITsIh88nfOgNOefLRquXxbzyfHtxi446Js4ZANJxrc
|
||||
4xzmRN5S+PqYQW3IW5UGxAT6tmYIww2yxw09TlNO0yenbCpHovlOnMk8TesRuXAK
|
||||
WjZjZQEW7YSa4zVRPqVWYi1ftpRokXxfm3zt9F3LaIUlcRZf5IJMTrDO3NTt076+
|
||||
OGHO9XRzyT4weDsSC4W1E1ev1H0H3W7dHODpw+8xL/1R2gayCE3wYOumj28GDVK/
|
||||
wAeFSv2d8+OOLhoHlh09pvMPln6JVWU/aVSuVNIn1PqffGazE7XqzR3TQKuXM/4v
|
||||
gkJxP59RU61on6ae2BKzyUAOKQjHH8ojboYyo9SznHUkcjXpJy4=
|
||||
=ZdCV
|
||||
-----END PGP SIGNATURE-----
|
16
nano-4.1.tar.xz.asc
Normal file
16
nano-4.1.tar.xz.asc
Normal file
@ -0,0 +1,16 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQIzBAABCAAdFiEEv9AJBh5TUFKtDfIVDSjU0qCs6IQFAly0OWYACgkQDSjU0qCs
|
||||
6ITxhQ/+ItBoiJCHUuxN8Wr0NxkmtWKw4ufAyJoo9vhHiAPxwASQoSvsHJS9jj1i
|
||||
5mn2Syw4dL7j+oUkTpp9fR/saWmGz6965nhyCVEv7FmMOrEz0PW4k79k+UWzK8Gy
|
||||
9Sk0S7r1J1IbujVqoWHMRQiKnYILDHjQxMqndZkUUpfEFhGaJP+3Wll/kVvEqnJ9
|
||||
zsfHWOIAbctO0CJyi8rZdZXmI3XsnJXQFl/onfxn83/egt0ButCJIcf2bBa+8qPb
|
||||
P7FNXQZhaeQ6wTud68EUxs8cuG+Gzpy01MZdklUl+Al8tbEiiazaJn6W5wCyX7fP
|
||||
IM8yCD2t8FSYXGesRVnNnZVzxZf/HvJuThh+iPovcAfPewIn3Z3HjlJ6L0Ja61PZ
|
||||
FqXR0LbiBSmNGsRhOiXH1B+qHZ9sGRKXLxmqA4Hef6w8ql/rHGEq9T4o+mMBnNkz
|
||||
mlrbzHwpCZB0iDn0UYgZyvEVrTVoJwgtAnoFoBrN5oomNc3nnmkRXH8ItebE2DaF
|
||||
1ynXPZh5JBRtR1FlySqKKO0CTVQnHNO068BUdndklsriM7KzIseQIbbiczaVZMtb
|
||||
HOe82k8uJzl8XVgeVKR7JLlorx12fSTQZQtFr9d5zqdkkePEjTRLp9MQyXam2TKW
|
||||
IZzI6ipDFZGRqKKto2ZZN5xfVBh8WMdUKcKunnz26GXx+JWPioo=
|
||||
=ATF4
|
||||
-----END PGP SIGNATURE-----
|
11
nano.spec
11
nano.spec
@ -1,7 +1,7 @@
|
||||
Summary: A small text editor
|
||||
Name: nano
|
||||
Version: 4.0
|
||||
Release: 2%{?dist}
|
||||
Version: 4.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
URL: https://www.nano-editor.org
|
||||
Source: https://www.nano-editor.org/dist/latest/%{name}-%{version}.tar.xz
|
||||
@ -17,10 +17,6 @@ BuildRequires: sed
|
||||
BuildRequires: texinfo
|
||||
Conflicts: filesystem < 3
|
||||
|
||||
# make sure that variables on stack are initialized
|
||||
# upstream bug: https://savannah.gnu.org/bugs/?56023
|
||||
Patch1: 0001-nano-4.0-init-vars.patch
|
||||
|
||||
%description
|
||||
GNU nano is a small and friendly text editor.
|
||||
|
||||
@ -68,6 +64,9 @@ install -m 0644 ./nanorc %{buildroot}%{_sysconfdir}/nanorc
|
||||
%{_datadir}/nano
|
||||
|
||||
%changelog
|
||||
* Mon Apr 15 2019 Kamil Dudka <kdudka@redhat.com> - 4.1-1
|
||||
- new upstream release
|
||||
|
||||
* Tue Apr 02 2019 Kamil Dudka <kdudka@redhat.com> - 4.0-2
|
||||
- make sure that variables on stack are initialized
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user