new upstream release - 2.3.5
This commit is contained in:
parent
53cb30c200
commit
ace90c7fcd
@ -11,7 +11,7 @@ diff --git a/src/files.c b/src/files.c
|
||||
index f6efbf1..99cc1b8 100644
|
||||
--- a/src/files.c
|
||||
+++ b/src/files.c
|
||||
@@ -300,6 +300,24 @@ int do_lockfile(const char *filename)
|
||||
@@ -310,6 +310,24 @@ int do_lockfile(const char *filename)
|
||||
}
|
||||
#endif /* !NANO_TINY */
|
||||
|
||||
@ -36,7 +36,7 @@ index f6efbf1..99cc1b8 100644
|
||||
/* If it's not "", filename is a file to open. We make a new buffer, if
|
||||
* necessary, and then open and read the file, if applicable. */
|
||||
void open_buffer(const char *filename, bool undoable)
|
||||
@@ -345,11 +363,7 @@ void open_buffer(const char *filename, bool undoable)
|
||||
@@ -355,11 +373,7 @@ void open_buffer(const char *filename, bool undoable)
|
||||
if (rc > 0) {
|
||||
read_file(f, rc, filename, undoable, new_buffer);
|
||||
#ifndef NANO_TINY
|
||||
@ -49,7 +49,7 @@ index f6efbf1..99cc1b8 100644
|
||||
#endif
|
||||
}
|
||||
|
||||
@@ -1737,10 +1751,8 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
@@ -1753,10 +1767,8 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
* specified it interactively), stat and save the value now,
|
||||
* or else we will chase null pointers when we do modtime checks,
|
||||
* preserve file times, and so on, during backup. */
|
||||
@ -62,7 +62,7 @@ index f6efbf1..99cc1b8 100644
|
||||
|
||||
/* We backup only if the backup toggle is set, the file isn't
|
||||
* temporary, and the file already exists. Furthermore, if we
|
||||
@@ -2133,8 +2145,10 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
@@ -2149,8 +2161,10 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
if (openfile->current_stat == NULL)
|
||||
openfile->current_stat =
|
||||
(struct stat *)nmalloc(sizeof(struct stat));
|
||||
|
@ -14,7 +14,7 @@ diff --git a/config.h.in b/config.h.in
|
||||
index 52e13f1..cb17b29 100644
|
||||
--- a/config.h.in
|
||||
+++ b/config.h.in
|
||||
@@ -66,6 +66,9 @@
|
||||
@@ -69,6 +69,9 @@
|
||||
/* Define to 1 if you don't have `vprintf' but do have `_doprnt.' */
|
||||
#undef HAVE_DOPRNT
|
||||
|
||||
@ -28,7 +28,7 @@ diff --git a/configure b/configure
|
||||
index 02733c7..1805e53 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -7577,7 +7577,7 @@ fi
|
||||
@@ -7599,7 +7599,7 @@ fi
|
||||
|
||||
|
||||
|
||||
@ -41,7 +41,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 66f8ee3..f4975d3 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -419,7 +419,7 @@ int main(void)
|
||||
@@ -432,7 +432,7 @@ int main(void)
|
||||
|
||||
dnl Checks for functions.
|
||||
|
||||
@ -54,7 +54,7 @@ diff --git a/src/files.c b/src/files.c
|
||||
index 99cc1b8..9a1bdcc 100644
|
||||
--- a/src/files.c
|
||||
+++ b/src/files.c
|
||||
@@ -1662,6 +1662,29 @@ int copy_file(FILE *inn, FILE *out)
|
||||
@@ -1676,6 +1676,29 @@ int copy_file(FILE *inn, FILE *out)
|
||||
return retval;
|
||||
}
|
||||
|
||||
@ -84,7 +84,7 @@ index 99cc1b8..9a1bdcc 100644
|
||||
/* Write a file out to disk. If f_open isn't NULL, we assume that it is
|
||||
* a stream associated with the file, and we don't try to open it
|
||||
* ourselves. If tmp is TRUE, we set the umask to disallow anyone else
|
||||
@@ -1912,7 +1935,8 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
@@ -1928,7 +1951,8 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
}
|
||||
|
||||
/* And set its metadata. */
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.10 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlFRsnwACgkQvLNW35EAn6f9wwCdHmY/WKtwVoLR49vPgr/D8mwN
|
||||
ULcAn0nHgbd3m7B5XKaWrF5hJkypsss/
|
||||
=ZC4W
|
||||
-----END PGP SIGNATURE-----
|
7
nano-2.3.5.tar.gz.asc
Normal file
7
nano-2.3.5.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.14 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlO/3HsACgkQvLNW35EAn6dE5wCgxFn/AyUx9yVgIwgQrvRrbKQH
|
||||
OmgAoLQYdnngSUETQsktRL/DP/W4bd+b
|
||||
=22jA
|
||||
-----END PGP SIGNATURE-----
|
@ -1,7 +1,7 @@
|
||||
Summary: A small text editor
|
||||
Name: nano
|
||||
Version: 2.3.4
|
||||
Release: 2%{?dist}
|
||||
Version: 2.3.5
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Editors
|
||||
URL: http://www.nano-editor.org
|
||||
@ -79,7 +79,7 @@ fi
|
||||
exit 0
|
||||
|
||||
%files -f %{name}.lang
|
||||
%doc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README THANKS TODO
|
||||
%doc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
|
||||
%doc doc/nanorc.sample
|
||||
%doc doc/faq.html
|
||||
%{_bindir}/*
|
||||
@ -90,6 +90,9 @@ exit 0
|
||||
%{_datadir}/nano
|
||||
|
||||
%changelog
|
||||
* Wed Jul 16 2014 Kamil Dudka <kdudka@redhat.com> - 2.3.5-1
|
||||
- new upstream release
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user