- new upstream release
This commit is contained in:
parent
585d51e7de
commit
7048abbb6e
@ -1 +1 @@
|
||||
nano-2.2.2.tar.gz
|
||||
nano-2.2.3.tar.gz
|
||||
|
37
nano-2.2.3-warnings.patch
Normal file
37
nano-2.2.3-warnings.patch
Normal file
@ -0,0 +1,37 @@
|
||||
diff --git a/po/Makefile.in.in b/po/Makefile.in.in
|
||||
index ada8bb4..f7b2a95 100644
|
||||
--- a/po/Makefile.in.in
|
||||
+++ b/po/Makefile.in.in
|
||||
@@ -20,6 +20,7 @@ VPATH = @srcdir@
|
||||
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
+datarootdir = @datarootdir@
|
||||
datadir = @datadir@
|
||||
localedir = $(datadir)/locale
|
||||
gettextsrcdir = $(datadir)/gettext/po
|
||||
diff --git a/src/nano.c b/src/nano.c
|
||||
index 7008413..22b305d 100644
|
||||
--- a/src/nano.c
|
||||
+++ b/src/nano.c
|
||||
@@ -1894,7 +1894,7 @@ precalc_cleanup:
|
||||
* TRUE. */
|
||||
void do_output(char *output, size_t output_len, bool allow_cntrls)
|
||||
{
|
||||
- size_t current_len, orig_lenpt, i = 0;
|
||||
+ size_t current_len, orig_lenpt = 0, i = 0;
|
||||
char *char_buf = charalloc(mb_cur_max());
|
||||
int char_buf_len;
|
||||
|
||||
diff --git a/src/winio.c b/src/winio.c
|
||||
index 65fd0e4..b201e02 100644
|
||||
--- a/src/winio.c
|
||||
+++ b/src/winio.c
|
||||
@@ -3125,7 +3125,6 @@ void edit_redraw(filestruct *old_current, size_t pww_save)
|
||||
old_current->lineno, openfile->edittop->lineno);
|
||||
#endif
|
||||
filestruct *old_edittop = openfile->edittop;
|
||||
- ssize_t nlines;
|
||||
|
||||
#ifndef NANO_TINY
|
||||
/* If the mark is on, update all the lines between old_current
|
@ -1,12 +1,13 @@
|
||||
Summary: A small text editor
|
||||
Name: nano
|
||||
Version: 2.2.2
|
||||
Version: 2.2.3
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Editors
|
||||
URL: http://www.nano-editor.org
|
||||
Source: http://www.nano-editor.org/dist/v2.2/%{name}-%{version}.tar.gz
|
||||
Source2: nanorc
|
||||
Patch0: nano-2.2.3-warnings.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: gettext-devel
|
||||
@ -21,6 +22,7 @@ GNU nano is a small and friendly text editor.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
for f in doc/man/fr/{nano.1,nanorc.5,rnano.1} ; do
|
||||
iconv -f iso-8859-1 -t utf-8 -o $f.tmp $f && mv $f.tmp $f
|
||||
@ -79,6 +81,9 @@ rm -rf %{buildroot}
|
||||
%{_datadir}/nano
|
||||
|
||||
%changelog
|
||||
* Wed Mar 03 2010 Kamil Dudka <kdudka@redhat.com> - 2.2.3-1
|
||||
- new upstream release
|
||||
|
||||
* Fri Jan 29 2010 Kamil Dudka <kdudka@redhat.com> - 2.2.2-1
|
||||
- new upstream release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user