new upstream release - 5.9
This commit is contained in:
parent
c7f2d7ed86
commit
4fea658095
@ -1,82 +0,0 @@
|
|||||||
From 67ee5ab6af622666d8caf4127e945c941698b816 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Benno Schulenberg <bensberg@telfort.nl>
|
|
||||||
Date: Tue, 29 Jun 2021 12:51:44 +0200
|
|
||||||
Subject: [PATCH 1/2] feedback: when not in curses mode, just skip displaying
|
|
||||||
any message
|
|
||||||
|
|
||||||
Calling die() could trigger another call of emergency_save(), which
|
|
||||||
could fail and cause another call to statusline(), which would call
|
|
||||||
die() again... Spiralling until stack space runs out.
|
|
||||||
|
|
||||||
This fixes https://savannah.gnu.org/bugs/?60853.
|
|
||||||
|
|
||||||
Bug existed since version 5.1, commit 7942dab0.
|
|
||||||
|
|
||||||
Original report was in https://bugzilla.redhat.com/1976410.
|
|
||||||
Reported-by: Souptik Dutta Roy <duttaroy.souptik@gmail.com>
|
|
||||||
|
|
||||||
Upstream-commit: fc01c5a10ee729d6f82e109890b593aef976205e
|
|
||||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
|
||||||
---
|
|
||||||
src/winio.c | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/winio.c b/src/winio.c
|
|
||||||
index 72f4f95..345fb19 100644
|
|
||||||
--- a/src/winio.c
|
|
||||||
+++ b/src/winio.c
|
|
||||||
@@ -2255,8 +2255,9 @@ void statusline(message_type importance, const char *msg, ...)
|
|
||||||
|
|
||||||
UNSET(WHITESPACE_DISPLAY);
|
|
||||||
|
|
||||||
+ /* When not in curses mode, there is no status bar to display anything on. */
|
|
||||||
if (isendwin())
|
|
||||||
- die("Out of curses -- please report a bug\n");
|
|
||||||
+ return;
|
|
||||||
#endif
|
|
||||||
|
|
||||||
/* Ignore a message with an importance that is lower than the last one. */
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
||||||
|
|
||||||
From 242cde94e13352ef97c048a5c8c6ddbf83d7c9a4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Benno Schulenberg <bensberg@telfort.nl>
|
|
||||||
Date: Tue, 29 Jun 2021 13:20:16 +0200
|
|
||||||
Subject: [PATCH 2/2] input: give up on the input stream only after millions of
|
|
||||||
errors
|
|
||||||
|
|
||||||
This mitigates a problem seen sometimes among the Red Hat crash reports:
|
|
||||||
somehow wgetch() keeps returning ERR, as if it were in nodelay mode.
|
|
||||||
(I've seen this happen once after nano came out of suspension.)
|
|
||||||
|
|
||||||
Using a much larger error-count value gives the user a few seconds
|
|
||||||
to type something and hopefully get out of the error condition.
|
|
||||||
|
|
||||||
Upstream-commit: 8d1a666dcfbb9e9fcf6ce7a875a4ad4f5ea932ce
|
|
||||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
|
||||||
---
|
|
||||||
src/winio.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/winio.c b/src/winio.c
|
|
||||||
index 345fb19..744562f 100644
|
|
||||||
--- a/src/winio.c
|
|
||||||
+++ b/src/winio.c
|
|
||||||
@@ -233,11 +233,11 @@ void read_keys_from(WINDOW *win)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
- /* When we've failed to get a keycode over a hundred times in a row,
|
|
||||||
+ /* When we've failed to get a keycode millions of times in a row,
|
|
||||||
* assume our input source is gone and die gracefully. We could
|
|
||||||
* check if errno is set to EIO ("Input/output error") and die in
|
|
||||||
* that case, but it's not always set properly. Argh. */
|
|
||||||
- if (input == ERR && ++errcount == 123)
|
|
||||||
+ if (input == ERR && ++errcount == 12345678)
|
|
||||||
die(_("Too many errors from stdin\n"));
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
@ -1,16 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
|
|
||||||
iQIzBAABCAAdFiEEv9AJBh5TUFKtDfIVDSjU0qCs6IQFAmDIZLYACgkQDSjU0qCs
|
|
||||||
6IQH/g/7BCG+gdFC6JwPfnG/7UfbL6HIg2DpPplOocJ08/fw/2MLZKx3+f8EFOzo
|
|
||||||
G7hAlNeaoa7sNWDvCVhI9oJYwNrBVc7FRyWyOltSDv/7NYT0ofPnAoXigxhBMuqB
|
|
||||||
xFbX0pfep6Rn2ZyZ5n790ONwCmzpHs/BbLoilDQNsw8Trk3UKhOxnYMdrAUuUSpF
|
|
||||||
GUqmYhzyDBm1+Tn4o6wa0/ZN1Spgfn6Ef/tUVz0Gcq+jqwTDuUgwb00+DeALnnWr
|
|
||||||
MGQJjPTYhjjJczJ+rpcC05conRDryxx0jGsL6J6wtJ/MxIq4atYSq3b1FUs3L7As
|
|
||||||
tZI1k8l8++V/Hnd8Q9QjATHiwj8adS7sysV3Fs6YxBdKNke6fqF4TB9l+jZRpBUT
|
|
||||||
fK7UX6dJYIs+cOJblYkz8PM9WhzepV4NxYa7/9b5tXFHrP2G1j58AGkhbICEaczx
|
|
||||||
vCOsf6s14hYqU1CXoodunRDIL0zkrfE2YO2I/yLDX08lk6uJ0uG7YOeLYn363Uq5
|
|
||||||
FUKnIGajSVdIDpebfb/UWQoRmq30OUSgfjkhacRIqqPoV55/VsWuC14buAQVV7FX
|
|
||||||
VRy29FnnShgcOKV4clP0SV6/AxSAQIbFd2DR0L/x7JZXqIIUSD9z503IGO3TDIsz
|
|
||||||
F/S5Qd7tNsRWgonX7QKDbyftQ1HX0FzPMUeuloCJdUYWdak24Jo=
|
|
||||||
=q7GX
|
|
||||||
-----END PGP SIGNATURE-----
|
|
16
nano-5.9.tar.xz.asc
Normal file
16
nano-5.9.tar.xz.asc
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
|
||||||
|
iQIzBAABCAAdFiEEv9AJBh5TUFKtDfIVDSjU0qCs6IQFAmFdZA8ACgkQDSjU0qCs
|
||||||
|
6IRufA/+JltYzPg6vGjrwCV6rAWwPM36DBcoUBlIZU9+do7w/mv7H1rhWvMsArnx
|
||||||
|
kGVTNSWltcMorMBKbbLbxDFxK2hKbjEpukFKCUqkA4HJDKR8ShN7EYERDl5ponTw
|
||||||
|
pqFkpmkUMW2Zv2BDBbWEJ3PqNL508kgEZGB0ZfvjezXeWg/o0ub1mnxhel3GnYx2
|
||||||
|
a1OxeAaPa/KZegcYGlG5ahAuLDn/B1Vc2CTG6GH6Kv9r0YFYCnrNAnzUHz8c48ew
|
||||||
|
e1PvNy/SYzzaqLI0M8XhbNtf3badynXn/dGk02bJxiAdtAp/CqQLp9swZ13m65uN
|
||||||
|
qc6v9EziPyp1C84scYGswwsb7um9YCBRfE7G9O9DJCCKPVMjgm/zAyivFxs10JnB
|
||||||
|
TFBZrXicKb8YwfCSJ9euPhvL2iWrsUxuGh00pKqOMkdxiDoi2VN8Q/9jxltnBthN
|
||||||
|
gMcYG7V7niGA54NjaC3oe4G1Q/dxIXq6eJqJcvfvMkxEQ7BL26NwFEGnGo8OK8Re
|
||||||
|
6m4aKxKnsy6HqRGDCq9Ygvrya2qNuY555bQNMykxqcUa6uYUPFfXlhHia7e32WnQ
|
||||||
|
aOGzUHGncq6I++GHVXN546Ufw801glkMI5sVJ5teWqLuaz6xPRLQWixJw58dNk1V
|
||||||
|
qhYVjTMMv9Oy6GnTgEr3MYItiXIak6JRc52lFrucToi0z9ddWTw=
|
||||||
|
=HMNR
|
||||||
|
-----END PGP SIGNATURE-----
|
10
nano.spec
10
nano.spec
@ -7,16 +7,13 @@
|
|||||||
|
|
||||||
Summary: A small text editor
|
Summary: A small text editor
|
||||||
Name: nano
|
Name: nano
|
||||||
Version: 5.8
|
Version: 5.9
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: https://www.nano-editor.org
|
URL: https://www.nano-editor.org
|
||||||
Source: https://www.nano-editor.org/dist/latest/%{name}-%{version}.tar.xz
|
Source: https://www.nano-editor.org/dist/latest/%{name}-%{version}.tar.xz
|
||||||
Source2: nanorc
|
Source2: nanorc
|
||||||
|
|
||||||
# fix infinite recursion when handling an error (#1976410)
|
|
||||||
Patch1: nano-5.8-die-infinite-recursion.patch
|
|
||||||
|
|
||||||
# Shell snippets for default-editor setup
|
# Shell snippets for default-editor setup
|
||||||
Source11: nano-default-editor.sh
|
Source11: nano-default-editor.sh
|
||||||
Source12: nano-default-editor.csh
|
Source12: nano-default-editor.csh
|
||||||
@ -125,6 +122,9 @@ install -Dpm 0644 %{SOURCE13} %{buildroot}%{_datadir}/fish/vendor_conf.d/%{basen
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 06 2021 Kamil Dudka <kdudka@redhat.com> - 5.9-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.8-4
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.8-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (nano-5.8.tar.xz) = ac614587f1a76c5ccb425fc8b4c6d4f7748dda89b863b2b8c6937b31e837edca5c83e3c13f53c9f5da5a9e24a1d8093c19dd0e8a85723f0bbae57fdab155e15c
|
SHA512 (nano-5.9.tar.xz) = 45ff3abce4dab24a8090409e6d7bb26afa7fa7812a51e06728c2aa47d5b4de610d97ba4609cf13d9173087bd909fdf377235eee988a6fdcf52abb70341c40b5b
|
||||||
|
Loading…
Reference in New Issue
Block a user