new upstream release - 2.6.0
This commit is contained in:
parent
fa152470f3
commit
335c462b13
@ -1,7 +1,7 @@
|
|||||||
From 8d618f769b1e66a26e7b790e4e94b2c3dca68d31 Mon Sep 17 00:00:00 2001
|
From 8d618f769b1e66a26e7b790e4e94b2c3dca68d31 Mon Sep 17 00:00:00 2001
|
||||||
From: Kamil Dudka <kdudka@redhat.com>
|
From: Kamil Dudka <kdudka@redhat.com>
|
||||||
Date: Tue, 26 Mar 2013 16:20:27 +0100
|
Date: Tue, 26 Mar 2013 16:20:27 +0100
|
||||||
Subject: [PATCH 1/3] fix compile-time warnings in nano-2.3.3
|
Subject: [PATCH 1/2] fix compile-time warnings in nano-2.3.3
|
||||||
|
|
||||||
---
|
---
|
||||||
po/Makefile.in.in | 1 +
|
po/Makefile.in.in | 1 +
|
@ -1,20 +1,20 @@
|
|||||||
From 23510b930ea31f7de8005e2f0ff6cab7062b4e26 Mon Sep 17 00:00:00 2001
|
From 23510b930ea31f7de8005e2f0ff6cab7062b4e26 Mon Sep 17 00:00:00 2001
|
||||||
From: Kamil Dudka <kdudka@redhat.com>
|
From: Kamil Dudka <kdudka@redhat.com>
|
||||||
Date: Thu, 19 Aug 2010 15:23:06 +0200
|
Date: Thu, 19 Aug 2010 15:23:06 +0200
|
||||||
Subject: [PATCH 3/3] use futimens() if available, instead of utime()
|
Subject: [PATCH 2/2] use futimens() if available, instead of utime()
|
||||||
|
|
||||||
---
|
---
|
||||||
config.h.in | 3 +++
|
config.h.in | 3 +++
|
||||||
configure | 2 +-
|
configure | 2 +-
|
||||||
configure.ac | 2 +-
|
configure.ac | 2 +-
|
||||||
src/files.c | 48 ++++++++++++++++++++++++++++++++++++------------
|
src/files.c | 46 +++++++++++++++++++++++++++++++++++-----------
|
||||||
4 files changed, 41 insertions(+), 14 deletions(-)
|
4 files changed, 40 insertions(+), 13 deletions(-)
|
||||||
|
|
||||||
diff --git a/config.h.in b/config.h.in
|
diff --git a/config.h.in b/config.h.in
|
||||||
index 52e13f1..cb17b29 100644
|
index 52e13f1..cb17b29 100644
|
||||||
--- a/config.h.in
|
--- a/config.h.in
|
||||||
+++ b/config.h.in
|
+++ b/config.h.in
|
||||||
@@ -69,6 +69,9 @@
|
@@ -72,6 +72,9 @@
|
||||||
/* Define to 1 if you don't have `vprintf' but do have `_doprnt.' */
|
/* Define to 1 if you don't have `vprintf' but do have `_doprnt.' */
|
||||||
#undef HAVE_DOPRNT
|
#undef HAVE_DOPRNT
|
||||||
|
|
||||||
@ -28,7 +28,7 @@ diff --git a/configure b/configure
|
|||||||
index 02733c7..1805e53 100755
|
index 02733c7..1805e53 100755
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -7752,7 +7752,7 @@ fi
|
@@ -7775,7 +7775,7 @@ fi
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
@ -41,7 +41,7 @@ diff --git a/configure.ac b/configure.ac
|
|||||||
index 66f8ee3..f4975d3 100644
|
index 66f8ee3..f4975d3 100644
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -428,7 +428,7 @@ int main(void)
|
@@ -442,7 +442,7 @@ int main(void)
|
||||||
|
|
||||||
dnl Checks for functions.
|
dnl Checks for functions.
|
||||||
|
|
||||||
@ -54,7 +54,7 @@ diff --git a/src/files.c b/src/files.c
|
|||||||
index 99cc1b8..9a1bdcc 100644
|
index 99cc1b8..9a1bdcc 100644
|
||||||
--- a/src/files.c
|
--- a/src/files.c
|
||||||
+++ b/src/files.c
|
+++ b/src/files.c
|
||||||
@@ -1741,6 +1741,29 @@ int copy_file(FILE *inn, FILE *out)
|
@@ -1691,6 +1691,29 @@ int copy_file(FILE *inn, FILE *out)
|
||||||
return retval;
|
return retval;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -84,7 +84,7 @@ index 99cc1b8..9a1bdcc 100644
|
|||||||
/* Write a file out to disk. If f_open isn't NULL, we assume that it is
|
/* Write a file out to disk. If f_open isn't NULL, we assume that it is
|
||||||
* a stream associated with the file, and we don't try to open it
|
* a stream associated with the file, and we don't try to open it
|
||||||
* ourselves. If tmp is TRUE, we set the umask to disallow anyone else
|
* ourselves. If tmp is TRUE, we set the umask to disallow anyone else
|
||||||
@@ -1964,18 +1987,9 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
@@ -1912,17 +1935,9 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||||
fprintf(stderr, "Backing up %s to %s\n", realname, backupname);
|
fprintf(stderr, "Backing up %s to %s\n", realname, backupname);
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -92,9 +92,8 @@ index 99cc1b8..9a1bdcc 100644
|
|||||||
- copy_status = copy_file(f, backup_file);
|
- copy_status = copy_file(f, backup_file);
|
||||||
-
|
-
|
||||||
- if (copy_status != 0) {
|
- if (copy_status != 0) {
|
||||||
- statusbar(_("Error reading %s: %s"), realname,
|
- statusline(ALERT, _("Error reading %s: %s"), realname,
|
||||||
- strerror(errno));
|
- strerror(errno));
|
||||||
- beep();
|
|
||||||
- goto cleanup_and_exit;
|
- goto cleanup_and_exit;
|
||||||
- }
|
- }
|
||||||
-
|
-
|
||||||
@ -105,8 +104,8 @@ index 99cc1b8..9a1bdcc 100644
|
|||||||
+ && !ISSET(INSECURE_BACKUP)) {
|
+ && !ISSET(INSECURE_BACKUP)) {
|
||||||
if (prompt_failed_backupwrite(backupname))
|
if (prompt_failed_backupwrite(backupname))
|
||||||
goto skip_backup;
|
goto skip_backup;
|
||||||
statusbar(_("Error writing backup file %s: %s"), backupname,
|
statusline(HUSH, _("Error writing backup file %s: %s"),
|
||||||
@@ -1987,6 +2001,16 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
@@ -1934,6 +1949,15 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||||
goto cleanup_and_exit;
|
goto cleanup_and_exit;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -114,9 +113,8 @@ index 99cc1b8..9a1bdcc 100644
|
|||||||
+ copy_status = copy_file(f, backup_file);
|
+ copy_status = copy_file(f, backup_file);
|
||||||
+
|
+
|
||||||
+ if (copy_status != 0) {
|
+ if (copy_status != 0) {
|
||||||
+ statusbar(_("Error reading %s: %s"), realname,
|
+ statusline(ALERT, _("Error reading %s: %s"), realname,
|
||||||
+ strerror(errno));
|
+ strerror(errno));
|
||||||
+ beep();
|
|
||||||
+ goto cleanup_and_exit;
|
+ goto cleanup_and_exit;
|
||||||
+ }
|
+ }
|
||||||
+
|
+
|
||||||
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v1
|
|
||||||
|
|
||||||
iEYEABECAAYFAlbPd0AACgkQvLNW35EAn6fSYgCgvx6YZ/9x1YMgS7JFIdeOIfFP
|
|
||||||
q90An3TfqqstJqqW5imBLBLQv+htaa3i
|
|
||||||
=VHLC
|
|
||||||
-----END PGP SIGNATURE-----
|
|
11
nano-2.6.0.tar.gz.asc
Normal file
11
nano-2.6.0.tar.gz.asc
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v1
|
||||||
|
|
||||||
|
iQEcBAABAgAGBQJXZC7oAAoJEJ30hirxF1xbJIIH/i4sKTO+uY/ev361ldpTgeMq
|
||||||
|
ZNZvFvPJwnOqnwJNfnKQKDmSwDvXXwzHDTGTEQrJOImMbBA1HmmAojB+o1hkpdJm
|
||||||
|
T3WFEEGm9EXcBHzasLDlX6WmqZhVy0CbSapR12SNovxB02gkqneNUgcXB7q8FWHu
|
||||||
|
C+jMtCyWja0B8JpRZExAFRbXgD3iZ5YOpE4n6K1Abn93n5R1azcFLPBY9KTuGl90
|
||||||
|
DmJy9i3Oj08DhOuRguCQLuEfV565vqAOJJTxqdqWxi0AqmLCkV9utYKl3b9KMpbN
|
||||||
|
WrMB+b06TGaY2geIR3DEvbfYCp7IdJZcWTYes/BmhSuk4f4mJNve/i24uqxg4lw=
|
||||||
|
=I2JF
|
||||||
|
-----END PGP SIGNATURE-----
|
12
nano.spec
12
nano.spec
@ -1,13 +1,14 @@
|
|||||||
Summary: A small text editor
|
Summary: A small text editor
|
||||||
Name: nano
|
Name: nano
|
||||||
Version: 2.5.3
|
Version: 2.6.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/Editors
|
Group: Applications/Editors
|
||||||
URL: http://www.nano-editor.org
|
URL: http://www.nano-editor.org
|
||||||
Source: http://www.nano-editor.org/dist/v2.5/%{name}-%{version}.tar.gz
|
Source: http://www.nano-editor.org/dist/v2.6/%{name}-%{version}.tar.gz
|
||||||
Source2: nanorc
|
Source2: nanorc
|
||||||
Patch0: nano-2.3.3-warnings.patch
|
|
||||||
|
Patch1: 0001-fix-compile-time-warnings-in-nano-2.3.3.patch
|
||||||
|
|
||||||
# http://lists.gnu.org/archive/html/nano-devel/2010-08/msg00005.html
|
# http://lists.gnu.org/archive/html/nano-devel/2010-08/msg00005.html
|
||||||
Patch2: 0002-use-futimens-if-available-instead-of-utime.patch
|
Patch2: 0002-use-futimens-if-available-instead-of-utime.patch
|
||||||
@ -28,7 +29,7 @@ GNU nano is a small and friendly text editor.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
|
|
||||||
for f in doc/man/fr/{nano.1,nanorc.5,rnano.1} ; do
|
for f in doc/man/fr/{nano.1,nanorc.5,rnano.1} ; do
|
||||||
@ -92,6 +93,9 @@ exit 0
|
|||||||
%{_datadir}/nano
|
%{_datadir}/nano
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 20 2016 Kamil Dudka <kdudka@redhat.com> - 2.6.0-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
* Fri Feb 26 2016 Kamil Dudka <kdudka@redhat.com> - 2.5.3-1
|
* Fri Feb 26 2016 Kamil Dudka <kdudka@redhat.com> - 2.5.3-1
|
||||||
- new upstream release
|
- new upstream release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user