51 lines
2.0 KiB
Diff
51 lines
2.0 KiB
Diff
This patch is needed to improve the probability that the MySQL tests pass
|
|
in Red Hat's build environment. The 32-bit and 64-bit variants of a single
|
|
architecture may be built on the same machine at the same time, so we have
|
|
to ensure that the tests use different port numbers on a 64-bit arch than
|
|
on a 32-bit, else they will interfere with each other.
|
|
|
|
We also have to hack the top-level Makefile to enable the openssl regression
|
|
tests. (Why doesn't this happen automatically given the configure option??)
|
|
|
|
Note: keep an eye on which version of "mysql-test-run" gets invoked by
|
|
the "make test" target. In the 4.1 branch this is now defaulting to the
|
|
perl script, but 5.0 is not (yet?) doing that; they also seem to be fooling
|
|
with a C-code version. Besides this patch, mysql-libtool.patch
|
|
would need to be changed to use either one.
|
|
|
|
|
|
diff -Naur mysql-5.0.16.orig/Makefile.am mysql-5.0.16/Makefile.am
|
|
--- mysql-5.0.16.orig/Makefile.am 2005-11-14 19:12:31.000000000 -0500
|
|
+++ mysql-5.0.16/Makefile.am 2005-12-09 18:29:31.000000000 -0500
|
|
@@ -107,8 +107,8 @@
|
|
|
|
test:
|
|
cd mysql-test ; \
|
|
- ./mysql-test-run && \
|
|
- ./mysql-test-run --ps-protocol
|
|
+ ./mysql-test-run --with-openssl && \
|
|
+ ./mysql-test-run --ps-protocol --with-openssl
|
|
|
|
test-force:
|
|
cd mysql-test; \
|
|
diff -Naur mysql-5.0.16.orig/mysql-test/mysql-test-run.sh mysql-5.0.16/mysql-test/mysql-test-run.sh
|
|
--- mysql-5.0.16.orig/mysql-test/mysql-test-run.sh 2005-11-14 19:12:46.000000000 -0500
|
|
+++ mysql-5.0.16/mysql-test/mysql-test-run.sh 2005-12-09 18:34:09.000000000 -0500
|
|
@@ -222,6 +222,16 @@
|
|
# an environment variable can be used to control all ports. A small
|
|
# number is to be used, 0 - 16 or similar.
|
|
#
|
|
+# hack to allow 32- and 64-bit tests to run concurrently on same build machine
|
|
+case `uname -m` in
|
|
+ ppc64 | s390x | x86_64)
|
|
+ MTR_BUILD_THREAD=7
|
|
+ ;;
|
|
+ *)
|
|
+ MTR_BUILD_THREAD=11
|
|
+ ;;
|
|
+esac
|
|
+
|
|
if [ -n "$MTR_BUILD_THREAD" ] ; then
|
|
MASTER_MYPORT=`expr $MTR_BUILD_THREAD '*' 5 + 10000`
|
|
MYSQL_MANAGER_PORT=`expr $MASTER_MYPORT + 2`
|