17 lines
635 B
Diff
17 lines
635 B
Diff
mysql 5.5's new cmake-based build scripts forgot about defining
|
|
DEFAULT_HOME_ENV. Upstream at http://bugs.mysql.com/bug.php?id=59280
|
|
|
|
|
|
diff -Naur mysql-5.5.8.orig/mysys/CMakeLists.txt mysql-5.5.8/mysys/CMakeLists.txt
|
|
--- mysql-5.5.8.orig/mysys/CMakeLists.txt 2010-12-03 12:58:26.000000000 -0500
|
|
+++ mysql-5.5.8/mysys/CMakeLists.txt 2011-01-13 11:58:42.583471734 -0500
|
|
@@ -69,6 +69,8 @@
|
|
SET(MYSYS_SOURCES ${MYSYS_SOURCES} my_port.c)
|
|
ENDIF()
|
|
|
|
+ADD_DEFINITIONS( -DDEFAULT_HOME_ENV=MYSQL_HOME)
|
|
+
|
|
ADD_CONVENIENCE_LIBRARY(mysys ${MYSYS_SOURCES})
|
|
TARGET_LINK_LIBRARIES(mysys dbug strings ${ZLIB_LIBRARY}
|
|
${LIBNSL} ${LIBM} ${LIBRT})
|