46 lines
1.8 KiB
Diff
46 lines
1.8 KiB
Diff
Hack the top-level Makefile to enable the openssl regression tests.
|
|
(Why doesn't this happen automatically given the configure option??)
|
|
|
|
Also, tweak the Perl test script so that the mysqld daemon gets detached
|
|
from the calling terminal session. Without this, the ssl_des test hangs up
|
|
because OpenSSL tries to read a PEM key from /dev/tty.
|
|
|
|
|
|
diff -Naur mysql-5.1.30.orig/Makefile.am mysql-5.1.30/Makefile.am
|
|
--- mysql-5.1.30.orig/Makefile.am 2008-11-14 11:34:15.000000000 -0500
|
|
+++ mysql-5.1.30/Makefile.am 2009-01-13 11:13:12.000000000 -0500
|
|
@@ -98,7 +98,7 @@
|
|
|
|
test-ns:
|
|
cd mysql-test ; \
|
|
- @PERL@ ./mysql-test-run.pl $(force) $(mem) --mysqld=--binlog-format=mixed
|
|
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ssl --mysqld=--binlog-format=mixed
|
|
|
|
test-binlog-statement:
|
|
cd mysql-test ; \
|
|
diff -Naur mysql-5.1.30.orig/mysql-test/lib/mtr_process.pl mysql-5.1.30/mysql-test/lib/mtr_process.pl
|
|
--- mysql-5.1.30.orig/mysql-test/lib/mtr_process.pl 2008-11-14 12:31:10.000000000 -0500
|
|
+++ mysql-5.1.30/mysql-test/lib/mtr_process.pl 2009-01-13 11:14:25.000000000 -0500
|
|
@@ -150,6 +150,9 @@
|
|
{
|
|
# Child, redirect output and exec
|
|
|
|
+ # Needed to become detached from terminal session
|
|
+ POSIX::setsid();
|
|
+
|
|
$SIG{INT}= 'DEFAULT'; # Parent do some stuff, we don't
|
|
|
|
my $log_file_open_mode = '>';
|
|
diff -Naur mysql-5.1.30.orig/mysql-test/mysql-test-run.pl mysql-5.1.30/mysql-test/mysql-test-run.pl
|
|
--- mysql-5.1.30.orig/mysql-test/mysql-test-run.pl 2008-11-14 11:34:48.000000000 -0500
|
|
+++ mysql-5.1.30/mysql-test/mysql-test-run.pl 2009-01-13 11:17:52.000000000 -0500
|
|
@@ -4204,7 +4204,7 @@
|
|
|
|
if ( defined $exe )
|
|
{
|
|
- $pid= mtr_spawn($exe, $args, "",
|
|
+ $pid= mtr_spawn($exe, $args, '/dev/null',
|
|
$mysqld->{'path_myerr'},
|
|
$mysqld->{'path_myerr'},
|
|
"",
|