mysql8.4/mysql-testing.patch

48 lines
1.8 KiB
Diff

Hack the top-level Makefile to enable the openssl regression tests.
(Why doesn't this happen automatically given the configure option??)
Also, tweak the Perl test script so that the mysqld daemon gets detached
from the calling terminal session. Without this, the ssl_des test hangs up
because OpenSSL tries to read a PEM key from /dev/tty.
diff -Naur mysql-5.0.33.orig/Makefile.am mysql-5.0.33/Makefile.am
--- mysql-5.0.33.orig/Makefile.am 2007-01-09 07:51:07.000000000 -0500
+++ mysql-5.0.33/Makefile.am 2007-02-09 13:37:00.000000000 -0500
@@ -121,8 +121,8 @@
test:
cd mysql-test ; \
- ./mysql-test-run && \
- ./mysql-test-run --ps-protocol
+ ./mysql-test-run --ssl && \
+ ./mysql-test-run --ps-protocol --ssl
test-force:
cd mysql-test; \
diff -Naur mysql-5.0.33.orig/mysql-test/lib/mtr_process.pl mysql-5.0.33/mysql-test/lib/mtr_process.pl
--- mysql-5.0.33.orig/mysql-test/lib/mtr_process.pl 2007-01-09 08:09:33.000000000 -0500
+++ mysql-5.0.33/mysql-test/lib/mtr_process.pl 2007-02-09 13:36:05.000000000 -0500
@@ -147,6 +147,9 @@
# became a deamon as well, and was hard to kill ;-)
# Need to catch SIGCHLD and do waitpid or something instead......
+ # dunno, it works for me ...
+ POSIX::setsid();
+
$SIG{INT}= 'DEFAULT'; # Parent do some stuff, we don't
my $log_file_open_mode = '>';
diff -Naur mysql-5.0.33.orig/mysql-test/mysql-test-run.pl mysql-5.0.33/mysql-test/mysql-test-run.pl
--- mysql-5.0.33.orig/mysql-test/mysql-test-run.pl 2007-01-09 07:51:07.000000000 -0500
+++ mysql-5.0.33/mysql-test/mysql-test-run.pl 2007-02-09 13:36:27.000000000 -0500
@@ -3862,7 +3862,7 @@
if ( defined $exe )
{
- $pid= mtr_spawn($exe, $args, "",
+ $pid= mtr_spawn($exe, $args, '/dev/null',
$mysqld->{'path_myerr'},
$mysqld->{'path_myerr'},
"",