58 lines
1.4 KiB
Diff
58 lines
1.4 KiB
Diff
The idea of userland using <asm/atomic.h> has our kernel hackers all bent
|
|
out of shape, so don't do it. Suppressing this has another benefit too,
|
|
which is we avoid the 4-vs-8-byte problem in BDB that formerly required
|
|
mysql-threads.patch.
|
|
|
|
|
|
diff -Naur mysql-5.0.21.orig/configure.in mysql-5.0.21/configure.in
|
|
--- mysql-5.0.21.orig/configure.in 2006-04-26 14:31:03.000000000 -0400
|
|
+++ mysql-5.0.21/configure.in 2006-05-01 20:52:08.000000000 -0400
|
|
@@ -803,47 +803,6 @@
|
|
AC_SUBST(WRAPLIBS)
|
|
|
|
if test "$TARGET_LINUX" = "true"; then
|
|
- AC_MSG_CHECKING([for atomic operations])
|
|
-
|
|
- AC_LANG_SAVE
|
|
- AC_LANG_CPLUSPLUS
|
|
-
|
|
- atom_ops=
|
|
- AC_TRY_RUN([
|
|
-#include <asm/atomic.h>
|
|
-int main()
|
|
-{
|
|
- atomic_t v;
|
|
-
|
|
- atomic_set(&v, 23);
|
|
- atomic_add(5, &v);
|
|
- return atomic_read(&v) == 28 ? 0 : -1;
|
|
-}
|
|
- ],
|
|
- [AC_DEFINE([HAVE_ATOMIC_ADD], [1],
|
|
- [atomic_add() from <asm/atomic.h> (Linux only)])
|
|
- atom_ops="${atom_ops}atomic_add "],
|
|
- )
|
|
- AC_TRY_RUN([
|
|
-#include <asm/atomic.h>
|
|
-int main()
|
|
-{
|
|
- atomic_t v;
|
|
-
|
|
- atomic_set(&v, 23);
|
|
- atomic_sub(5, &v);
|
|
- return atomic_read(&v) == 18 ? 0 : -1;
|
|
-}
|
|
- ],
|
|
- [AC_DEFINE([HAVE_ATOMIC_SUB], [1],
|
|
- [atomic_sub() from <asm/atomic.h> (Linux only)])
|
|
- atom_ops="${atom_ops}atomic_sub "],
|
|
- )
|
|
-
|
|
- if test -z "$atom_ops"; then atom_ops="no"; fi
|
|
- AC_MSG_RESULT($atom_ops)
|
|
-
|
|
- AC_LANG_RESTORE
|
|
|
|
AC_ARG_WITH(pstack,
|
|
[ --with-pstack Use the pstack backtrace library],
|