Remove mysql-cluster, which is no longer supported by upstream in this

source distribution.
This commit is contained in:
Tom Lane 2010-02-14 02:55:17 +00:00 committed by Michal Schorm
parent 021d6527f9
commit f8d32ebcee
8 changed files with 17 additions and 467 deletions

15
my.cnf
View File

@ -5,21 +5,6 @@ user=mysql
# Disabling symbolic-links is recommended to prevent assorted security risks # Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0 symbolic-links=0
# To allow mysqld to connect to a MySQL Cluster management daemon, uncomment
# these lines and adjust the connectstring as needed.
#ndbcluster
#ndb-connectstring="nodeid=4;host=localhost:1186"
[mysqld_safe] [mysqld_safe]
log-error=/var/log/mysqld.log log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid pid-file=/var/run/mysqld/mysqld.pid
[ndbd]
# If you are running a MySQL Cluster storage daemon (ndbd) on this machine,
# adjust its connection to the management daemon here.
# Note: ndbd init script requires this to include nodeid!
connect-string="nodeid=2;host=localhost:1186"
[ndb_mgm]
# connection string for MySQL Cluster management tool
connect-string="host=localhost:1186"

View File

@ -4,10 +4,10 @@ like /usr/share/mysql-test, we have to hack up the paths in mtr_cases.pm.
This patch also improves the documentation a tad. This patch also improves the documentation a tad.
diff -Naur mysql-5.1.30.orig/mysql-test/README mysql-5.1.30/mysql-test/README diff -Naur mysql-5.1.43.orig/mysql-test/README mysql-5.1.43/mysql-test/README
--- mysql-5.1.30.orig/mysql-test/README 2008-11-14 11:34:38.000000000 -0500 --- mysql-5.1.43.orig/mysql-test/README 2010-01-15 12:14:43.000000000 -0500
+++ mysql-5.1.30/mysql-test/README 2009-01-13 11:30:00.000000000 -0500 +++ mysql-5.1.43/mysql-test/README 2010-02-13 21:18:06.000000000 -0500
@@ -6,6 +6,19 @@ @@ -6,6 +6,16 @@
actually have a co-existing MySQL installation. The tests will not actually have a co-existing MySQL installation. The tests will not
conflict with it. conflict with it.
@ -17,17 +17,14 @@ diff -Naur mysql-5.1.30.orig/mysql-test/README mysql-5.1.30/mysql-test/README
+ sudo -u mysql ./mysql-test-run + sudo -u mysql ./mysql-test-run
+This will use the installed mysql executables, but will run a private copy +This will use the installed mysql executables, but will run a private copy
+of the server process (using data files within /usr/share/mysql-test), +of the server process (using data files within /usr/share/mysql-test),
+so you need not start the mysqld service beforehand. If you have not +so you need not start the mysqld service beforehand.
+installed mysql-cluster, use +To clean up afterwards, remove the created "var" subdirectory, eg
+ sudo -u mysql ./mysql-test-run --skip-ndbcluster
+to skip the cluster-related tests. To clean up afterwards, remove the
+created "var" subdirectory, eg
+ sudo -u mysql rm -rf /usr/share/mysql-test/var + sudo -u mysql rm -rf /usr/share/mysql-test/var
+ +
All tests must pass. If one or more of them fail on your system, please All tests must pass. If one or more of them fail on your system, please
read the following manual section for instructions on how to report the read the following manual section for instructions on how to report the
problem: problem:
@@ -25,7 +38,8 @@ @@ -25,7 +35,8 @@
With no test cases named on the command line, mysql-test-run falls back With no test cases named on the command line, mysql-test-run falls back
to the normal "non-extern" behavior. The reason for this is that some to the normal "non-extern" behavior. The reason for this is that some
@ -37,10 +34,10 @@ diff -Naur mysql-5.1.30.orig/mysql-test/README mysql-5.1.30/mysql-test/README
You can create your own test cases. To create a test case, create a new You can create your own test cases. To create a test case, create a new
diff -Naur mysql-5.1.32.orig/mysql-test/lib/mtr_cases.pm mysql-5.1.32/mysql-test/lib/mtr_cases.pm diff -Naur mysql-5.1.43.orig/mysql-test/lib/mtr_cases.pm mysql-5.1.43/mysql-test/lib/mtr_cases.pm
--- mysql-5.1.32.orig/mysql-test/lib/mtr_cases.pm 2009-02-13 19:52:34.000000000 -0500 --- mysql-5.1.43.orig/mysql-test/lib/mtr_cases.pm 2010-01-15 12:14:49.000000000 -0500
+++ mysql-5.1.32/mysql-test/lib/mtr_cases.pm 2009-03-04 20:34:23.000000000 -0500 +++ mysql-5.1.43/mysql-test/lib/mtr_cases.pm 2010-02-13 21:17:30.000000000 -0500
@@ -228,7 +228,9 @@ @@ -259,7 +259,9 @@
else else
{ {
$suitedir= my_find_dir($::basedir, $suitedir= my_find_dir($::basedir,

View File

@ -1,31 +0,0 @@
Raise minimum stack size in ndb code to be a uniform 32K (64K on 64-bit
platforms). This is in response to an episode where glibc needed 8K of
stack to run malloc(), resulting in ndbd crashing at launch. While that
was acknowledged to be a glibc bug (see bz #494631), byte-shaving here
isn't any better an idea than it is in the main mysql server.
Note: the request gets rounded up to at least PTHREAD_STACK_MIN, which
is 128K on PPC; otherwise we would need to do something about including
the stack guard size explicitly, since it's so much larger on PPC than
elsewhere. At some point we might want to use our my_setstacksize()
hack in NdbThread_Create().
diff -Naur mysql-5.1.39.orig/storage/ndb/src/kernel/blocks/ndbfs/AsyncFile.cpp mysql-5.1.39/storage/ndb/src/kernel/blocks/ndbfs/AsyncFile.cpp
--- mysql-5.1.39.orig/storage/ndb/src/kernel/blocks/ndbfs/AsyncFile.cpp 2009-09-04 12:21:19.000000000 -0400
+++ mysql-5.1.39/storage/ndb/src/kernel/blocks/ndbfs/AsyncFile.cpp 2009-09-21 22:33:08.000000000 -0400
@@ -106,13 +106,8 @@
AsyncFile::doStart()
{
// Stacksize for filesystem threads
-#if !defined(DBUG_OFF) && defined (__hpux)
- // Empirical evidence indicates at least 32k
+ // don't make this too small
const NDB_THREAD_STACKSIZE stackSize = 32768;
-#else
- // Otherwise an 8k stack should be enough
- const NDB_THREAD_STACKSIZE stackSize = 8192;
-#endif
char buf[16];
numAsyncFiles++;

View File

@ -1,38 +0,0 @@
Fix a bit of silliness; the original coding not only computes the required
size of the temp variable incorrectly, but doesn't guarantee the correct
alignment. This demonstrably leads to ndbd crashing at launch on sparc64,
and is probably bad news for performance on other 64-bit machines even
if they don't give an actual SIGBUS.
Filed upstream at http://bugs.mysql.com/bug.php?id=48132
diff -Naur mysql-5.1.39.orig/storage/ndb/src/kernel/blocks/dbtup/DbtupRoutines.cpp mysql-5.1.39/storage/ndb/src/kernel/blocks/dbtup/DbtupRoutines.cpp
--- mysql-5.1.39.orig/storage/ndb/src/kernel/blocks/dbtup/DbtupRoutines.cpp 2009-09-04 12:21:18.000000000 -0400
+++ mysql-5.1.39/storage/ndb/src/kernel/blocks/dbtup/DbtupRoutines.cpp 2009-10-17 14:24:56.000000000 -0400
@@ -1144,8 +1144,9 @@
KeyReqStruct *req_struct,
Uint32* outBuffer)
{
- Uint32 tmp[sizeof(SignalHeader)+25];
- Signal * signal = (Signal*)&tmp;
+ SignalT<25> signalT;
+ Signal *signal= (Signal*)&signalT;
+
switch(attrId){
case AttributeHeader::FRAGMENT:
* outBuffer = fragptr.p->fragmentId;
diff -Naur mysql-5.1.39.orig/storage/ndb/src/kernel/blocks/ndbfs/AsyncFile.cpp mysql-5.1.39/storage/ndb/src/kernel/blocks/ndbfs/AsyncFile.cpp
--- mysql-5.1.39.orig/storage/ndb/src/kernel/blocks/ndbfs/AsyncFile.cpp 2009-09-04 12:21:19.000000000 -0400
+++ mysql-5.1.39/storage/ndb/src/kernel/blocks/ndbfs/AsyncFile.cpp 2009-10-17 14:26:21.000000000 -0400
@@ -529,8 +529,8 @@
{
off_t off = 0;
const off_t sz = request->par.open.file_size;
- Uint32 tmp[sizeof(SignalHeader)+25];
- Signal * signal = (Signal*)(&tmp[0]);
+ SignalT<25> signalT;
+ Signal *signal= (Signal*)&signalT;
FsReadWriteReq* req = (FsReadWriteReq*)signal->getDataPtrSend();
Uint32 index = 0;

View File

@ -1,6 +1,6 @@
Name: mysql Name: mysql
Version: 5.1.43 Version: 5.1.43
Release: 1%{?dist} Release: 2%{?dist}
Summary: MySQL client programs and shared libraries Summary: MySQL client programs and shared libraries
Group: Applications/Databases Group: Applications/Databases
URL: http://www.mysql.com URL: http://www.mysql.com
@ -19,9 +19,6 @@ Source1: mysql.init
Source3: my.cnf Source3: my.cnf
Source4: scriptstub.c Source4: scriptstub.c
Source5: my_config.h Source5: my_config.h
Source6: ndbd.init
Source7: ndb_mgmd.init
Source8: ndb_types.h
Source9: mysql-embedded-check.c Source9: mysql-embedded-check.c
# Working around perl dependency checking bug in rpm FTTB. Remove later. # Working around perl dependency checking bug in rpm FTTB. Remove later.
Source999: filter-requires-mysql.sh Source999: filter-requires-mysql.sh
@ -34,9 +31,7 @@ Patch5: mysql-install-test.patch
Patch6: mysql-stack-guard.patch Patch6: mysql-stack-guard.patch
Patch7: mysql-plugin-bug.patch Patch7: mysql-plugin-bug.patch
Patch8: mysql-setschedparam.patch Patch8: mysql-setschedparam.patch
Patch9: mysql-ndb-stacksize.patch
Patch10: mysql-strmov.patch Patch10: mysql-strmov.patch
Patch11: mysql-signal-align.patch
Patch12: mysql-cve-2008-7247.patch Patch12: mysql-cve-2008-7247.patch
Patch13: mysql-expired-certs.patch Patch13: mysql-expired-certs.patch
@ -93,22 +88,6 @@ client/server implementation consisting of a server daemon (mysqld)
and many different client programs and libraries. This package contains and many different client programs and libraries. This package contains
the MySQL server and some accompanying files and directories. the MySQL server and some accompanying files and directories.
%package cluster
Summary: MySQL Cluster daemons and related files
Group: Applications/Databases
Requires: %{name} = %{version}-%{release}
Conflicts: MySQL-storage-cluster
Conflicts: MySQL-management-cluster
Conflicts: MySQL-tools-cluster
Conflicts: MySQL-extra-cluster
%description cluster
MySQL is a multi-user, multi-threaded SQL database server.
MySQL Cluster is a distributed in-memory data store that can be accessed
by a MySQL server. This package contains the programs needed to run a MySQL
Cluster installation.
%package devel %package devel
Summary: Files for development of MySQL applications Summary: Files for development of MySQL applications
@ -180,9 +159,7 @@ the MySQL sources.
%patch6 -p1 %patch6 -p1
%patch7 -p1 %patch7 -p1
%patch8 -p1 %patch8 -p1
%patch9 -p1
%patch10 -p1 %patch10 -p1
%patch11 -p1
%patch12 -p1 %patch12 -p1
%patch13 -p1 %patch13 -p1
@ -236,7 +213,6 @@ export CFLAGS CXXFLAGS
--with-big-tables \ --with-big-tables \
--with-pic \ --with-pic \
--with-plugin-innobase \ --with-plugin-innobase \
--with-plugin-ndbcluster \
--without-plugin-innodb_plugin \ --without-plugin-innodb_plugin \
--enable-local-infile \ --enable-local-infile \
--enable-largefile \ --enable-largefile \
@ -294,8 +270,6 @@ case `uname -i` in
i386 | x86_64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 ) i386 | x86_64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
mv $RPM_BUILD_ROOT/usr/include/mysql/my_config.h $RPM_BUILD_ROOT/usr/include/mysql/my_config_`uname -i`.h mv $RPM_BUILD_ROOT/usr/include/mysql/my_config.h $RPM_BUILD_ROOT/usr/include/mysql/my_config_`uname -i`.h
install -m 644 %{SOURCE5} $RPM_BUILD_ROOT/usr/include/mysql/ install -m 644 %{SOURCE5} $RPM_BUILD_ROOT/usr/include/mysql/
mv $RPM_BUILD_ROOT/usr/include/mysql/storage/ndb/ndb_types.h $RPM_BUILD_ROOT/usr/include/mysql/storage/ndb/ndb_types_`uname -i`.h
install -m 644 %{SOURCE8} $RPM_BUILD_ROOT/usr/include/mysql/storage/ndb/
;; ;;
*) *)
;; ;;
@ -312,11 +286,8 @@ gzip ${RPM_BUILD_ROOT}%{_infodir}/*
mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
mkdir -p $RPM_BUILD_ROOT/var/run/mysqld mkdir -p $RPM_BUILD_ROOT/var/run/mysqld
install -m 0755 -d $RPM_BUILD_ROOT/var/lib/mysql install -m 0755 -d $RPM_BUILD_ROOT/var/lib/mysql
install -m 0755 -d $RPM_BUILD_ROOT/var/lib/mysql-cluster
install -m 0755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysqld install -m 0755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysqld
install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT/etc/my.cnf install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT/etc/my.cnf
install -m 0755 %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/ndbd
install -m 0755 %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/ndb_mgmd
rm -f $RPM_BUILD_ROOT/%{_infodir}/dir* rm -f $RPM_BUILD_ROOT/%{_infodir}/dir*
mv $RPM_BUILD_ROOT/usr/sql-bench $RPM_BUILD_ROOT%{_datadir}/sql-bench mv $RPM_BUILD_ROOT/usr/sql-bench $RPM_BUILD_ROOT%{_datadir}/sql-bench
mv $RPM_BUILD_ROOT/usr/mysql-test $RPM_BUILD_ROOT%{_datadir}/mysql-test mv $RPM_BUILD_ROOT/usr/mysql-test $RPM_BUILD_ROOT%{_datadir}/mysql-test
@ -340,7 +311,6 @@ rm -f ${RPM_BUILD_ROOT}%{_bindir}/make_win_src_distribution
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/make_win_bin_dist.1* rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/make_win_bin_dist.1*
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/make_win_src_distribution.1* rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/make_win_src_distribution.1*
rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/libmysqlclient*.la rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/libmysqlclient*.la
rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/libndbclient.la
rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/*.a rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/*.a
rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/plugin/*.la rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/plugin/*.la
rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/plugin/*.a rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/plugin/*.a
@ -348,6 +318,7 @@ rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/binary-configure
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/make_binary_distribution rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/make_binary_distribution
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/make_sharedlib_distribution rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/make_sharedlib_distribution
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mi_test_all* rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mi_test_all*
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/ndb-config-2-node.ini
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mysql.server rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mysql.server
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mysqld_multi.server rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mysqld_multi.server
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/MySQL-shared-compat.spec rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/MySQL-shared-compat.spec
@ -359,12 +330,6 @@ rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mysql-log-rotate
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/ChangeLog rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/ChangeLog
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/mysql-stress-test.pl.1* rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/mysql-stress-test.pl.1*
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/mysql-test-run.pl.1* rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/mysql-test-run.pl.1*
rm -f ${RPM_BUILD_ROOT}/usr/libexec/ndb_cpcd
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/ndb_cpcd.1*
# for the moment, remove ndb_size because of dependency on HTML::Template
rm -f ${RPM_BUILD_ROOT}%{_bindir}/ndb_size.pl
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/ndb_size.pl.1*
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/ndb_size.tmpl
mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
echo "%{_libdir}/mysql" > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{name}-%{_arch}.conf echo "%{_libdir}/mysql" > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{name}-%{_arch}.conf
@ -376,10 +341,6 @@ rm -rf $RPM_BUILD_ROOT
/usr/sbin/useradd -M -o -r -d /var/lib/mysql -s /bin/bash \ /usr/sbin/useradd -M -o -r -d /var/lib/mysql -s /bin/bash \
-c "MySQL Server" -u 27 mysql > /dev/null 2>&1 || : -c "MySQL Server" -u 27 mysql > /dev/null 2>&1 || :
%pre cluster
/usr/sbin/useradd -M -o -r -d /var/lib/mysql -s /bin/bash \
-c "MySQL Server" -u 27 mysql > /dev/null 2>&1 || :
%post %post
/sbin/install-info %{_infodir}/mysql.info.gz %{_infodir}/dir /sbin/install-info %{_infodir}/mysql.info.gz %{_infodir}/dir
@ -393,13 +354,6 @@ fi
/bin/chmod 0755 /var/lib/mysql /bin/chmod 0755 /var/lib/mysql
/bin/touch /var/log/mysqld.log /bin/touch /var/log/mysqld.log
%post cluster
if [ $1 = 1 ]; then
/sbin/chkconfig --add ndbd
/sbin/chkconfig --add ndb_mgmd
fi
/bin/chmod 0755 /var/lib/mysql-cluster
%preun %preun
if [ $1 = 0 ]; then if [ $1 = 0 ]; then
/sbin/install-info --delete %{_infodir}/mysql.info.gz %{_infodir}/dir || : /sbin/install-info --delete %{_infodir}/mysql.info.gz %{_infodir}/dir || :
@ -410,12 +364,6 @@ if [ $1 = 0 ]; then
/sbin/chkconfig --del mysqld /sbin/chkconfig --del mysqld
fi fi
%preun cluster
if [ $1 = 0 ]; then
/sbin/chkconfig --del ndb_mgmd
/sbin/chkconfig --del ndbd
fi
%postun libs %postun libs
if [ $1 = 0 ] ; then if [ $1 = 0 ] ; then
/sbin/ldconfig /sbin/ldconfig
@ -427,12 +375,6 @@ if [ $1 -ge 1 ]; then
/sbin/service mysqld condrestart >/dev/null 2>&1 || : /sbin/service mysqld condrestart >/dev/null 2>&1 || :
fi fi
%postun cluster
if [ $1 -ge 1 ]; then
/sbin/service ndb_mgmd condrestart >/dev/null 2>&1 || :
/sbin/service ndbd condrestart >/dev/null 2>&1 || :
fi
%files %files
%defattr(-,root,root) %defattr(-,root,root)
@ -478,7 +420,6 @@ fi
%dir %{_libdir}/mysql %dir %{_libdir}/mysql
%{_libdir}/mysql/libmysqlclient*.so.* %{_libdir}/mysql/libmysqlclient*.so.*
%{_libdir}/mysql/libndbclient.so.*
/etc/ld.so.conf.d/* /etc/ld.so.conf.d/*
%dir %{_datadir}/mysql %dir %{_datadir}/mysql
@ -588,63 +529,11 @@ fi
%attr(0755,mysql,mysql) %dir /var/lib/mysql %attr(0755,mysql,mysql) %dir /var/lib/mysql
%attr(0640,mysql,mysql) %config(noreplace) %verify(not md5 size mtime) /var/log/mysqld.log %attr(0640,mysql,mysql) %config(noreplace) %verify(not md5 size mtime) /var/log/mysqld.log
%files cluster
%defattr(-,root,root)
%{_bindir}/ndb_config
%{_bindir}/ndb_delete_all
%{_bindir}/ndb_desc
%{_bindir}/ndb_drop_index
%{_bindir}/ndb_drop_table
%{_bindir}/ndb_error_reporter
%{_bindir}/ndb_mgm
%{_bindir}/ndb_print_backup_file
%{_bindir}/ndb_print_schema_file
%{_bindir}/ndb_print_sys_file
%{_bindir}/ndb_restore
%{_bindir}/ndb_select_all
%{_bindir}/ndb_select_count
%{_bindir}/ndb_show_tables
#%{_bindir}/ndb_size.pl
%{_bindir}/ndb_test_platform
%{_bindir}/ndb_waiter
/usr/libexec/ndb_mgmd
/usr/libexec/ndbd
%{_datadir}/mysql/ndb-*.ini
#%{_datadir}/mysql/ndb_size.tmpl
/etc/rc.d/init.d/ndbd
/etc/rc.d/init.d/ndb_mgmd
%attr(0755,mysql,mysql) %dir /var/lib/mysql-cluster
%{_mandir}/man1/ndb_config.1*
%{_mandir}/man1/ndb_delete_all.1*
%{_mandir}/man1/ndb_desc.1*
%{_mandir}/man1/ndb_drop_index.1*
%{_mandir}/man1/ndb_drop_table.1*
%{_mandir}/man1/ndb_error_reporter.1*
%{_mandir}/man1/ndb_mgm.1*
%{_mandir}/man1/ndb_print_backup_file.1*
%{_mandir}/man1/ndb_print_schema_file.1*
%{_mandir}/man1/ndb_print_sys_file.1*
%{_mandir}/man1/ndb_restore.1*
%{_mandir}/man1/ndb_select_all.1*
%{_mandir}/man1/ndb_select_count.1*
%{_mandir}/man1/ndb_show_tables.1*
#%{_mandir}/man1/ndb_size.pl.1*
%{_mandir}/man1/ndb_waiter.1*
%{_mandir}/man1/ndbd_redo_log_reader.1*
%{_mandir}/man8/ndbd.8*
%{_mandir}/man8/ndbmtd.8*
%{_mandir}/man8/ndb_mgmd.8*
%files devel %files devel
%defattr(-,root,root) %defattr(-,root,root)
/usr/include/mysql /usr/include/mysql
/usr/share/aclocal/mysql.m4 /usr/share/aclocal/mysql.m4
%{_libdir}/mysql/libmysqlclient*.so %{_libdir}/mysql/libmysqlclient*.so
%{_libdir}/mysql/libndbclient.so
%files embedded %files embedded
%defattr(-,root,root) %defattr(-,root,root)
@ -670,6 +559,10 @@ fi
%{_mandir}/man1/mysql_client_test.1* %{_mandir}/man1/mysql_client_test.1*
%changelog %changelog
* Sat Feb 13 2010 Tom Lane <tgl@redhat.com> 5.1.43-2
- Remove mysql-cluster, which is no longer supported by upstream in this
source distribution. If we want it we'll need a separate SRPM for it.
* Fri Feb 12 2010 Tom Lane <tgl@redhat.com> 5.1.43-1 * Fri Feb 12 2010 Tom Lane <tgl@redhat.com> 5.1.43-1
- Update to MySQL 5.1.43, for various fixes described at - Update to MySQL 5.1.43, for various fixes described at
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-43.html http://dev.mysql.com/doc/refman/5.1/en/news-5-1-43.html

View File

@ -1,116 +0,0 @@
#!/bin/bash
#
# ndb_mgmd This shell script takes care of starting and stopping
# the MySQL Cluster management daemon (ndb_mgmd).
#
# chkconfig: - 62 38
# description: MySQL Cluster management daemon.
# processname: ndb_mgmd
# config: /var/lib/mysql-cluster/config.ini
# pidfile: /var/lib/mysql-cluster/ndb_${node_id}.pid
# Source function library.
. /etc/rc.d/init.d/functions
# Source networking configuration.
. /etc/sysconfig/network
prog="ndb_mgmd"
# extract value of a MySQL option from config files
# Usage: get_mysql_option SECTION VARNAME DEFAULT
# result is returned in $result
# We use my_print_defaults which prints all options from multiple files,
# with the more specific ones later; hence take the last match.
get_mysql_option(){
result=`/usr/bin/my_print_defaults --extra-file=/var/lib/mysql-cluster/config.ini "$1" | sed -n "s/^--$2=//p" | tail -n 1`
if [ -z "$result" ]; then
# not found, use default
result="$3"
fi
}
get_mysql_option ndb_mgmd id "1"
node_id="$result"
errlogfile="/var/lib/mysql-cluster/ndb_${node_id}_out.log"
pidfile="/var/lib/mysql-cluster/ndb_${node_id}.pid"
# For SELinux we need to use 'runuser' not 'su'
if [ -x /sbin/runuser ]
then
SU=runuser
else
SU=su
fi
start(){
touch "$errlogfile"
chown mysql:mysql "$errlogfile"
chmod 0640 "$errlogfile"
[ -x /sbin/restorecon ] && /sbin/restorecon "$errlogfile"
# all options are expected to be specified in
# /var/lib/mysql-cluster/config.ini.
$SU -l mysql -c "cd /var/lib/mysql-cluster; /usr/libexec/ndb_mgmd" >> "$errlogfile" 2>&1 < /dev/null
ret=$?
if [ $ret -eq 0 ]; then
action $"Starting $prog: " /bin/true
else
action $"Starting $prog: " /bin/false
fi
[ $ret -eq 0 ] && touch /var/lock/subsys/ndb_mgmd
return $ret
}
stop(){
NDB_MGMD_PID=`cat "$pidfile" 2>/dev/null `
if [ -n "$NDB_MGMD_PID" ]; then
/usr/bin/ndb_mgm -e shutdown >/dev/null
ret=$?
if [ $ret -eq 0 ]; then
rm -f /var/lock/subsys/ndb_mgmd
rm -f "$pidfile"
action $"Stopping $prog: " /bin/true
else
action $"Stopping $prog: " /bin/false
fi
else
ret=1
action $"Stopping $prog: " /bin/false
fi
return $ret
}
restart(){
stop
start
}
condrestart(){
[ -e /var/lock/subsys/ndb_mgmd ] && restart || :
}
# See how we were called.
case "$1" in
start)
start
;;
stop)
stop
;;
status)
status ndb_mgmd
;;
restart)
restart
;;
condrestart)
condrestart
;;
*)
echo $"Usage: $0 {start|stop|status|condrestart|restart}"
exit 1
esac
exit $?

View File

@ -1,29 +0,0 @@
/*
* Kluge to support multilib installation of both 32- and 64-bit RPMS:
* we need to arrange that header files that appear in both RPMs are
* identical. Hence, this file is architecture-independent and calls
* in an arch-dependent file that will appear in just one RPM.
*
* To avoid breaking arches not explicitly supported by Red Hat, we
* use this indirection file *only* on known multilib arches.
*
* Note: this may well fail if user tries to use gcc's -I- option.
* But that option is deprecated anyway.
*/
#if defined(__x86_64__)
#include "ndb_types_x86_64.h"
#elif defined(__i386__)
#include "ndb_types_i386.h"
#elif defined(__ppc64__) || defined(__powerpc64__)
#include "ndb_types_ppc64.h"
#elif defined(__ppc__) || defined(__powerpc__)
#include "ndb_types_ppc.h"
#elif defined(__s390x__)
#include "ndb_types_s390x.h"
#elif defined(__s390__)
#include "ndb_types_s390.h"
#elif defined(__sparc__) && defined(__arch64__)
#include "ndb_types_sparc64.h"
#elif defined(__sparc__)
#include "ndb_types_sparc.h"
#endif

111
ndbd.init
View File

@ -1,111 +0,0 @@
#!/bin/bash
#
# ndbd This shell script takes care of starting and stopping
# the MySQL Cluster data node daemon (ndbd).
#
# chkconfig: - 63 37
# description: MySQL Cluster data node daemon.
# processname: ndbd
# config: /etc/my.cnf
# pidfile: /var/lib/mysql-cluster/ndb_${node_id}.pid
# Source function library.
. /etc/rc.d/init.d/functions
# Source networking configuration.
. /etc/sysconfig/network
prog="ndbd"
# extract value of a MySQL option from config files
# Usage: get_mysql_option SECTION VARNAME DEFAULT
# result is returned in $result
# We use my_print_defaults which prints all options from multiple files,
# with the more specific ones later; hence take the last match.
get_mysql_option(){
result=`/usr/bin/my_print_defaults "$1" | sed -n "s/^--$2=//p" | tail -n 1`
if [ -z "$result" ]; then
# not found, use default
result="$3"
fi
}
get_mysql_option ndbd connect-string "nodeid=2;host=localhost:1186"
ndbd_connect_string="$result"
node_id=`echo "$result" | sed 's/^nodeid=\([0-9]*\);.*$/\1/'`
connect_string=`echo "$result" | sed 's/^.*host=//'`
pidfile="/var/lib/mysql-cluster/ndb_${node_id}.pid"
# For SELinux we need to use 'runuser' not 'su'
if [ -x /sbin/runuser ]
then
SU=runuser
else
SU=su
fi
start(){
# all options are expected to be specified in /etc/my.cnf
$SU -l mysql -c "/usr/libexec/ndbd" >/dev/null 2>&1
ret=$?
if [ $ret -eq 0 ]; then
action $"Starting $prog: " /bin/true
else
action $"Starting $prog: " /bin/false
fi
[ $ret -eq 0 ] && touch /var/lock/subsys/ndbd
return $ret
}
stop(){
NDBD_PID=`cat "$pidfile" 2>/dev/null `
if [ -n "$NDBD_PID" ]; then
/usr/bin/ndb_mgm -e "$node_id STOP" "$connect_string" >/dev/null
ret=$?
if [ $ret -eq 0 ]; then
rm -f /var/lock/subsys/ndbd
rm -f "$pidfile"
action $"Stopping $prog: " /bin/true
else
action $"Stopping $prog: " /bin/false
fi
else
ret=1
action $"Stopping $prog: " /bin/false
fi
return $ret
}
restart(){
stop
start
}
condrestart(){
[ -e /var/lock/subsys/ndbd ] && restart || :
}
# See how we were called.
case "$1" in
start)
start
;;
stop)
stop
;;
status)
status ndbd
;;
restart)
restart
;;
condrestart)
condrestart
;;
*)
echo $"Usage: $0 {start|stop|status|condrestart|restart}"
exit 1
esac
exit $?