Update devel branch to MySQL 4.1.7.
This commit is contained in:
parent
6773a8c883
commit
f2a9cba9de
@ -1 +1 @@
|
|||||||
mysql-3.23.58.tar.gz
|
mysql-4.1.7.tar.gz
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- mysql-3.23.52/include/global.h.jj 2002-08-13 18:08:16.000000000 -0400
|
diff -Naur mysql-4.1.7-orig/include/my_global.h mysql-4.1.7/include/my_global.h
|
||||||
+++ mysql-3.23.52/include/global.h 2002-11-18 18:35:10.000000000 -0500
|
--- mysql-4.1.7-orig/include/my_global.h 2004-10-23 03:28:43.000000000 -0400
|
||||||
@@ -58,6 +58,10 @@
|
+++ mysql-4.1.7/include/my_global.h 2004-10-27 21:13:26.335448200 -0400
|
||||||
|
@@ -102,6 +102,10 @@
|
||||||
#define _GNU_SOURCE 1
|
#define _GNU_SOURCE 1
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
11
mysql-libdir.patch
Normal file
11
mysql-libdir.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -Naur mysql-4.1.7-orig/scripts/mysql_config.sh mysql-4.1.7/scripts/mysql_config.sh
|
||||||
|
--- mysql-4.1.7-orig/scripts/mysql_config.sh 2004-10-23 03:28:44.000000000 -0400
|
||||||
|
+++ mysql-4.1.7/scripts/mysql_config.sh 2004-10-27 21:15:48.762963874 -0400
|
||||||
|
@@ -75,7 +75,6 @@
|
||||||
|
execdir='@libexecdir@'
|
||||||
|
bindir='@bindir@'
|
||||||
|
pkglibdir='@pkglibdir@'
|
||||||
|
-fix_path pkglibdir lib/mysql lib
|
||||||
|
pkgincludedir='@pkgincludedir@'
|
||||||
|
fix_path pkgincludedir include/mysql include
|
||||||
|
version='@VERSION@'
|
@ -34,7 +34,7 @@ start(){
|
|||||||
fi
|
fi
|
||||||
chown -R mysql:mysql $datadir
|
chown -R mysql:mysql $datadir
|
||||||
chmod 0755 $datadir
|
chmod 0755 $datadir
|
||||||
/usr/bin/safe_mysqld --defaults-file=/etc/my.cnf >/dev/null 2>&1 &
|
/usr/bin/mysqld_safe --defaults-file=/etc/my.cnf >/dev/null 2>&1 &
|
||||||
ret=$?
|
ret=$?
|
||||||
# If you've removed anonymous users, this line must be changed to
|
# If you've removed anonymous users, this line must be changed to
|
||||||
# use a user that is allowed to ping mysqld.
|
# use a user that is allowed to ping mysqld.
|
||||||
|
126
mysql.spec
126
mysql.spec
@ -1,27 +1,19 @@
|
|||||||
Name: mysql
|
Name: mysql
|
||||||
Version: 3.23.58
|
Version: 4.1.7
|
||||||
Release: 13
|
Release: 2
|
||||||
Source0: http://www.mysql.com/Downloads/MySQL-3.23/mysql-%{version}.tar.gz
|
Source0: http://dev.mysql.com/get/Downloads/MySQL-4.1/mysql-%{version}.tar.gz
|
||||||
Source1: mysql.init
|
Source1: mysql.init
|
||||||
Source2: mysql.logrotate
|
Source2: mysql.logrotate
|
||||||
Source3: my.cnf
|
Source3: my.cnf
|
||||||
Source4: scriptstub.c
|
Source4: scriptstub.c
|
||||||
# Working around perl dependency checking bug in rpm FTTB. Remove later.
|
# Working around perl dependency checking bug in rpm FTTB. Remove later.
|
||||||
Source999: filter-requires-mysql.sh
|
Source999: filter-requires-mysql.sh
|
||||||
Patch0: mysql-3.23.51-manfixes.patch
|
Patch1: mysql-libdir.patch
|
||||||
Patch1: mysql-3.23.54-libdir.patch
|
|
||||||
Patch2: mysql-errno.patch
|
Patch2: mysql-errno.patch
|
||||||
Patch3: mysql-3.23.58-hotcopy.patch
|
|
||||||
Patch4: mysql-3.23.58-setpermission.patch
|
|
||||||
Patch5: mysql-3.23.58-typo.patch
|
|
||||||
Patch6: mysql-3.23.58-symlink.patch
|
|
||||||
Patch7: mysql-3.23.58-dropdb.patch
|
|
||||||
Patch8: mysql-3.23.58-config.patch
|
|
||||||
Patch9: mysql-3.23.58-security.patch
|
|
||||||
URL: http://www.mysql.com
|
URL: http://www.mysql.com
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
Summary: MySQL client programs and shared libraries.
|
Summary: MySQL client programs and shared libraries.
|
||||||
License: GPL/LGPL
|
License: GPL
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
Prereq: /sbin/ldconfig, /sbin/install-info, grep, fileutils, chkconfig
|
Prereq: /sbin/ldconfig, /sbin/install-info, grep, fileutils, chkconfig
|
||||||
BuildRequires: gperf, perl, readline-devel
|
BuildRequires: gperf, perl, readline-devel
|
||||||
@ -63,7 +55,7 @@ directories.
|
|||||||
%package devel
|
%package devel
|
||||||
|
|
||||||
Summary: Files for development of MySQL applications.
|
Summary: Files for development of MySQL applications.
|
||||||
License: LGPL
|
License: GPL
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
Requires: %{name} = %{version}
|
Requires: %{name} = %{version}
|
||||||
Conflicts: MySQL-devel
|
Conflicts: MySQL-devel
|
||||||
@ -76,7 +68,7 @@ developing MySQL applications.
|
|||||||
%package bench
|
%package bench
|
||||||
|
|
||||||
Summary: MySQL benchmark scripts and data.
|
Summary: MySQL benchmark scripts and data.
|
||||||
License: GPL/LGPL
|
License: GPL
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
Requires: %{name} = %{version}
|
Requires: %{name} = %{version}
|
||||||
Conflicts: MySQL-bench
|
Conflicts: MySQL-bench
|
||||||
@ -89,16 +81,8 @@ MySQL.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
|
||||||
%patch4 -p1
|
|
||||||
%patch5 -p1
|
|
||||||
%patch6 -p1
|
|
||||||
%patch7 -p1
|
|
||||||
%patch8 -p1
|
|
||||||
%patch9 -p1
|
|
||||||
|
|
||||||
libtoolize --force
|
libtoolize --force
|
||||||
aclocal
|
aclocal
|
||||||
@ -117,7 +101,7 @@ CXXFLAGS="$CFLAGS -fno-rtti -fno-exceptions"
|
|||||||
export CFLAGS CXXFLAGS
|
export CFLAGS CXXFLAGS
|
||||||
|
|
||||||
%configure \
|
%configure \
|
||||||
--without-readline \
|
--with-readline \
|
||||||
--without-debug \
|
--without-debug \
|
||||||
--enable-shared \
|
--enable-shared \
|
||||||
--with-extra-charsets=complex \
|
--with-extra-charsets=complex \
|
||||||
@ -173,12 +157,21 @@ install -m 0755 scriptstub ${RPM_BUILD_ROOT}%{_bindir}/mysql_config
|
|||||||
# Doesn't contain anything
|
# Doesn't contain anything
|
||||||
rm -f Docs/manual.ps
|
rm -f Docs/manual.ps
|
||||||
rm -fr $RPM_BUILD_ROOT/usr/mysql-test
|
rm -fr $RPM_BUILD_ROOT/usr/mysql-test
|
||||||
|
rm -f ${RPM_BUILD_ROOT}%{_bindir}/client_test
|
||||||
|
rm -f ${RPM_BUILD_ROOT}%{_bindir}/comp_err
|
||||||
|
rm -f ${RPM_BUILD_ROOT}%{_bindir}/make_win_binary_distribution
|
||||||
|
rm -f ${RPM_BUILD_ROOT}%{_bindir}/make_win_src_distribution
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/libmysqlclient*.la
|
rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/libmysqlclient*.la
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/binary-configure
|
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/binary-configure
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/make_binary_distribution
|
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/make_binary_distribution
|
||||||
|
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/make_sharedlib_distribution
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mi_test_all*
|
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mi_test_all*
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/*.cnf
|
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/*.cnf
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mysql.server
|
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mysql.server
|
||||||
|
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/MySQL-shared-compat.spec
|
||||||
|
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/*.plist
|
||||||
|
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/preinstall
|
||||||
|
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/postinstall
|
||||||
|
|
||||||
# compress manual
|
# compress manual
|
||||||
bzip2 Docs/manual.txt
|
bzip2 Docs/manual.txt
|
||||||
@ -238,21 +231,32 @@ fi
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc README COPYING*
|
%doc README COPYING
|
||||||
%doc Docs/manual.txt.bz2 Docs/mysqld_error.txt
|
%doc Docs/manual.txt.bz2 Docs/mysqld_error.txt
|
||||||
|
|
||||||
# /usr/bin/* except mysqladmin and safe_mysqld
|
|
||||||
%{_bindir}/[a-ln-rt-z]*
|
|
||||||
%{_bindir}/msql2mysql
|
%{_bindir}/msql2mysql
|
||||||
%{_bindir}/mysql
|
%{_bindir}/mysql
|
||||||
%{_bindir}/mysql_*
|
%{_bindir}/mysql_config
|
||||||
|
%{_bindir}/mysql_find_rows
|
||||||
|
%{_bindir}/mysql_tableinfo
|
||||||
|
%{_bindir}/mysql_waitpid
|
||||||
%{_bindir}/mysqlaccess
|
%{_bindir}/mysqlaccess
|
||||||
%{_bindir}/mysql[b-z]*
|
%{_bindir}/mysqladmin
|
||||||
%{_bindir}/my_*
|
%{_bindir}/mysqlbinlog
|
||||||
%{_bindir}/myisam*
|
%{_bindir}/mysqlcheck
|
||||||
|
%{_bindir}/mysqldump
|
||||||
|
%{_bindir}/mysqldumpslow
|
||||||
|
%{_bindir}/mysqlimport
|
||||||
|
%{_bindir}/mysqlshow
|
||||||
|
|
||||||
%{_infodir}/*
|
%{_infodir}/*
|
||||||
%{_mandir}/man1/*
|
|
||||||
|
%{_mandir}/man1/mysql.1*
|
||||||
|
%{_mandir}/man1/mysqlaccess.1*
|
||||||
|
%{_mandir}/man1/mysqladmin.1*
|
||||||
|
%{_mandir}/man1/mysqldump.1*
|
||||||
|
%{_mandir}/man1/mysqlshow.1*
|
||||||
|
|
||||||
%dir %{_libdir}/mysql
|
%dir %{_libdir}/mysql
|
||||||
%{_libdir}/mysql/libmysqlclient*.so.*
|
%{_libdir}/mysql/libmysqlclient*.so.*
|
||||||
%{_libdir}/mysql/mysqlbug
|
%{_libdir}/mysql/mysqlbug
|
||||||
@ -277,6 +281,7 @@ fi
|
|||||||
%lang(pt) %{_datadir}/mysql/portuguese
|
%lang(pt) %{_datadir}/mysql/portuguese
|
||||||
%lang(ro) %{_datadir}/mysql/romanian
|
%lang(ro) %{_datadir}/mysql/romanian
|
||||||
%lang(ru) %{_datadir}/mysql/russian
|
%lang(ru) %{_datadir}/mysql/russian
|
||||||
|
%lang(sr) %{_datadir}/mysql/serbian
|
||||||
%lang(sk) %{_datadir}/mysql/slovak
|
%lang(sk) %{_datadir}/mysql/slovak
|
||||||
%lang(es) %{_datadir}/mysql/spanish
|
%lang(es) %{_datadir}/mysql/spanish
|
||||||
%lang(sv) %{_datadir}/mysql/swedish
|
%lang(sv) %{_datadir}/mysql/swedish
|
||||||
@ -287,15 +292,58 @@ fi
|
|||||||
%files server
|
%files server
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc support-files/*.cnf
|
%doc support-files/*.cnf
|
||||||
%{_bindir}/mysqladmin
|
|
||||||
%{_bindir}/safe_mysqld
|
%{_bindir}/isamchk
|
||||||
|
%{_bindir}/isamlog
|
||||||
|
%{_bindir}/my_print_defaults
|
||||||
|
%{_bindir}/myisamchk
|
||||||
|
%{_bindir}/myisam_ftdump
|
||||||
|
%{_bindir}/myisamlog
|
||||||
|
%{_bindir}/myisampack
|
||||||
|
%{_bindir}/mysql_convert_table_format
|
||||||
|
%{_bindir}/mysql_create_system_tables
|
||||||
|
%{_bindir}/mysql_explain_log
|
||||||
|
%{_bindir}/mysql_fix_extensions
|
||||||
|
%{_bindir}/mysql_fix_privilege_tables
|
||||||
|
%{_bindir}/mysql_install_db
|
||||||
|
%{_bindir}/mysql_secure_installation
|
||||||
|
%{_bindir}/mysql_setpermission
|
||||||
|
%{_bindir}/mysql_tzinfo_to_sql
|
||||||
|
%{_bindir}/mysql_zap
|
||||||
|
%{_bindir}/mysqlbug
|
||||||
|
%{_bindir}/mysqld_multi
|
||||||
|
%{_bindir}/mysqld_safe
|
||||||
|
%{_bindir}/mysqlhotcopy
|
||||||
|
%{_bindir}/mysqlmanager
|
||||||
|
%{_bindir}/mysqlmanager-pwgen
|
||||||
|
%{_bindir}/mysqlmanagerc
|
||||||
|
%{_bindir}/mysqltest
|
||||||
|
%{_bindir}/pack_isam
|
||||||
|
%{_bindir}/perror
|
||||||
|
%{_bindir}/replace
|
||||||
|
%{_bindir}/resolve_stack_dump
|
||||||
|
%{_bindir}/resolveip
|
||||||
|
|
||||||
/usr/libexec/*
|
/usr/libexec/*
|
||||||
|
|
||||||
|
%{_mandir}/man1/isamchk.1*
|
||||||
|
%{_mandir}/man1/isamlog.1*
|
||||||
|
%{_mandir}/man1/mysql_zap.1*
|
||||||
|
%{_mandir}/man1/mysqld.1*
|
||||||
|
%{_mandir}/man1/mysql_fix_privilege_tables.1*
|
||||||
|
%{_mandir}/man1/mysqld_multi.1*
|
||||||
|
%{_mandir}/man1/mysqld_safe.1*
|
||||||
|
%{_mandir}/man1/perror.1*
|
||||||
|
%{_mandir}/man1/replace.1*
|
||||||
|
|
||||||
|
%dir %{_datadir}/mysql
|
||||||
|
%{_datadir}/mysql/fill_help_tables.sql
|
||||||
|
%{_datadir}/mysql/mysql_fix_privilege_tables.sql
|
||||||
/etc/rc.d/init.d/mysqld
|
/etc/rc.d/init.d/mysqld
|
||||||
%attr(0755,mysql,mysql) %dir /var/run/mysqld
|
%attr(0755,mysql,mysql) %dir /var/run/mysqld
|
||||||
%config(noreplace) /etc/logrotate.d/mysqld
|
%config(noreplace) /etc/logrotate.d/mysqld
|
||||||
%attr(0755,mysql,mysql) %dir /var/lib/mysql
|
%attr(0755,mysql,mysql) %dir /var/lib/mysql
|
||||||
%ghost %attr(0640,mysql,mysql) /var/log/mysqld.log
|
%attr(0640,mysql,mysql) %config(noreplace) %verify(not md5 size mtime) /var/log/mysqld.log
|
||||||
%config(noreplace) %verify(not md5 size mtime) /var/log/mysqld.log
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -309,6 +357,12 @@ fi
|
|||||||
%{_datadir}/sql-bench
|
%{_datadir}/sql-bench
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 28 2004 Tom Lane <tgl@redhat.com> 4.1.7-2
|
||||||
|
- rebuild in devel branch
|
||||||
|
|
||||||
|
* Wed Oct 27 2004 Tom Lane <tgl@redhat.com> 4.1.7-1
|
||||||
|
- Update to MySQL 4.1.x.
|
||||||
|
|
||||||
* Tue Oct 12 2004 Tom Lane <tgl@redhat.com> 3.23.58-13
|
* Tue Oct 12 2004 Tom Lane <tgl@redhat.com> 3.23.58-13
|
||||||
- fix security issues CAN-2004-0835, CAN-2004-0836, CAN-2004-0837
|
- fix security issues CAN-2004-0835, CAN-2004-0836, CAN-2004-0837
|
||||||
(bugs #135372, 135375, 135387)
|
(bugs #135372, 135375, 135387)
|
||||||
|
Loading…
Reference in New Issue
Block a user