Update to MySQL 5.1.51

This commit is contained in:
Tom Lane 2010-10-05 23:12:20 -04:00 committed by Michal Schorm
parent 2e8a172cd5
commit e8f900c9b2
6 changed files with 9 additions and 156 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/mysql-5.1.50-nodocs.tar.gz
/mysql-5.1.51-nodocs.tar.gz

View File

@ -1,7 +1,4 @@
mysql's idea of a suitable place to install the regression tests is
/usr/mysql-test. To relocate this to a reasonably FHS-compliant place
like /usr/share/mysql-test, we have to hack up the paths in mtr_cases.pm.
This patch also improves the documentation a tad.
Improve the documentation that will be installed in the mysql-test RPM.
diff -Naur mysql-5.1.43.orig/mysql-test/README mysql-5.1.43/mysql-test/README
@ -34,17 +31,3 @@ diff -Naur mysql-5.1.43.orig/mysql-test/README mysql-5.1.43/mysql-test/README
You can create your own test cases. To create a test case, create a new
diff -Naur mysql-5.1.43.orig/mysql-test/lib/mtr_cases.pm mysql-5.1.43/mysql-test/lib/mtr_cases.pm
--- mysql-5.1.43.orig/mysql-test/lib/mtr_cases.pm 2010-01-15 12:14:49.000000000 -0500
+++ mysql-5.1.43/mysql-test/lib/mtr_cases.pm 2010-02-13 21:17:30.000000000 -0500
@@ -259,7 +259,9 @@
else
{
$suitedir= my_find_dir($::basedir,
- ["mysql-test/suite",
+ ["share/mysql-test/suite",
+ "share/mysql-test",
+ "mysql-test/suite",
"mysql-test",
# Look in storage engine specific suite dirs
"storage/*/mysql-test-suites"

View File

@ -1,105 +0,0 @@
From: Date: August 24 2010 3:48pm
Subject: bzr commit into mysql-5.1-bugteam branch (davi:3489) Bug#55846
List-Archive: http://lists.mysql.com/commits/116644
X-Bug: 55846
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="===============1139944217595210815=="
--===============1139944217595210815==
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline
# At a local mysql-5.1-bugteam repository of davi
3489 Davi Arnaut 2010-08-24
Bug#55846: Link tests fail on Windows - my_compiler.h missing
Make the my_compiler.h header, like my_attribute.h, part of
the distribution. This is required due to the dependency of
the former on the latter (which can undefine __attribute__).
modified:
include/Makefile.am
scripts/make_win_bin_dist
=== modified file 'include/Makefile.am'
--- a/include/Makefile.am 2010-07-14 12:27:13 +0000
+++ b/include/Makefile.am 2010-08-24 13:48:45 +0000
@@ -26,7 +26,8 @@ pkginclude_HEADERS = $(HEADERS_ABI) my_d
decimal.h errmsg.h my_global.h my_net.h \
my_getopt.h sslopt-longopts.h my_dir.h \
sslopt-vars.h sslopt-case.h sql_common.h keycache.h \
- m_ctype.h my_attribute.h $(HEADERS_GEN_CONFIGURE) \
+ m_ctype.h my_attribute.h my_compiler.h \
+ $(HEADERS_GEN_CONFIGURE) \
$(HEADERS_GEN_MAKE)
noinst_HEADERS = config-win.h config-netware.h my_bit.h \
@@ -37,7 +38,7 @@ noinst_HEADERS = config-win.h config-net
my_aes.h my_tree.h my_trie.h hash.h thr_alarm.h \
thr_lock.h t_ctype.h violite.h my_md5.h base64.h \
my_handler.h my_time.h my_vle.h my_user.h \
- my_libwrap.h my_stacktrace.h my_compiler.h
+ my_libwrap.h my_stacktrace.h
EXTRA_DIST = mysql.h.pp mysql/plugin.h.pp
=== modified file 'scripts/make_win_bin_dist'
--- a/scripts/make_win_bin_dist 2009-11-17 16:53:45 +0000
+++ b/scripts/make_win_bin_dist 2010-08-24 13:48:45 +0000
@@ -263,6 +263,7 @@ cp include/mysql.h \
include/keycache.h \
include/m_ctype.h \
include/my_attribute.h \
+ include/my_compiler.h \
include/mysqld_error.h \
include/sql_state.h \
include/mysqld_ername.h \
--===============1139944217595210815==
MIME-Version: 1.0
Content-Type: text/bzr-bundle; charset="us-ascii";
name="bzr/davi.arnaut@stripped"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline
# Bazaar merge directive format 2 (Bazaar 0.90)
# revision_id: davi.arnaut@stripped
# target_branch: file:///home/davi/bzr/bugs/55846-5.1/
# testament_sha1: a436a03b0f660a8b69093e88fe1377a743d53b3b
# timestamp: 2010-08-24 10:48:54 -0300
# base_revision_id: mattias.jonsson@stripped\
# mk1a4rux131hao8r
#
# Begin bundle
IyBCYXphYXIgcmV2aXNpb24gYnVuZGxlIHY0CiMKQlpoOTFBWSZTWWZFKW8AAidfgAAwXGf/93/n
noS////wUAVMvNwNW6sFVWW7uHCUSAE02lTzDUyofqZJp6jzVPUPQnqG0mZTJ6glIU9DEwJPSmTK
aNANABkBoANAxJoTUp/onqKeNJomTQxMjDQgGQ0GmhzRkxMAExGBGmBBiMEyYBGCSQUwaTTTKYJt
U/RPQRT9KeUabUNqAGgKiiY0UdzaboTvYcfRd5FdKF8ue9oiPkV10kC3yPM4DNNfD9ax8xeEkkB+
e4j9vcquwsnWaDCCLKUfZ66bBq72Q71azfj/NKWib8cQyXI1Blp4YhxdRjVAcGWoW7vTwh5ZfW92
kvlxB5UQ7Nfz0EO/ztug6qSkVBLNRqQM1jouG7oGtZ4cKCfbUVqwRKKHoPBtIMfRtCuM0oLvK9ds
yLmR4taNBrTyPMgCadgWYeaxnpjxY/oqJCqrFiRAJxjECJ5rDYJvN6WJuVbFuKgJwwDDo6CnGzSF
G4OjsKMx02Y1jt7EeIdRXkBumzhRdGxiWTzdqyY6m/LcKmYF/KjRtypvisM0hPSSImaQIItA5LYn
YauMjFdh3LpZvFqyBdiFCdeUv4+Bd1mDzOhQgzfrgmm57AGwWWUZpnYe+5w1k5BSsgMSowWMpkIK
AvhHJYGVFNR395hgwkkQogOlAwSZgTNpFk+b2YpgNSpapcYj2EiAv/MPE7JXDR5z6SLlOBGDzMMW
TDosp9FtoZ9ZqA6TwGrlF+55SbNQ9WAq6mU5g+Nodvesm1VNaLkzYtIKAXQ2gVGisXT2RiXvkB6K
NNo0xJUBFxdXAvjlIoHgRpL6bVJSztKM4PGD5FCF5zuZsAnUTQidyx2nXoFEuManlBbe4viQPasS
bZppFVFVXr9vBnPxi8ePKPy8PLLlz82+fqy08EBW/+2f4iOksBrYDESJf5fRwIOfgS4O+eJHhCG4
14fGbt4MYgZD5KfbK2BCag9MyKpw4JUT7pI0XpvpRTiHuoVK+LLcpJHl6CNZ8rD57jeYDvipzEC7
Azp1/rIuC5tHYCzv+Bjw8KSg7Sz+9R8s3e0WYQ4tEptIZNnpOBN7wJG6+jpWZRHl8NG0kFAfenQR
7HcmLvo0C4qmNkjmtSfsjP84e/aPccBj3Zs+UAWOfsPIYHvwldF/8Tbg69DzIVdStnOeSRathccd
Vl9Ry6ZRZ9BElTPMA6umRV5sIXbCeVTkihBoZXY/YC2v65tnVGQSI4OQ/A4m0NJibzgm3lOOCmMi
xV8yC8Scdi46NJePP/DdaBVpE99w9d1pWoij4lo5HXIextIGH+yVAahaHMIoMcXJg4wOb9vn5I3D
p+So3YJbGN4ZjVnTFJXq0OkdUvTjpuggnUKtNk9qGqsFiK9rLDUlxj1sjTumZLTI+0DFHYrJ5/AM
LEaHl7F2MyJ0DLFhVjbcpkuDnAg61/NtgHOgyDNePbfqmcl0ywGjGZ2oXq1ZiiECEDAFOLyRFxpR
EmYSQrAN5uQRLlQYIDlyoy4KpPkY89SQPKEb03X1WFB/yCSKwmpeSwZmKGuoEa5RQV5Iao9gD4YT
ukvrxTsQLTRWSxTBQxSJdV6CJunuLEVORNtOdaQgHd49+Qfl6IJSxzB6TG0ojgGemYSaZW9wvn3Q
oIYDZKhEBloBvxXI5MzSn4plQ+pD3eCH4HUttwrVR90YiHnMHRGHNaYI6tiMT7oqrOT9JmqRJZTp
722UPCq9hQOMazbkWjvb155e1iLm0FiRnkGV5oXdMuk6Q8+CMCEe+o7S9OK29obq1nNsbJqjidCC
KdMWJgJgOVt+JmFgLz7vkcFDhuCOamQ3kI3/i7kinChIMyKUt4A=
--===============1139944217595210815==--

View File

@ -1,25 +0,0 @@
The plugin_load test fails on PPC64 (maybe not always, but at least in the
several tries I've made so far). It doesn't fail on x86, x86_64, or ppc,
at least not in a similarly small number of tries. My best theory at the
moment is that the test itself is wrong. Reported upstream at
http://bugs.mysql.com/bug.php?id=42144
For the moment, just disable this test.
Also, disable the outfile_loaddata test, which as of 5.1.38 is giving
platform-dependent results, with the "expected" results being arguably the
wrong ones. This is upstream at http://bugs.mysql.com/bug.php?id=46895
NB: 42144 is fixed as of 5.1.51, and 46895 has been "fixed" by disabling
the test, so we won't need this anymore in 5.1.51.
diff -Naur mysql-5.1.50.orig/mysql-test/t/disabled.def mysql-5.1.50/mysql-test/t/disabled.def
--- mysql-5.1.50.orig/mysql-test/t/disabled.def 2010-08-03 13:53:51.000000000 -0400
+++ mysql-5.1.50/mysql-test/t/disabled.def 2010-08-27 23:36:17.491455874 -0400
@@ -14,3 +14,5 @@
partition_innodb_plugin : Bug#53307 2010-04-30 VasilDimov valgrind warnings
main.mysqlhotcopy_myisam : bug#54129 2010-06-04 Horst
main.mysqlhotcopy_archive: bug#54129 2010-06-04 Horst
+#
+plugin_load : gives wrong answer on PPC64

View File

@ -1,6 +1,6 @@
Name: mysql
Version: 5.1.50
Release: 2%{?dist}
Version: 5.1.51
Release: 1%{?dist}
Summary: MySQL client programs and shared libraries
Group: Applications/Databases
URL: http://www.mysql.com
@ -35,7 +35,6 @@ Patch2: mysql-errno.patch
Patch4: mysql-testing.patch
Patch5: mysql-install-test.patch
Patch6: mysql-stack-guard.patch
Patch7: mysql-plugin-bug.patch
Patch8: mysql-setschedparam.patch
Patch9: mysql-no-docs.patch
Patch10: mysql-strmov.patch
@ -44,7 +43,6 @@ Patch13: mysql-expired-certs.patch
Patch14: mysql-missing-string-code.patch
Patch15: mysql-lowercase-bug.patch
Patch16: mysql-chain-certs.patch
Patch17: mysql-missing-header.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: gperf, perl, readline-devel, openssl-devel
@ -176,7 +174,6 @@ the MySQL sources.
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
@ -185,7 +182,6 @@ the MySQL sources.
%patch14 -p1
%patch15 -p1
%patch16 -p1
%patch17 -p1
# workaround for upstream bug #56342
rm -f mysql-test/t/ssl_8k_key-master.opt
@ -579,6 +575,10 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
* Wed Oct 6 2010 Tom Lane <tgl@redhat.com> 5.1.51-1
- Update to MySQL 5.1.51, for various fixes described at
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-51.html
* Sat Aug 28 2010 Tom Lane <tgl@redhat.com> 5.1.50-2
- Include my_compiler.h in distribution, per upstream bug #55846.
Otherwise PHP, for example, won't build.

View File

@ -1 +1 @@
1de8cfbc727a0aaeaeeeb610f2d19d3c mysql-5.1.50-nodocs.tar.gz
b1f17ca9fa8d9439e2daa9afa78fd0a1 mysql-5.1.51-nodocs.tar.gz