Fix patching of logrotate

Apply the patch to the correct file, because we use a different one:
  https://src.fedoraproject.org/rpms/mysql8.0/blob/84d52c8/f/mysql8.0.spec#_663

--

cherry-picked Fedora commit:
  https://src.fedoraproject.org/rpms/mysql8.0/c/f4c4f1?branch=rawhide

--

Resolves: RHEL-79549
This commit is contained in:
Michal Schorm 2025-02-13 15:04:10 +00:00
parent 083e265abb
commit de2e5f3752

View File

@ -1,17 +1,35 @@
diff -up mysql-8.0.35/support-files/mysql-log-rotate.in.origf mysql-8.0.35/support-files/mysql-log-rotate.in --- mysql-8.0.40/packaging/rpm-common/mysql.logrotate.in 2024-09-18 12:08:24.000000000 +0200
--- mysql-8.0.35/support-files/mysql-log-rotate.in.origf 2024-01-29 23:00:32.043257515 +0100 +++ mysql-8.0.40/packaging/rpm-common/mysql.logrotate.in_patched 2025-02-13 16:00:32.325677977 +0100
+++ mysql-8.0.35/support-files/mysql-log-rotate.in 2024-01-29 23:02:26.520440388 +0100 @@ -5,18 +5,6 @@
@@ -49,11 +49,7 @@ # [mysqld]
missingok # log-error=@LOGFILE_RPM@
compress #
postrotate -# For the mysqladmin commands below to work, root account
- # just if mysqld is really running -# password is required. Use mysql_config_editor(1) to store
- if test -x @bindir@/mysqladmin && \ -# authentication credentials in the encrypted login path file
- @bindir@/mysqladmin ping &>/dev/null -# ~/.mylogin.cnf
- then -#
- @bindir@/mysqladmin flush-logs -# Example usage:
- fi -#
+ # SIGUSR1 makes the daemon to flush the logs, no need to connect -# mysql_config_editor set --login-path=client --user=root --host=localhost --password
+ @bindir@/kill -USR1 $(systemctl show --property MainPID --value mysqld) -#
endscript -# When these actions has been done, un-comment the following to
} -# enable rotation of mysqld's log error.
-#
#@LOGFILE_RPM@ {
# create 640 mysql mysql
@@ -26,11 +14,7 @@
# missingok
# compress
# postrotate
-# # just if mysqld is really running
-# if test -x @bindir@/mysqladmin && \
-# @bindir@/mysqladmin ping &>/dev/null
-# then
-# @bindir@/mysqladmin flush-logs
-# fi
+# # SIGUSR1 makes the daemon to flush the logs, no need to connect through mysqladmin
+# @bindir@/kill -USR1 $(systemctl show --property MainPID --value mysqld)
# endscript
#}