Update to MySQL 5.5.12
This commit is contained in:
parent
eb8f59bfd8
commit
9595c341f3
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/mysql-5.5.10-nodocs.tar.gz
|
||||
/mysql-5.5.12-nodocs.tar.gz
|
||||
|
@ -16,13 +16,13 @@ Also disable innodb.innodb, which is showing platform-dependent results
|
||||
as of 5.5.9. Upstream at http://bugs.mysql.com/bug.php?id=60155
|
||||
|
||||
|
||||
diff -Naur mysql-5.5.9.orig/mysql-test/t/disabled.def mysql-5.5.9/mysql-test/t/disabled.def
|
||||
--- mysql-5.5.9.orig/mysql-test/t/disabled.def 2011-01-19 17:37:09.000000000 -0500
|
||||
+++ mysql-5.5.9/mysql-test/t/disabled.def 2011-02-16 23:19:34.844378338 -0500
|
||||
@@ -18,3 +18,9 @@
|
||||
sum_distinct-big : Bug#56927 2010-11-15 mattiasj was not tested
|
||||
diff -Naur mysql-5.5.12.orig/mysql-test/t/disabled.def mysql-5.5.12/mysql-test/t/disabled.def
|
||||
--- mysql-5.5.12.orig/mysql-test/t/disabled.def 2011-04-11 06:44:01.000000000 -0400
|
||||
+++ mysql-5.5.12/mysql-test/t/disabled.def 2011-05-10 18:42:11.742438341 -0400
|
||||
@@ -17,3 +17,9 @@
|
||||
alter_table-big : Bug#37248 2010-11-15 mattiasj was not tested
|
||||
create-big : Bug#37248 2010-11-15 mattiasj was not tested
|
||||
archive-big : Bug#11817185 2011-03-10 Anitha Disabled since this leads to timeout on Solaris Sparc
|
||||
+#
|
||||
+outfile_loaddata : bug#46895 code wrong, expected results wrong too
|
||||
+sys_vars.plugin_dir_basic : bug#52223 fails for lib64 library directory
|
||||
|
@ -1,16 +0,0 @@
|
||||
mysql 5.5's new cmake-based build scripts forgot about defining
|
||||
DEFAULT_HOME_ENV. Upstream at http://bugs.mysql.com/bug.php?id=59280
|
||||
|
||||
|
||||
diff -Naur mysql-5.5.8.orig/mysys/CMakeLists.txt mysql-5.5.8/mysys/CMakeLists.txt
|
||||
--- mysql-5.5.8.orig/mysys/CMakeLists.txt 2010-12-03 12:58:26.000000000 -0500
|
||||
+++ mysql-5.5.8/mysys/CMakeLists.txt 2011-01-13 11:58:42.583471734 -0500
|
||||
@@ -69,6 +69,8 @@
|
||||
SET(MYSYS_SOURCES ${MYSYS_SOURCES} my_port.c)
|
||||
ENDIF()
|
||||
|
||||
+ADD_DEFINITIONS( -DDEFAULT_HOME_ENV=MYSQL_HOME)
|
||||
+
|
||||
ADD_CONVENIENCE_LIBRARY(mysys ${MYSYS_SOURCES})
|
||||
TARGET_LINK_LIBRARIES(mysys dbug strings ${ZLIB_LIBRARY}
|
||||
${LIBNSL} ${LIBM} ${LIBRT})
|
14
mysql.spec
14
mysql.spec
@ -1,6 +1,6 @@
|
||||
Name: mysql
|
||||
Version: 5.5.10
|
||||
Release: 3%{?dist}
|
||||
Version: 5.5.12
|
||||
Release: 1%{?dist}
|
||||
Summary: MySQL client programs and shared libraries
|
||||
Group: Applications/Databases
|
||||
URL: http://www.mysql.com
|
||||
@ -42,9 +42,8 @@ Patch7: mysql-versioning.patch
|
||||
Patch8: mysql-dubious-exports.patch
|
||||
Patch9: mysql-disable-test.patch
|
||||
Patch10: mysql-embedded-crash.patch
|
||||
Patch11: mysql-home.patch
|
||||
Patch12: mysql-plugin-bool.patch
|
||||
Patch13: mysql-s390-tsc.patch
|
||||
Patch11: mysql-plugin-bool.patch
|
||||
Patch12: mysql-s390-tsc.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
BuildRequires: perl, readline-devel, openssl-devel
|
||||
@ -188,7 +187,6 @@ the MySQL sources.
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
|
||||
# workaround for upstream bug #56342
|
||||
rm -f mysql-test/t/ssl_8k_key-master.opt
|
||||
@ -611,6 +609,10 @@ fi
|
||||
%{_mandir}/man1/mysql_client_test.1*
|
||||
|
||||
%changelog
|
||||
* Tue May 10 2011 Tom Lane <tgl@redhat.com> 5.5.12-1
|
||||
- Update to MySQL 5.5.12, for various fixes described at
|
||||
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-12.html
|
||||
|
||||
* Tue May 10 2011 Tom Lane <tgl@redhat.com> 5.5.10-3
|
||||
- Add LSB init block to initscript, to ensure sane ordering at system boot
|
||||
Resolves: #703214
|
||||
|
Loading…
Reference in New Issue
Block a user