Let's see if these changes will persuade the regression tests to pass in

koji.
This commit is contained in:
Tom Lane 2009-08-14 23:39:16 +00:00 committed by Michal Schorm
parent 8ac557d4bb
commit 92b0730cde
3 changed files with 36 additions and 2 deletions

View File

@ -0,0 +1,20 @@
As of mysql 5.1.x, the --check-testcases option in mysql-test-run was made
the default, although the documentation for it doesn't tell you that.
Unfortunately the check-testcases code frequently fails in koji for
obscure reasons; what's more it slows down the tests materially.
Since it's not really our job to debug the test suite, let's just turn
it back off ...
diff -Naur mysql-5.1.37.orig/mysql-test/mysql-test-run.pl mysql-5.1.37/mysql-test/mysql-test-run.pl
--- mysql-5.1.37.orig/mysql-test/mysql-test-run.pl 2009-07-13 19:09:03.000000000 -0400
+++ mysql-5.1.37/mysql-test/mysql-test-run.pl 2009-08-14 17:40:49.000000000 -0400
@@ -193,7 +193,7 @@
my $opt_skip_core;
-our $opt_check_testcases= 1;
+our $opt_check_testcases= 0;
my $opt_mark_progress;
my $opt_sleep;

View File

@ -1,6 +1,13 @@
Hack the top-level Makefile to enable the openssl regression tests.
(Why doesn't this happen automatically given the configure option??)
Also, increase the overall timeout for the regression tests to 12 hours,
because on a slow or heavily-loaded build machine sometimes the default of
5 hours isn't enough. (This has been demonstrated to fail in mass-rebuild
scenarios, which aren't that uncommon for Fedora.) Similarly increase the
per-testcase timeout to 30 minutes, since the default of 15 hasn't got a
great deal of headroom either.
diff -Naur mysql-5.1.32.orig/Makefile.am mysql-5.1.32/Makefile.am
--- mysql-5.1.32.orig/Makefile.am 2009-02-13 19:51:56.000000000 -0500
@ -10,7 +17,7 @@ diff -Naur mysql-5.1.32.orig/Makefile.am mysql-5.1.32/Makefile.am
test-ns:
cd mysql-test ; \
- @PERL@ ./mysql-test-run.pl $(force) $(mem) --mysqld=--binlog-format=mixed
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ssl --mysqld=--binlog-format=mixed
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ssl --mysqld=--binlog-format=mixed --suite-timeout=720 --testcase-timeout=30
test-binlog-statement:
cd mysql-test ; \

View File

@ -1,6 +1,6 @@
Name: mysql
Version: 5.1.37
Release: 1%{?dist}
Release: 2%{?dist}
Summary: MySQL client programs and shared libraries
Group: Applications/Databases
URL: http://www.mysql.com
@ -32,6 +32,7 @@ Patch6: mysql-stack-guard.patch
Patch7: mysql-plugin-bug.patch
Patch8: mysql-setschedparam.patch
Patch9: mysql-ndb-stacksize.patch
Patch10: mysql-no-check-testcases.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: gperf, perl, readline-devel, openssl-devel
@ -174,6 +175,7 @@ the MySQL sources.
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
libtoolize --force
aclocal
@ -249,6 +251,7 @@ make check
# note: "make test" invokes two largely-duplicate sets of tests,
# which makes the runtime really unacceptably long ...
# if you want to change this, look at mysql-testing.patch too.
make test-ns
%endif
@ -639,6 +642,10 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
* Fri Aug 14 2009 Tom Lane <tgl@redhat.com> 5.1.37-2
- Add a couple of patches to improve the probability of the regression tests
completing in koji builds
* Sun Aug 2 2009 Tom Lane <tgl@redhat.com> 5.1.37-1
- Update to MySQL 5.1.37, for various fixes described at
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-37.html