diff --git a/mysql.spec b/mysql.spec
index 35e1a44..e008c71 100644
--- a/mysql.spec
+++ b/mysql.spec
@@ -1,6 +1,6 @@
 Name: mysql
 Version: 4.1.11
-Release: 2
+Release: 3
 Source0: http://dev.mysql.com/get/Downloads/MySQL-4.1/mysql-%{version}.tar.gz
 Source1: mysql.init
 Source2: mysql.logrotate
@@ -13,6 +13,7 @@ Patch2: mysql-errno.patch
 Patch3: mysql-libtool.patch
 Patch4: mysql-testing.patch
 Patch5: mysql-no-atomic.patch
+Patch6: mysql-test-ssl.patch
 URL: http://www.mysql.com
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Summary: MySQL client programs and shared libraries.
@@ -90,6 +91,7 @@ MySQL.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 libtoolize --force
 aclocal
@@ -126,6 +128,7 @@ export CFLAGS CXXFLAGS
 	--enable-large-files=yes --enable-largefile=yes \
 	--with-berkeley-db \
 	--enable-thread-safe-client \
+	--disable-dependency-tracking \
 	--with-named-thread-libs="-lpthread"
 
 gcc $CFLAGS $LDFLAGS -o scriptstub "-DLIBDIR=\"%{_libdir}/mysql\"" %{SOURCE4}
@@ -363,6 +366,10 @@ fi
 %{_datadir}/sql-bench
 
 %changelog
+* Mon Apr 25 2005 Tom Lane <tgl@redhat.com> 4.1.11-3
+- Enable openssl tests during build, per bz#155850
+- Might as well turn on --disable-dependency-tracking
+
 * Fri Apr  8 2005 Tom Lane <tgl@redhat.com> 4.1.11-2
 - Avoid dependency on <asm/atomic.h>, cause it won't build anymore on ia64.
   This is probably a cleaner solution for bz#143537, too.