Spread mysql test ports around a bit more --- I'm wondering if there are
buildfarm cross-machine dependencies I don't know about.
This commit is contained in:
parent
a448c5eaa5
commit
6d57e80587
@ -1,8 +1,8 @@
|
|||||||
This patch is needed to improve the probability that the MySQL tests pass
|
This patch is needed to improve the probability that the MySQL tests pass
|
||||||
in Red Hat's build environment. The 32-bit and 64-bit variants of a single
|
in Red Hat's build environment. The 32-bit and 64-bit variants of a single
|
||||||
architecture may be built on the same machine at the same time, so we have
|
architecture may be built on the same machine at the same time, so we have
|
||||||
to ensure that the tests use different port numbers on a 64-bit arch than
|
to ensure that the tests use different port numbers on each arch, else they
|
||||||
on a 32-bit, else they will interfere with each other.
|
will interfere with each other.
|
||||||
|
|
||||||
We also have to hack the top-level Makefile to enable the openssl regression
|
We also have to hack the top-level Makefile to enable the openssl regression
|
||||||
tests. (Why doesn't this happen automatically given the configure option??)
|
tests. (Why doesn't this happen automatically given the configure option??)
|
||||||
@ -14,10 +14,10 @@ with a C-code version. Besides this patch, mysql-libtool.patch
|
|||||||
would need to be changed to use either one.
|
would need to be changed to use either one.
|
||||||
|
|
||||||
|
|
||||||
diff -Naur mysql-5.0.16.orig/Makefile.am mysql-5.0.16/Makefile.am
|
diff -Naur mysql-5.0.22.orig/Makefile.am mysql-5.0.22/Makefile.am
|
||||||
--- mysql-5.0.16.orig/Makefile.am 2005-11-14 19:12:31.000000000 -0500
|
--- mysql-5.0.22.orig/Makefile.am 2006-05-25 04:56:41.000000000 -0400
|
||||||
+++ mysql-5.0.16/Makefile.am 2005-12-09 18:29:31.000000000 -0500
|
+++ mysql-5.0.22/Makefile.am 2006-06-09 00:03:21.000000000 -0400
|
||||||
@@ -107,8 +107,8 @@
|
@@ -106,8 +106,8 @@
|
||||||
|
|
||||||
test:
|
test:
|
||||||
cd mysql-test ; \
|
cd mysql-test ; \
|
||||||
@ -28,23 +28,41 @@ diff -Naur mysql-5.0.16.orig/Makefile.am mysql-5.0.16/Makefile.am
|
|||||||
|
|
||||||
test-force:
|
test-force:
|
||||||
cd mysql-test; \
|
cd mysql-test; \
|
||||||
diff -Naur mysql-5.0.16.orig/mysql-test/mysql-test-run.sh mysql-5.0.16/mysql-test/mysql-test-run.sh
|
diff -Naur mysql-5.0.22.orig/mysql-test/mysql-test-run.sh mysql-5.0.22/mysql-test/mysql-test-run.sh
|
||||||
--- mysql-5.0.16.orig/mysql-test/mysql-test-run.sh 2005-11-14 19:12:46.000000000 -0500
|
--- mysql-5.0.22.orig/mysql-test/mysql-test-run.sh 2006-05-25 04:56:49.000000000 -0400
|
||||||
+++ mysql-5.0.16/mysql-test/mysql-test-run.sh 2005-12-09 18:34:09.000000000 -0500
|
+++ mysql-5.0.22/mysql-test/mysql-test-run.sh 2006-06-09 00:06:22.000000000 -0400
|
||||||
@@ -222,6 +222,16 @@
|
@@ -252,6 +252,34 @@
|
||||||
# an environment variable can be used to control all ports. A small
|
# 5.1 test run, even if different MTR_BUILD_THREAD is used. This means
|
||||||
# number is to be used, 0 - 16 or similar.
|
# all port numbers might not be used in this version of the script.
|
||||||
#
|
#
|
||||||
+# hack to allow 32- and 64-bit tests to run concurrently on same build machine
|
+# hack to allow 32- and 64-bit tests to run concurrently on same build machine
|
||||||
+case `uname -m` in
|
+case `uname -m` in
|
||||||
+ ppc64 | s390x | x86_64)
|
+ i?86)
|
||||||
+ MTR_BUILD_THREAD=7
|
+ MTR_BUILD_THREAD=0
|
||||||
|
+ ;;
|
||||||
|
+ x86_64)
|
||||||
|
+ MTR_BUILD_THREAD=1
|
||||||
|
+ ;;
|
||||||
|
+ ia64)
|
||||||
|
+ MTR_BUILD_THREAD=2
|
||||||
|
+ ;;
|
||||||
|
+ ppc)
|
||||||
|
+ MTR_BUILD_THREAD=3
|
||||||
|
+ ;;
|
||||||
|
+ ppc64)
|
||||||
|
+ MTR_BUILD_THREAD=4
|
||||||
|
+ ;;
|
||||||
|
+ s390)
|
||||||
|
+ MTR_BUILD_THREAD=5
|
||||||
|
+ ;;
|
||||||
|
+ s390x)
|
||||||
|
+ MTR_BUILD_THREAD=6
|
||||||
+ ;;
|
+ ;;
|
||||||
+ *)
|
+ *)
|
||||||
+ MTR_BUILD_THREAD=11
|
+ MTR_BUILD_THREAD=7
|
||||||
+ ;;
|
+ ;;
|
||||||
+esac
|
+esac
|
||||||
+
|
+
|
||||||
if [ -n "$MTR_BUILD_THREAD" ] ; then
|
if [ -n "$MTR_BUILD_THREAD" ] ; then
|
||||||
MASTER_MYPORT=`expr $MTR_BUILD_THREAD '*' 5 + 10000`
|
MASTER_MYPORT=`expr $MTR_BUILD_THREAD '*' 10 + 10000`
|
||||||
MYSQL_MANAGER_PORT=`expr $MASTER_MYPORT + 2`
|
MYSQL_MANAGER_PORT=`expr $MASTER_MYPORT + 2`
|
||||||
|
Loading…
Reference in New Issue
Block a user