Update to MySQL 5.0.15.
This commit is contained in:
parent
a5079af36c
commit
6cfe7c32f0
@ -1 +1 @@
|
||||
mysql-4.1.14.tar.gz
|
||||
mysql-5.0.15.tar.gz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -Naur mysql-4.1.7-orig/include/my_global.h mysql-4.1.7/include/my_global.h
|
||||
--- mysql-4.1.7-orig/include/my_global.h 2004-10-23 03:28:43.000000000 -0400
|
||||
+++ mysql-4.1.7/include/my_global.h 2004-10-27 21:13:26.335448200 -0400
|
||||
@@ -102,6 +102,10 @@
|
||||
diff -Naur mysql-5.0.15.orig/include/my_global.h mysql-5.0.15/include/my_global.h
|
||||
--- mysql-5.0.15.orig/include/my_global.h 2005-10-16 21:27:27.000000000 -0400
|
||||
+++ mysql-5.0.15/include/my_global.h 2005-11-02 16:16:37.000000000 -0500
|
||||
@@ -107,6 +107,10 @@
|
||||
#define _GNU_SOURCE 1
|
||||
#endif
|
||||
|
||||
@ -9,6 +9,6 @@ diff -Naur mysql-4.1.7-orig/include/my_global.h mysql-4.1.7/include/my_global.h
|
||||
+#define HAVE_ERRNO_AS_DEFINE
|
||||
+#endif
|
||||
+
|
||||
/* The client defines this to avoid all thread code */
|
||||
#if defined(UNDEF_THREADS_HACK)
|
||||
#undef THREAD
|
||||
/*
|
||||
Temporary solution to solve bug#7156. Include "sys/types.h" before
|
||||
the thread headers, else the function madvise() will not be defined
|
||||
|
31
mysql.spec
31
mysql.spec
@ -1,7 +1,7 @@
|
||||
Name: mysql
|
||||
Version: 4.1.14
|
||||
Version: 5.0.15
|
||||
Release: 1
|
||||
Source0: http://dev.mysql.com/get/Downloads/MySQL-4.1/mysql-%{version}.tar.gz
|
||||
Source0: http://dev.mysql.com/get/Downloads/MySQL-5.0/mysql-%{version}.tar.gz
|
||||
Source1: mysql.init
|
||||
Source2: mysql.logrotate
|
||||
Source3: my.cnf
|
||||
@ -13,9 +13,7 @@ Patch2: mysql-errno.patch
|
||||
Patch3: mysql-libtool.patch
|
||||
Patch4: mysql-testing.patch
|
||||
Patch5: mysql-no-atomic.patch
|
||||
Patch6: mysql-lock-ssl.patch
|
||||
Patch7: mysql-test-ssl.patch
|
||||
Patch8: mysql-buffer-warning.patch
|
||||
Patch6: mysql-test-ssl.patch
|
||||
URL: http://www.mysql.com
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Summary: MySQL client programs and shared libraries.
|
||||
@ -95,8 +93,6 @@ MySQL.
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
|
||||
libtoolize --force
|
||||
aclocal
|
||||
@ -118,7 +114,6 @@ export CFLAGS CXXFLAGS
|
||||
|
||||
%configure \
|
||||
--with-readline \
|
||||
--with-vio \
|
||||
--with-openssl \
|
||||
--without-debug \
|
||||
--enable-shared \
|
||||
@ -128,10 +123,9 @@ export CFLAGS CXXFLAGS
|
||||
--with-mysqld-user="mysql" \
|
||||
--with-extra-charsets=all \
|
||||
--with-innodb \
|
||||
--with-isam \
|
||||
--with-berkeley-db \
|
||||
--enable-local-infile \
|
||||
--enable-large-files=yes --enable-largefile=yes \
|
||||
--enable-largefile \
|
||||
--enable-thread-safe-client \
|
||||
--disable-dependency-tracking \
|
||||
--with-named-thread-libs="-lpthread"
|
||||
@ -281,7 +275,6 @@ fi
|
||||
%lang(hu) %{_datadir}/mysql/hungarian
|
||||
%lang(it) %{_datadir}/mysql/italian
|
||||
%lang(ja) %{_datadir}/mysql/japanese
|
||||
%lang(ja) %{_datadir}/mysql/japanese-sjis
|
||||
%lang(ko) %{_datadir}/mysql/korean
|
||||
%lang(no) %{_datadir}/mysql/norwegian
|
||||
%lang(no) %{_datadir}/mysql/norwegian-ny
|
||||
@ -301,8 +294,6 @@ fi
|
||||
%defattr(-,root,root)
|
||||
%doc support-files/*.cnf
|
||||
|
||||
%{_bindir}/isamchk
|
||||
%{_bindir}/isamlog
|
||||
%{_bindir}/my_print_defaults
|
||||
%{_bindir}/myisamchk
|
||||
%{_bindir}/myisam_ftdump
|
||||
@ -322,11 +313,11 @@ fi
|
||||
%{_bindir}/mysqld_multi
|
||||
%{_bindir}/mysqld_safe
|
||||
%{_bindir}/mysqlhotcopy
|
||||
%{_bindir}/mysqlmanager
|
||||
%{_bindir}/mysqlmanager-pwgen
|
||||
%{_bindir}/mysqlmanagerc
|
||||
%{_bindir}/mysqltestmanager
|
||||
%{_bindir}/mysqltestmanager-pwgen
|
||||
%{_bindir}/mysqltestmanagerc
|
||||
%{_bindir}/mysqltest
|
||||
%{_bindir}/pack_isam
|
||||
%{_bindir}/innochecksum
|
||||
%{_bindir}/perror
|
||||
%{_bindir}/replace
|
||||
%{_bindir}/resolve_stack_dump
|
||||
@ -334,8 +325,6 @@ fi
|
||||
|
||||
/usr/libexec/*
|
||||
|
||||
%{_mandir}/man1/isamchk.1*
|
||||
%{_mandir}/man1/isamlog.1*
|
||||
%{_mandir}/man1/mysql_zap.1*
|
||||
%{_mandir}/man1/mysqld.1*
|
||||
%{_mandir}/man1/mysql_fix_privilege_tables.1*
|
||||
@ -345,6 +334,7 @@ fi
|
||||
%{_mandir}/man1/replace.1*
|
||||
|
||||
%dir %{_datadir}/mysql
|
||||
%{_datadir}/mysql/errmsg.txt
|
||||
%{_datadir}/mysql/fill_help_tables.sql
|
||||
%{_datadir}/mysql/mysql_fix_privilege_tables.sql
|
||||
/etc/rc.d/init.d/mysqld
|
||||
@ -365,6 +355,9 @@ fi
|
||||
%{_datadir}/sql-bench
|
||||
|
||||
%changelog
|
||||
* Wed Nov 2 2005 Tom Lane <tgl@redhat.com> 5.0.15-1
|
||||
- Update to MySQL 5.0.15
|
||||
|
||||
* Wed Oct 5 2005 Tom Lane <tgl@redhat.com> 4.1.14-1
|
||||
- Update to MySQL 4.1.14
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user