Update to MySQL 4.1.11 to fix bz#152911; also fix bz#154123, bz#143537.
This commit is contained in:
parent
9f0113bbe2
commit
652b269cca
@ -1 +1 @@
|
|||||||
mysql-4.1.10a.tar.gz
|
mysql-4.1.11.tar.gz
|
||||||
|
@ -2,19 +2,17 @@ This patch is needed to improve the probability that the MySQL tests pass
|
|||||||
in Red Hat's build environment. The 32-bit and 64-bit variants of a single
|
in Red Hat's build environment. The 32-bit and 64-bit variants of a single
|
||||||
architecture may be built on the same machine at the same time, so we have
|
architecture may be built on the same machine at the same time, so we have
|
||||||
to ensure that the tests use different port numbers on a 64-bit arch than
|
to ensure that the tests use different port numbers on a 64-bit arch than
|
||||||
on a 32-bit, else they will interfere with each other. Also increase a
|
on a 32-bit, else they will interfere with each other.
|
||||||
timeout that has been observed to get violated under heavy load.
|
|
||||||
|
|
||||||
|
|
||||||
diff -Naur mysql-4.1.9.orig/mysql-test/mysql-test-run.sh mysql-4.1.9/mysql-test/mysql-test-run.sh
|
diff -Naur mysql-4.1.11.orig/mysql-test/mysql-test-run.sh mysql-4.1.11/mysql-test/mysql-test-run.sh
|
||||||
--- mysql-4.1.9.orig/mysql-test/mysql-test-run.sh 2005-01-11 17:06:03.000000000 -0500
|
--- mysql-4.1.11.orig/mysql-test/mysql-test-run.sh 2005-04-07 16:09:59.971778102 -0400
|
||||||
+++ mysql-4.1.9/mysql-test/mysql-test-run.sh 2005-01-15 19:44:10.780699826 -0500
|
+++ mysql-4.1.11/mysql-test/mysql-test-run.sh 2005-04-07 16:11:29.993510299 -0400
|
||||||
@@ -200,12 +200,24 @@
|
@@ -200,11 +200,24 @@
|
||||||
|
|
||||||
MASTER_RUNNING=0
|
MASTER_RUNNING=0
|
||||||
MASTER1_RUNNING=0
|
MASTER1_RUNNING=0
|
||||||
-MASTER_MYPORT=9306
|
-MASTER_MYPORT=9306
|
||||||
-MASTER_MYPORT1=9307
|
|
||||||
SLAVE_RUNNING=0
|
SLAVE_RUNNING=0
|
||||||
-SLAVE_MYPORT=9308 # leave room for 2 masters for cluster tests
|
-SLAVE_MYPORT=9308 # leave room for 2 masters for cluster tests
|
||||||
-MYSQL_MANAGER_PORT=9305 # needs to be out of the way of slaves
|
-MYSQL_MANAGER_PORT=9305 # needs to be out of the way of slaves
|
||||||
@ -39,12 +37,3 @@ diff -Naur mysql-4.1.9.orig/mysql-test/mysql-test-run.sh mysql-4.1.9/mysql-test/
|
|||||||
MYSQL_MANAGER_PW_FILE=$MYSQL_TEST_DIR/var/tmp/manager.pwd
|
MYSQL_MANAGER_PW_FILE=$MYSQL_TEST_DIR/var/tmp/manager.pwd
|
||||||
MYSQL_MANAGER_LOG=$MYSQL_TEST_DIR/var/log/manager.log
|
MYSQL_MANAGER_LOG=$MYSQL_TEST_DIR/var/log/manager.log
|
||||||
MYSQL_MANAGER_USER=root
|
MYSQL_MANAGER_USER=root
|
||||||
@@ -230,7 +242,7 @@
|
|
||||||
SLEEP_TIME_FOR_FIRST_MASTER=400 # Enough time to create innodb tables
|
|
||||||
SLEEP_TIME_FOR_SECOND_MASTER=400
|
|
||||||
SLEEP_TIME_FOR_FIRST_SLAVE=400
|
|
||||||
-SLEEP_TIME_FOR_SECOND_SLAVE=30
|
|
||||||
+SLEEP_TIME_FOR_SECOND_SLAVE=60
|
|
||||||
CHARACTER_SET=latin1
|
|
||||||
DBUSER=""
|
|
||||||
START_WAIT_TIMEOUT=10
|
|
||||||
|
19
mysql.spec
19
mysql.spec
@ -1,5 +1,5 @@
|
|||||||
Name: mysql
|
Name: mysql
|
||||||
Version: 4.1.10a
|
Version: 4.1.11
|
||||||
Release: 1
|
Release: 1
|
||||||
Source0: http://dev.mysql.com/get/Downloads/MySQL-4.1/mysql-%{version}.tar.gz
|
Source0: http://dev.mysql.com/get/Downloads/MySQL-4.1/mysql-%{version}.tar.gz
|
||||||
Source1: mysql.init
|
Source1: mysql.init
|
||||||
@ -12,7 +12,7 @@ Patch1: mysql-libdir.patch
|
|||||||
Patch2: mysql-errno.patch
|
Patch2: mysql-errno.patch
|
||||||
Patch3: mysql-libtool.patch
|
Patch3: mysql-libtool.patch
|
||||||
Patch4: mysql-testing.patch
|
Patch4: mysql-testing.patch
|
||||||
Patch5: mysql-4.1.10-macro-safety.patch
|
Patch5: mysql-threads.patch
|
||||||
URL: http://www.mysql.com
|
URL: http://www.mysql.com
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
Summary: MySQL client programs and shared libraries.
|
Summary: MySQL client programs and shared libraries.
|
||||||
@ -24,7 +24,6 @@ BuildRequires: gcc-c++, ncurses-devel, zlib-devel
|
|||||||
BuildRequires: libtool automake autoconf
|
BuildRequires: libtool automake autoconf
|
||||||
Requires: bash
|
Requires: bash
|
||||||
Conflicts: MySQL
|
Conflicts: MySQL
|
||||||
Requires: perl-DBI, perl-DBD-MySQL
|
|
||||||
Obsoletes: mysql-client mysql-perl
|
Obsoletes: mysql-client mysql-perl
|
||||||
# make test requires time
|
# make test requires time
|
||||||
BuildRequires: time
|
BuildRequires: time
|
||||||
@ -46,6 +45,8 @@ License: GPL
|
|||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
Prereq: /sbin/chkconfig, /usr/sbin/useradd
|
Prereq: /sbin/chkconfig, /usr/sbin/useradd
|
||||||
Requires: %{name} = %{version}-%{release}, sh-utils
|
Requires: %{name} = %{version}-%{release}, sh-utils
|
||||||
|
# mysqlhotcopy needs DBI/DBD support
|
||||||
|
Requires: perl-DBI, perl-DBD-MySQL
|
||||||
Conflicts: MySQL-server
|
Conflicts: MySQL-server
|
||||||
|
|
||||||
%description server
|
%description server
|
||||||
@ -124,7 +125,8 @@ export CFLAGS CXXFLAGS
|
|||||||
--enable-local-infile \
|
--enable-local-infile \
|
||||||
--enable-large-files=yes --enable-largefile=yes \
|
--enable-large-files=yes --enable-largefile=yes \
|
||||||
--with-berkeley-db \
|
--with-berkeley-db \
|
||||||
--enable-thread-safe-client
|
--enable-thread-safe-client \
|
||||||
|
--with-named-thread-libs="-lpthread"
|
||||||
|
|
||||||
gcc $CFLAGS $LDFLAGS -o scriptstub "-DLIBDIR=\"%{_libdir}/mysql\"" %{SOURCE4}
|
gcc $CFLAGS $LDFLAGS -o scriptstub "-DLIBDIR=\"%{_libdir}/mysql\"" %{SOURCE4}
|
||||||
|
|
||||||
@ -132,9 +134,7 @@ gcc $CFLAGS $LDFLAGS -o scriptstub "-DLIBDIR=\"%{_libdir}/mysql\"" %{SOURCE4}
|
|||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
make check
|
make check
|
||||||
%ifnarch s390x
|
|
||||||
make test
|
make test
|
||||||
%endif
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -363,6 +363,13 @@ fi
|
|||||||
%{_datadir}/sql-bench
|
%{_datadir}/sql-bench
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 7 2005 Tom Lane <tgl@redhat.com> 4.1.11-1
|
||||||
|
- Update to MySQL 4.1.11 to fix bz#152911 as well as other issues
|
||||||
|
- Move perl-DBI, perl-DBD-MySQL dependencies to server package (bz#154123)
|
||||||
|
- Override configure thread library test to suppress HAVE_LINUXTHREADS check
|
||||||
|
- Fix BDB failure on s390x (bz#143537)
|
||||||
|
- At last we can enable "make test" on all arches
|
||||||
|
|
||||||
* Fri Mar 11 2005 Tom Lane <tgl@redhat.com> 4.1.10a-1
|
* Fri Mar 11 2005 Tom Lane <tgl@redhat.com> 4.1.10a-1
|
||||||
- Update to MySQL 4.1.10a to fix security vulnerabilities (bz#150868,
|
- Update to MySQL 4.1.10a to fix security vulnerabilities (bz#150868,
|
||||||
for CAN-2005-0711, and bz#150871 for CAN-2005-0709, CAN-2005-0710).
|
for CAN-2005-0711, and bz#150871 for CAN-2005-0709, CAN-2005-0710).
|
||||||
|
Loading…
Reference in New Issue
Block a user