Update to MySQL 5.5.15
This commit is contained in:
parent
f316512a73
commit
5ad77d9c4f
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/mysql-5.5.14-nodocs.tar.gz
|
/mysql-5.5.15-nodocs.tar.gz
|
||||||
|
@ -14,12 +14,12 @@ Also disable innodb.innodb, which is showing platform-dependent results
|
|||||||
as of 5.5.9. Upstream at http://bugs.mysql.com/bug.php?id=60155
|
as of 5.5.9. Upstream at http://bugs.mysql.com/bug.php?id=60155
|
||||||
|
|
||||||
|
|
||||||
diff -Naur mysql-5.5.14.orig/mysql-test/t/disabled.def mysql-5.5.14/mysql-test/t/disabled.def
|
diff -Naur mysql-5.5.15.orig/mysql-test/t/disabled.def mysql-5.5.15/mysql-test/t/disabled.def
|
||||||
--- mysql-5.5.14.orig/mysql-test/t/disabled.def 2011-06-21 12:42:40.000000000 -0400
|
--- mysql-5.5.15.orig/mysql-test/t/disabled.def 2011-07-13 15:09:03.000000000 -0400
|
||||||
+++ mysql-5.5.14/mysql-test/t/disabled.def 2011-07-11 14:33:46.560138525 -0400
|
+++ mysql-5.5.15/mysql-test/t/disabled.def 2011-07-29 11:48:39.214514072 -0400
|
||||||
@@ -17,3 +17,7 @@
|
@@ -16,3 +16,7 @@
|
||||||
|
create-big : Bug#11748731 2010-11-15 mattiasj was not tested
|
||||||
archive-big : Bug#11817185 2011-03-10 Anitha Disabled since this leads to timeout on Solaris Sparc
|
archive-big : Bug#11817185 2011-03-10 Anitha Disabled since this leads to timeout on Solaris Sparc
|
||||||
main.query_cache_28249 : Bug#12584161 2009-03-25 main.query_cache_28249 fails sporadically
|
|
||||||
log_tables-big : Bug#11756699 2010-11-15 mattiasj report already exists
|
log_tables-big : Bug#11756699 2010-11-15 mattiasj report already exists
|
||||||
+#
|
+#
|
||||||
+outfile_loaddata : bug#46895 code wrong, expected results wrong too
|
+outfile_loaddata : bug#46895 code wrong, expected results wrong too
|
||||||
|
@ -1,19 +0,0 @@
|
|||||||
Fix crash in embedded mysql library when mysql_library_init() is invoked
|
|
||||||
with argc = 0, as is supposed to be a supported thing to do.
|
|
||||||
Patch from upstream bug #57931.
|
|
||||||
|
|
||||||
|
|
||||||
diff -Naur mysql-5.5.8.orig/libmysqld/lib_sql.cc mysql-5.5.8/libmysqld/lib_sql.cc
|
|
||||||
--- mysql-5.5.8.orig/libmysqld/lib_sql.cc 2010-12-03 12:58:26.000000000 -0500
|
|
||||||
+++ mysql-5.5.8/libmysqld/lib_sql.cc 2011-01-12 23:10:55.837471629 -0500
|
|
||||||
@@ -510,8 +510,8 @@
|
|
||||||
return 1;
|
|
||||||
defaults_argc= *argcp;
|
|
||||||
defaults_argv= *argvp;
|
|
||||||
- remaining_argc= argc;
|
|
||||||
- remaining_argv= argv;
|
|
||||||
+ remaining_argc= *argcp;
|
|
||||||
+ remaining_argv= *argvp;
|
|
||||||
|
|
||||||
/* Must be initialized early for comparison of options name */
|
|
||||||
system_charset_info= &my_charset_utf8_general_ci;
|
|
25
mysql.spec
25
mysql.spec
@ -1,8 +1,10 @@
|
|||||||
Name: mysql
|
Name: mysql
|
||||||
Version: 5.5.14
|
Version: 5.5.15
|
||||||
Release: 3%{?dist}
|
Release: 2%{?dist}
|
||||||
# Update this whenever F15 gets rebased; it must be NVR-greater than F15 pkg:
|
# Update this whenever F15 gets rebased; it must be NVR-greater than F15 pkg.
|
||||||
%global first_systemd_version 5.5.14-3
|
# Our convention for the life of F15 is that sysv packages will be numbered
|
||||||
|
# 1dist.n while systemd packages will be 2dist and higher.
|
||||||
|
%global first_systemd_version 5.5.15-2
|
||||||
|
|
||||||
Summary: MySQL client programs and shared libraries
|
Summary: MySQL client programs and shared libraries
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
@ -37,6 +39,7 @@ Source13: mysqld-wait-ready
|
|||||||
# Working around perl dependency checking bug in rpm FTTB. Remove later.
|
# Working around perl dependency checking bug in rpm FTTB. Remove later.
|
||||||
Source999: filter-requires-mysql.sh
|
Source999: filter-requires-mysql.sh
|
||||||
|
|
||||||
|
# Comments for these patches are in the patch files.
|
||||||
Patch1: mysql-errno.patch
|
Patch1: mysql-errno.patch
|
||||||
Patch2: mysql-strmov.patch
|
Patch2: mysql-strmov.patch
|
||||||
Patch3: mysql-install-test.patch
|
Patch3: mysql-install-test.patch
|
||||||
@ -46,11 +49,10 @@ Patch6: mysql-chain-certs.patch
|
|||||||
Patch7: mysql-versioning.patch
|
Patch7: mysql-versioning.patch
|
||||||
Patch8: mysql-dubious-exports.patch
|
Patch8: mysql-dubious-exports.patch
|
||||||
Patch9: mysql-disable-test.patch
|
Patch9: mysql-disable-test.patch
|
||||||
Patch10: mysql-embedded-crash.patch
|
Patch10: mysql-plugin-bool.patch
|
||||||
Patch11: mysql-plugin-bool.patch
|
Patch11: mysql-s390-tsc.patch
|
||||||
Patch12: mysql-s390-tsc.patch
|
Patch12: mysql-openssl-test.patch
|
||||||
Patch13: mysql-openssl-test.patch
|
Patch13: mysqld-nowatch.patch
|
||||||
Patch14: mysqld-nowatch.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
BuildRequires: perl, readline-devel, openssl-devel
|
BuildRequires: perl, readline-devel, openssl-devel
|
||||||
@ -201,7 +203,6 @@ the MySQL sources.
|
|||||||
%patch11 -p1
|
%patch11 -p1
|
||||||
%patch12 -p1
|
%patch12 -p1
|
||||||
%patch13 -p1
|
%patch13 -p1
|
||||||
%patch14 -p1
|
|
||||||
|
|
||||||
# workaround for upstream bug #56342
|
# workaround for upstream bug #56342
|
||||||
rm -f mysql-test/t/ssl_8k_key-master.opt
|
rm -f mysql-test/t/ssl_8k_key-master.opt
|
||||||
@ -648,6 +649,10 @@ fi
|
|||||||
%{_mandir}/man1/mysql_client_test.1*
|
%{_mandir}/man1/mysql_client_test.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 29 2011 Tom Lane <tgl@redhat.com> 5.5.15-2
|
||||||
|
- Update to MySQL 5.5.15, for various fixes described at
|
||||||
|
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-15.html
|
||||||
|
|
||||||
* Wed Jul 27 2011 Tom Lane <tgl@redhat.com> 5.5.14-3
|
* Wed Jul 27 2011 Tom Lane <tgl@redhat.com> 5.5.14-3
|
||||||
- Convert to systemd startup support (no socket activation, for now anyway)
|
- Convert to systemd startup support (no socket activation, for now anyway)
|
||||||
Related: #714426
|
Related: #714426
|
||||||
|
Loading…
Reference in New Issue
Block a user