Fix failure to honor MYSQL_HOME environment variable
This commit is contained in:
parent
9f11c7960c
commit
23dc9d6730
16
mysql-home.patch
Normal file
16
mysql-home.patch
Normal file
@ -0,0 +1,16 @@
|
||||
mysql 5.5's new cmake-based build scripts forgot about defining
|
||||
DEFAULT_HOME_ENV. Upstream at http://bugs.mysql.com/bug.php?id=59280
|
||||
|
||||
|
||||
diff -Naur mysql-5.5.8.orig/mysys/CMakeLists.txt mysql-5.5.8/mysys/CMakeLists.txt
|
||||
--- mysql-5.5.8.orig/mysys/CMakeLists.txt 2010-12-03 12:58:26.000000000 -0500
|
||||
+++ mysql-5.5.8/mysys/CMakeLists.txt 2011-01-13 11:58:42.583471734 -0500
|
||||
@@ -69,6 +69,8 @@
|
||||
SET(MYSYS_SOURCES ${MYSYS_SOURCES} my_port.c)
|
||||
ENDIF()
|
||||
|
||||
+ADD_DEFINITIONS( -DDEFAULT_HOME_ENV=MYSQL_HOME)
|
||||
+
|
||||
ADD_CONVENIENCE_LIBRARY(mysys ${MYSYS_SOURCES})
|
||||
TARGET_LINK_LIBRARIES(mysys dbug strings ${ZLIB_LIBRARY}
|
||||
${LIBNSL} ${LIBM} ${LIBRT})
|
@ -1,6 +1,6 @@
|
||||
Name: mysql
|
||||
Version: 5.5.8
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: MySQL client programs and shared libraries
|
||||
Group: Applications/Databases
|
||||
URL: http://www.mysql.com
|
||||
@ -41,6 +41,7 @@ Patch7: mysql-versioning.patch
|
||||
Patch8: mysql-dubious-exports.patch
|
||||
Patch9: mysql-disable-test.patch
|
||||
Patch10: mysql-embedded-crash.patch
|
||||
Patch11: mysql-home.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
BuildRequires: gperf, perl, readline-devel, openssl-devel
|
||||
@ -179,6 +180,7 @@ the MySQL sources.
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
|
||||
# workaround for upstream bug #56342
|
||||
rm -f mysql-test/t/ssl_8k_key-master.opt
|
||||
@ -598,6 +600,10 @@ fi
|
||||
%{_mandir}/man1/mysql_client_test.1*
|
||||
|
||||
%changelog
|
||||
* Thu Jan 13 2011 Tom Lane <tgl@redhat.com> 5.5.8-5
|
||||
- Fix failure to honor MYSQL_HOME environment variable
|
||||
Resolves: #669364
|
||||
|
||||
* Thu Jan 13 2011 Tom Lane <tgl@redhat.com> 5.5.8-4
|
||||
- Fix crash during startup of embedded mysqld library
|
||||
Resolves: #667365
|
||||
|
Loading…
Reference in New Issue
Block a user