Update to MySQL 5.5.14
This commit is contained in:
parent
452cc9ad32
commit
0796115f4d
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/mysql-5.5.13-nodocs.tar.gz
|
/mysql-5.5.14-nodocs.tar.gz
|
||||||
|
@ -3,25 +3,24 @@ platform-dependent results, with the "expected" results being arguably the
|
|||||||
wrong ones. This is upstream at http://bugs.mysql.com/bug.php?id=46895
|
wrong ones. This is upstream at http://bugs.mysql.com/bug.php?id=46895
|
||||||
(note that upstream has also disabled it, but only for Solaris, so we still
|
(note that upstream has also disabled it, but only for Solaris, so we still
|
||||||
need this patch).
|
need this patch).
|
||||||
This is allegedly fixed for 5.5.14 ...
|
Still broken in 5.5.14, despite alleged fix.
|
||||||
|
|
||||||
Also disable sys_vars.plugin_dir_basic, which is broken because
|
Also disable sys_vars.plugin_dir_basic, which is broken because
|
||||||
mysql-test-run doesn't set the right value of MYSQL_LIBDIR. Upstream at
|
mysql-test-run doesn't set the right value of MYSQL_LIBDIR. Upstream at
|
||||||
http://bugs.mysql.com/bug.php?id=52223
|
http://bugs.mysql.com/bug.php?id=52223
|
||||||
Still fails in 5.5.13, but apparently due to be fixed soon?
|
Still fails in 5.5.14, even though upstream marked it closed.
|
||||||
upstream marked it closed on 2-May.
|
|
||||||
|
|
||||||
Also disable innodb.innodb, which is showing platform-dependent results
|
Also disable innodb.innodb, which is showing platform-dependent results
|
||||||
as of 5.5.9. Upstream at http://bugs.mysql.com/bug.php?id=60155
|
as of 5.5.9. Upstream at http://bugs.mysql.com/bug.php?id=60155
|
||||||
|
|
||||||
|
|
||||||
diff -Naur mysql-5.5.12.orig/mysql-test/t/disabled.def mysql-5.5.12/mysql-test/t/disabled.def
|
diff -Naur mysql-5.5.14.orig/mysql-test/t/disabled.def mysql-5.5.14/mysql-test/t/disabled.def
|
||||||
--- mysql-5.5.12.orig/mysql-test/t/disabled.def 2011-04-11 06:44:01.000000000 -0400
|
--- mysql-5.5.14.orig/mysql-test/t/disabled.def 2011-06-21 12:42:40.000000000 -0400
|
||||||
+++ mysql-5.5.12/mysql-test/t/disabled.def 2011-05-10 18:42:11.742438341 -0400
|
+++ mysql-5.5.14/mysql-test/t/disabled.def 2011-07-11 14:33:46.560138525 -0400
|
||||||
@@ -17,3 +17,7 @@
|
@@ -17,3 +17,7 @@
|
||||||
alter_table-big : Bug#37248 2010-11-15 mattiasj was not tested
|
|
||||||
create-big : Bug#37248 2010-11-15 mattiasj was not tested
|
|
||||||
archive-big : Bug#11817185 2011-03-10 Anitha Disabled since this leads to timeout on Solaris Sparc
|
archive-big : Bug#11817185 2011-03-10 Anitha Disabled since this leads to timeout on Solaris Sparc
|
||||||
|
main.query_cache_28249 : Bug#12584161 2009-03-25 main.query_cache_28249 fails sporadically
|
||||||
|
log_tables-big : Bug#11756699 2010-11-15 mattiasj report already exists
|
||||||
+#
|
+#
|
||||||
+outfile_loaddata : bug#46895 code wrong, expected results wrong too
|
+outfile_loaddata : bug#46895 code wrong, expected results wrong too
|
||||||
+sys_vars.plugin_dir_basic : bug#52223 fails for lib64 library directory
|
+sys_vars.plugin_dir_basic : bug#52223 fails for lib64 library directory
|
||||||
|
22
mysql-openssl-test.patch
Normal file
22
mysql-openssl-test.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
Adjust openssl_1.result to match actual output when using OpenSSL.
|
||||||
|
|
||||||
|
The given expected result seems to be yaSSL-specific, as of mysql 5.5.14.
|
||||||
|
Upstream at http://bugs.mysql.com/bug.php?id=61827
|
||||||
|
|
||||||
|
|
||||||
|
diff -Naur mysql-5.5.14.orig/mysql-test/r/openssl_1.result mysql-5.5.14/mysql-test/r/openssl_1.result
|
||||||
|
--- mysql-5.5.14.orig/mysql-test/r/openssl_1.result 2011-06-21 12:42:40.000000000 -0400
|
||||||
|
+++ mysql-5.5.14/mysql-test/r/openssl_1.result 2011-07-11 18:52:39.925070616 -0400
|
||||||
|
@@ -44,9 +44,9 @@
|
||||||
|
drop user ssl_user1@localhost, ssl_user2@localhost,
|
||||||
|
ssl_user3@localhost, ssl_user4@localhost, ssl_user5@localhost;
|
||||||
|
drop table t1;
|
||||||
|
-mysqltest: Could not open connection 'default': 2026 SSL connection error: ASN: bad other signature confirmation
|
||||||
|
-mysqltest: Could not open connection 'default': 2026 SSL connection error: ASN: bad other signature confirmation
|
||||||
|
-mysqltest: Could not open connection 'default': 2026 SSL connection error: ASN: bad other signature confirmation
|
||||||
|
+mysqltest: Could not open connection 'default': 2026 SSL connection error: error:00000001:lib(0):func(0):reason(1)
|
||||||
|
+mysqltest: Could not open connection 'default': 2026 SSL connection error: error:00000001:lib(0):func(0):reason(1)
|
||||||
|
+mysqltest: Could not open connection 'default': 2026 SSL connection error: error:00000001:lib(0):func(0):reason(1)
|
||||||
|
SSL error: Unable to get private key from ''
|
||||||
|
mysqltest: Could not open connection 'default': 2026 SSL connection error: Unable to get private key
|
||||||
|
SSL error: Unable to get certificate from ''
|
10
mysql.spec
10
mysql.spec
@ -1,6 +1,6 @@
|
|||||||
Name: mysql
|
Name: mysql
|
||||||
Version: 5.5.13
|
Version: 5.5.14
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: MySQL client programs and shared libraries
|
Summary: MySQL client programs and shared libraries
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
URL: http://www.mysql.com
|
URL: http://www.mysql.com
|
||||||
@ -44,6 +44,7 @@ Patch9: mysql-disable-test.patch
|
|||||||
Patch10: mysql-embedded-crash.patch
|
Patch10: mysql-embedded-crash.patch
|
||||||
Patch11: mysql-plugin-bool.patch
|
Patch11: mysql-plugin-bool.patch
|
||||||
Patch12: mysql-s390-tsc.patch
|
Patch12: mysql-s390-tsc.patch
|
||||||
|
Patch13: mysql-openssl-test.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
BuildRequires: perl, readline-devel, openssl-devel
|
BuildRequires: perl, readline-devel, openssl-devel
|
||||||
@ -187,6 +188,7 @@ the MySQL sources.
|
|||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
%patch11 -p1
|
%patch11 -p1
|
||||||
%patch12 -p1
|
%patch12 -p1
|
||||||
|
%patch13 -p1
|
||||||
|
|
||||||
# workaround for upstream bug #56342
|
# workaround for upstream bug #56342
|
||||||
rm -f mysql-test/t/ssl_8k_key-master.opt
|
rm -f mysql-test/t/ssl_8k_key-master.opt
|
||||||
@ -609,6 +611,10 @@ fi
|
|||||||
%{_mandir}/man1/mysql_client_test.1*
|
%{_mandir}/man1/mysql_client_test.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 11 2011 Tom Lane <tgl@redhat.com> 5.5.14-1
|
||||||
|
- Update to MySQL 5.5.14, for various fixes described at
|
||||||
|
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-14.html
|
||||||
|
|
||||||
* Wed Jul 6 2011 Tom Lane <tgl@redhat.com> 5.5.13-2
|
* Wed Jul 6 2011 Tom Lane <tgl@redhat.com> 5.5.13-2
|
||||||
- Remove erroneously-included Default-Start line from LSB init block
|
- Remove erroneously-included Default-Start line from LSB init block
|
||||||
Resolves: #717024
|
Resolves: #717024
|
||||||
|
Loading…
Reference in New Issue
Block a user