Update to MySQL 5.0.21.
This commit is contained in:
parent
587f6c6241
commit
fa98cf328f
@ -1 +1 @@
|
|||||||
mysql-5.0.18.tar.gz
|
mysql-5.0.21.tar.gz
|
||||||
|
@ -4,12 +4,12 @@ like /usr/share/mysql-test, we have to hack up the paths in install_test_db
|
|||||||
and mysql-test-run. This patch also improves the documentation a tad.
|
and mysql-test-run. This patch also improves the documentation a tad.
|
||||||
|
|
||||||
|
|
||||||
diff -Naur mysql-5.0.18.orig/mysql-test/README mysql-5.0.18/mysql-test/README
|
diff -Naur mysql-5.0.21.orig/mysql-test/README mysql-5.0.21/mysql-test/README
|
||||||
--- mysql-5.0.18.orig/mysql-test/README 2005-12-21 14:39:48.000000000 -0500
|
--- mysql-5.0.21.orig/mysql-test/README 2006-04-26 14:31:03.000000000 -0400
|
||||||
+++ mysql-5.0.18/mysql-test/README 2006-03-09 20:29:24.000000000 -0500
|
+++ mysql-5.0.21/mysql-test/README 2006-05-01 20:58:04.000000000 -0400
|
||||||
@@ -2,11 +2,20 @@
|
@@ -6,6 +6,14 @@
|
||||||
the currently existing test cases, simply execute ./mysql-test-run in
|
actually have a co-existing MySQL installation. The tests will not
|
||||||
this directory. It will fire up the newly built mysqld and test it.
|
conflict with it.
|
||||||
|
|
||||||
+For use in Red Hat distributions, you should run the script as user mysql,
|
+For use in Red Hat distributions, you should run the script as user mysql,
|
||||||
+so the best bet is something like
|
+so the best bet is something like
|
||||||
@ -19,20 +19,22 @@ diff -Naur mysql-5.0.18.orig/mysql-test/README mysql-5.0.18/mysql-test/README
|
|||||||
+of the server process (using data files within /usr/share/mysql-test),
|
+of the server process (using data files within /usr/share/mysql-test),
|
||||||
+so you need not start the mysqld service beforehand.
|
+so you need not start the mysqld service beforehand.
|
||||||
+
|
+
|
||||||
If you want to run a test with a running MySQL server use the --extern
|
All tests must pass. If one or more of them fail on your system, please
|
||||||
option to mysql-test-run. Please note that in this mode the test suite
|
read the following manual section for instructions on how to report the
|
||||||
expects user to specify test names to run. Otherwise it falls back to the
|
problem:
|
||||||
-normal "non-extern" behaviour. The reason is that some tests
|
@@ -25,7 +33,8 @@
|
||||||
-could not run with external server. Here is the sample command
|
|
||||||
+normal "non-extern" behaviour. The reason is that many tests
|
|
||||||
+will fail with external server (because they need to control the options
|
|
||||||
+with which the server is started). Here is the sample command
|
|
||||||
to test "alias" and "analyze" tests on external server:
|
|
||||||
|
|
||||||
mysql-test-run --extern alias analyze
|
With no test cases named on the command line, mysql-test-run falls back
|
||||||
diff -Naur mysql-5.0.18.orig/mysql-test/install_test_db.sh mysql-5.0.18/mysql-test/install_test_db.sh
|
to the normal "non-extern" behavior. The reason for this is that some
|
||||||
--- mysql-5.0.18.orig/mysql-test/install_test_db.sh 2005-12-21 14:39:48.000000000 -0500
|
-tests cannot run with an external server.
|
||||||
+++ mysql-5.0.18/mysql-test/install_test_db.sh 2006-03-09 20:20:45.000000000 -0500
|
+tests cannot run with an external server (because they need to control the
|
||||||
|
+options with which the server is started).
|
||||||
|
|
||||||
|
|
||||||
|
You can create your own test cases. To create a test case, create a new
|
||||||
|
diff -Naur mysql-5.0.21.orig/mysql-test/install_test_db.sh mysql-5.0.21/mysql-test/install_test_db.sh
|
||||||
|
--- mysql-5.0.21.orig/mysql-test/install_test_db.sh 2006-04-26 14:31:03.000000000 -0400
|
||||||
|
+++ mysql-5.0.21/mysql-test/install_test_db.sh 2006-05-01 20:56:05.000000000 -0400
|
||||||
@@ -9,17 +9,17 @@
|
@@ -9,17 +9,17 @@
|
||||||
shift 1
|
shift 1
|
||||||
|
|
||||||
@ -67,10 +69,10 @@ diff -Naur mysql-5.0.18.orig/mysql-test/install_test_db.sh mysql-5.0.18/mysql-te
|
|||||||
else
|
else
|
||||||
basedir=.
|
basedir=.
|
||||||
EXTRA_ARG="--language=../sql/share/english/ --character-sets-dir=../sql/share/charsets/"
|
EXTRA_ARG="--language=../sql/share/english/ --character-sets-dir=../sql/share/charsets/"
|
||||||
diff -Naur mysql-5.0.18.orig/mysql-test/mysql-test-run.sh mysql-5.0.18/mysql-test/mysql-test-run.sh
|
diff -Naur mysql-5.0.21.orig/mysql-test/mysql-test-run.sh mysql-5.0.21/mysql-test/mysql-test-run.sh
|
||||||
--- mysql-5.0.18.orig/mysql-test/mysql-test-run.sh 2005-12-21 14:39:59.000000000 -0500
|
--- mysql-5.0.21.orig/mysql-test/mysql-test-run.sh 2006-04-26 14:31:05.000000000 -0400
|
||||||
+++ mysql-5.0.18/mysql-test/mysql-test-run.sh 2006-03-09 20:20:45.000000000 -0500
|
+++ mysql-5.0.21/mysql-test/mysql-test-run.sh 2006-05-01 20:56:05.000000000 -0400
|
||||||
@@ -693,6 +693,8 @@
|
@@ -740,6 +740,8 @@
|
||||||
# currently all binaries are in "bin", for a MySQL AB packaging
|
# currently all binaries are in "bin", for a MySQL AB packaging
|
||||||
# some are in "tests".
|
# some are in "tests".
|
||||||
|
|
||||||
|
@ -1,11 +1,12 @@
|
|||||||
diff -Naur mysql-4.1.7-orig/scripts/mysql_config.sh mysql-4.1.7/scripts/mysql_config.sh
|
diff -Naur mysql-5.0.21.orig/scripts/mysql_config.sh mysql-5.0.21/scripts/mysql_config.sh
|
||||||
--- mysql-4.1.7-orig/scripts/mysql_config.sh 2004-10-23 03:28:44.000000000 -0400
|
--- mysql-5.0.21.orig/scripts/mysql_config.sh 2006-04-26 14:30:47.000000000 -0400
|
||||||
+++ mysql-4.1.7/scripts/mysql_config.sh 2004-10-27 21:15:48.762963874 -0400
|
+++ mysql-5.0.21/scripts/mysql_config.sh 2006-05-01 20:45:42.000000000 -0400
|
||||||
@@ -75,7 +75,6 @@
|
@@ -85,8 +85,6 @@
|
||||||
execdir='@libexecdir@'
|
|
||||||
bindir='@bindir@'
|
# If installed, search for the compiled in directory first (might be "lib64")
|
||||||
pkglibdir='@pkglibdir@'
|
pkglibdir='@pkglibdir@'
|
||||||
-fix_path pkglibdir lib/mysql lib
|
-pkglibdir_rel=`echo $pkglibdir | sed -e "s;^$basedir/;;"`
|
||||||
|
-fix_path pkglibdir $pkglibdir_rel lib/mysql lib
|
||||||
|
|
||||||
pkgincludedir='@pkgincludedir@'
|
pkgincludedir='@pkgincludedir@'
|
||||||
fix_path pkgincludedir include/mysql include
|
fix_path pkgincludedir include/mysql include
|
||||||
version='@VERSION@'
|
|
||||||
|
@ -4,15 +4,18 @@ which is we avoid the 4-vs-8-byte problem in BDB that formerly required
|
|||||||
mysql-threads.patch.
|
mysql-threads.patch.
|
||||||
|
|
||||||
|
|
||||||
diff -Naur mysql-4.1.12.orig/configure.in mysql-4.1.12/configure.in
|
diff -Naur mysql-5.0.21.orig/configure.in mysql-5.0.21/configure.in
|
||||||
--- mysql-4.1.12.orig/configure.in 2005-05-13 07:32:33.000000000 -0400
|
--- mysql-5.0.21.orig/configure.in 2006-04-26 14:31:03.000000000 -0400
|
||||||
+++ mysql-4.1.12/configure.in 2005-07-11 12:16:28.000000000 -0400
|
+++ mysql-5.0.21/configure.in 2006-05-01 20:52:08.000000000 -0400
|
||||||
@@ -862,43 +862,6 @@
|
@@ -803,47 +803,6 @@
|
||||||
AC_SUBST(WRAPLIBS)
|
AC_SUBST(WRAPLIBS)
|
||||||
|
|
||||||
if test "$TARGET_LINUX" = "true"; then
|
if test "$TARGET_LINUX" = "true"; then
|
||||||
- AC_MSG_CHECKING([for atomic operations])
|
- AC_MSG_CHECKING([for atomic operations])
|
||||||
-
|
-
|
||||||
|
- AC_LANG_SAVE
|
||||||
|
- AC_LANG_CPLUSPLUS
|
||||||
|
-
|
||||||
- atom_ops=
|
- atom_ops=
|
||||||
- AC_TRY_RUN([
|
- AC_TRY_RUN([
|
||||||
-#include <asm/atomic.h>
|
-#include <asm/atomic.h>
|
||||||
@ -48,6 +51,7 @@ diff -Naur mysql-4.1.12.orig/configure.in mysql-4.1.12/configure.in
|
|||||||
- if test -z "$atom_ops"; then atom_ops="no"; fi
|
- if test -z "$atom_ops"; then atom_ops="no"; fi
|
||||||
- AC_MSG_RESULT($atom_ops)
|
- AC_MSG_RESULT($atom_ops)
|
||||||
-
|
-
|
||||||
|
- AC_LANG_RESTORE
|
||||||
|
|
||||||
AC_ARG_WITH(pstack,
|
AC_ARG_WITH(pstack,
|
||||||
[ --with-pstack Use the pstack backtrace library],
|
[ --with-pstack Use the pstack backtrace library],
|
||||||
[ USE_PSTACK=$withval ],
|
|
||||||
|
10
mysql.spec
10
mysql.spec
@ -1,6 +1,6 @@
|
|||||||
Name: mysql
|
Name: mysql
|
||||||
Version: 5.0.18
|
Version: 5.0.21
|
||||||
Release: 4
|
Release: 1
|
||||||
Summary: MySQL client programs and shared libraries.
|
Summary: MySQL client programs and shared libraries.
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
@ -343,6 +343,7 @@ fi
|
|||||||
%{_bindir}/mysql_secure_installation
|
%{_bindir}/mysql_secure_installation
|
||||||
%{_bindir}/mysql_setpermission
|
%{_bindir}/mysql_setpermission
|
||||||
%{_bindir}/mysql_tzinfo_to_sql
|
%{_bindir}/mysql_tzinfo_to_sql
|
||||||
|
%{_bindir}/mysql_upgrade
|
||||||
%{_bindir}/mysql_zap
|
%{_bindir}/mysql_zap
|
||||||
%{_bindir}/mysqlbug
|
%{_bindir}/mysqlbug
|
||||||
%{_bindir}/mysqld_multi
|
%{_bindir}/mysqld_multi
|
||||||
@ -364,9 +365,11 @@ fi
|
|||||||
%{_mandir}/man1/myisamchk.1.gz
|
%{_mandir}/man1/myisamchk.1.gz
|
||||||
%{_mandir}/man1/myisamlog.1.gz
|
%{_mandir}/man1/myisamlog.1.gz
|
||||||
%{_mandir}/man1/myisampack.1.gz
|
%{_mandir}/man1/myisampack.1.gz
|
||||||
|
%{_mandir}/man1/myisam_ftdump.1.gz
|
||||||
%{_mandir}/man1/mysql.server.1.gz
|
%{_mandir}/man1/mysql.server.1.gz
|
||||||
%{_mandir}/man1/mysql_config.1.gz
|
%{_mandir}/man1/mysql_config.1.gz
|
||||||
%{_mandir}/man1/mysql_fix_privilege_tables.1*
|
%{_mandir}/man1/mysql_fix_privilege_tables.1*
|
||||||
|
%{_mandir}/man1/mysql_upgrade.1*
|
||||||
%{_mandir}/man1/mysql_zap.1*
|
%{_mandir}/man1/mysql_zap.1*
|
||||||
%{_mandir}/man1/mysqlbinlog.1.gz
|
%{_mandir}/man1/mysqlbinlog.1.gz
|
||||||
%{_mandir}/man1/mysqlcheck.1.gz
|
%{_mandir}/man1/mysqlcheck.1.gz
|
||||||
@ -407,6 +410,9 @@ fi
|
|||||||
%attr(-,mysql,mysql) %{_datadir}/mysql-test
|
%attr(-,mysql,mysql) %{_datadir}/mysql-test
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 1 2006 Tom Lane <tgl@redhat.com> 5.0.21-1
|
||||||
|
- Update to MySQL 5.0.21
|
||||||
|
|
||||||
* Mon Mar 27 2006 Tom Lane <tgl@redhat.com> 5.0.18-4
|
* Mon Mar 27 2006 Tom Lane <tgl@redhat.com> 5.0.18-4
|
||||||
- Modify multilib header hack to not break non-RH arches, per bug #181335
|
- Modify multilib header hack to not break non-RH arches, per bug #181335
|
||||||
- Remove logrotate script, per bug #180639.
|
- Remove logrotate script, per bug #180639.
|
||||||
|
Loading…
Reference in New Issue
Block a user