Merge mysql-test-ssl.patch into mysql-testing.patch since the latter turns

out to have to touch the same files to work properly in 5.0.
This commit is contained in:
Tom Lane 2005-11-03 04:05:15 +00:00 committed by Michal Schorm
parent 6cfe7c32f0
commit 850b2a0e7e
2 changed files with 35 additions and 6 deletions

View File

@ -4,11 +4,42 @@ architecture may be built on the same machine at the same time, so we have
to ensure that the tests use different port numbers on a 64-bit arch than to ensure that the tests use different port numbers on a 64-bit arch than
on a 32-bit, else they will interfere with each other. on a 32-bit, else they will interfere with each other.
We also have to hack the top-level Makefile to enable the openssl regression
tests. (Why doesn't this happen automatically given the configure option??)
diff -Naur mysql-4.1.11.orig/mysql-test/mysql-test-run.sh mysql-4.1.11/mysql-test/mysql-test-run.sh Note: keep an eye on which version of "mysql-test-run" gets invoked by
--- mysql-4.1.11.orig/mysql-test/mysql-test-run.sh 2005-04-07 16:09:59.971778102 -0400 the "make test" target. In the 4.1 branch this is now defaulting to the
+++ mysql-4.1.11/mysql-test/mysql-test-run.sh 2005-04-07 16:11:29.993510299 -0400 perl script, but 5.0 is not (yet?) doing that; they also seem to be fooling
@@ -200,11 +200,24 @@ with a C-code version. Besides this patch, mysql-libtool.patch
would need to be changed to use either one.
diff -Naur mysql-5.0.15.orig/Makefile.am mysql-5.0.15/Makefile.am
--- mysql-5.0.15.orig/Makefile.am 2005-10-16 21:27:31.000000000 -0400
+++ mysql-5.0.15/Makefile.am 2005-11-02 22:56:50.000000000 -0500
@@ -97,16 +97,9 @@
support-files/build-tags
.PHONY: init-db bin-dist
-# Test installation. Ports are configurable from the environment.
+# Test installation. Ports are determined by code in mysql-test-run.sh
-MYSQL_TEST_MANAGER_PORT = 9305
-MYSQL_TEST_MASTER_PORT = 9306
-MYSQL_TEST_SLAVE_PORT = 9308
-MYSQL_TEST_NDB_PORT = 9350
-MYSQL_TEST_RUN_ARGS = --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
- --master_port=$(MYSQL_TEST_MASTER_PORT) \
- --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
- --ndbcluster_port=$(MYSQL_TEST_NDB_PORT)
+MYSQL_TEST_RUN_ARGS = --with-openssl
test:
cd mysql-test ; \
diff -Naur mysql-5.0.15.orig/mysql-test/mysql-test-run.sh mysql-5.0.15/mysql-test/mysql-test-run.sh
--- mysql-5.0.15.orig/mysql-test/mysql-test-run.sh 2005-10-16 21:27:55.000000000 -0400
+++ mysql-5.0.15/mysql-test/mysql-test-run.sh 2005-11-02 22:55:14.000000000 -0500
@@ -208,11 +208,24 @@
MASTER_RUNNING=0 MASTER_RUNNING=0
MASTER1_RUNNING=0 MASTER1_RUNNING=0

View File

@ -13,7 +13,6 @@ Patch2: mysql-errno.patch
Patch3: mysql-libtool.patch Patch3: mysql-libtool.patch
Patch4: mysql-testing.patch Patch4: mysql-testing.patch
Patch5: mysql-no-atomic.patch Patch5: mysql-no-atomic.patch
Patch6: mysql-test-ssl.patch
URL: http://www.mysql.com URL: http://www.mysql.com
BuildRoot: %{_tmppath}/%{name}-%{version}-root BuildRoot: %{_tmppath}/%{name}-%{version}-root
Summary: MySQL client programs and shared libraries. Summary: MySQL client programs and shared libraries.
@ -92,7 +91,6 @@ MySQL.
%patch3 -p1 %patch3 -p1
%patch4 -p1 %patch4 -p1
%patch5 -p1 %patch5 -p1
%patch6 -p1
libtoolize --force libtoolize --force
aclocal aclocal