Avoid dependency on <asm/atomic.h>, cause it won't build anymore on ia64.
This commit is contained in:
parent
652b269cca
commit
7d81af0361
68
mysql-no-atomic.patch
Normal file
68
mysql-no-atomic.patch
Normal file
@ -0,0 +1,68 @@
|
||||
The idea of userland using <asm/atomic.h> has our kernel hackers all bent
|
||||
out of shape, so don't do it. Suppressing this has another benefit too,
|
||||
which is we avoid the 4-vs-8-byte problem in BDB that formerly required
|
||||
mysql-threads.patch.
|
||||
|
||||
If you're wondering about the hack on Docs/Makefile.am, it's to prevent
|
||||
it from deciding we need to rebuild the docs after patching configure.in.
|
||||
|
||||
|
||||
diff -Naur mysql-4.1.11.orig/configure.in mysql-4.1.11/configure.in
|
||||
--- mysql-4.1.11.orig/configure.in 2005-04-01 06:36:51.000000000 -0500
|
||||
+++ mysql-4.1.11/configure.in 2005-04-08 16:16:18.000000000 -0400
|
||||
@@ -842,43 +842,6 @@
|
||||
AC_SUBST(WRAPLIBS)
|
||||
|
||||
if test "$IS_LINUX" = "true"; then
|
||||
- AC_MSG_CHECKING([for atomic operations])
|
||||
-
|
||||
- atom_ops=
|
||||
- AC_TRY_RUN([
|
||||
-#include <asm/atomic.h>
|
||||
-int main()
|
||||
-{
|
||||
- atomic_t v;
|
||||
-
|
||||
- atomic_set(&v, 23);
|
||||
- atomic_add(5, &v);
|
||||
- return atomic_read(&v) == 28 ? 0 : -1;
|
||||
-}
|
||||
- ],
|
||||
- [AC_DEFINE([HAVE_ATOMIC_ADD], [1],
|
||||
- [atomic_add() from <asm/atomic.h> (Linux only)])
|
||||
- atom_ops="${atom_ops}atomic_add "],
|
||||
- )
|
||||
- AC_TRY_RUN([
|
||||
-#include <asm/atomic.h>
|
||||
-int main()
|
||||
-{
|
||||
- atomic_t v;
|
||||
-
|
||||
- atomic_set(&v, 23);
|
||||
- atomic_sub(5, &v);
|
||||
- return atomic_read(&v) == 18 ? 0 : -1;
|
||||
-}
|
||||
- ],
|
||||
- [AC_DEFINE([HAVE_ATOMIC_SUB], [1],
|
||||
- [atomic_sub() from <asm/atomic.h> (Linux only)])
|
||||
- atom_ops="${atom_ops}atomic_sub "],
|
||||
- )
|
||||
-
|
||||
- if test -z "$atom_ops"; then atom_ops="no"; fi
|
||||
- AC_MSG_RESULT($atom_ops)
|
||||
-
|
||||
AC_ARG_WITH(pstack,
|
||||
[ --with-pstack Use the pstack backtrace library],
|
||||
[ USE_PSTACK=$withval ],
|
||||
diff -Naur mysql-4.1.11.orig/Docs/Makefile.am mysql-4.1.11/Docs/Makefile.am
|
||||
--- mysql-4.1.11.orig/Docs/Makefile.am 2005-04-01 06:36:45.000000000 -0500
|
||||
+++ mysql-4.1.11/Docs/Makefile.am 2005-04-08 16:47:02.865502712 -0400
|
||||
@@ -41,7 +41,7 @@
|
||||
#########################################################################
|
||||
|
||||
# The Makefile contains the previous version so we can not use that
|
||||
-include.texi: ../configure.in
|
||||
+include.texi:
|
||||
echo "@c This file is autogenerated by the Makefile" > $@
|
||||
echo -n "@set mysqlversion " >> $@
|
||||
grep "AM_INIT_AUTOMAKE(mysql, " ../configure.in | \
|
@ -1,6 +1,6 @@
|
||||
Name: mysql
|
||||
Version: 4.1.11
|
||||
Release: 1
|
||||
Release: 2
|
||||
Source0: http://dev.mysql.com/get/Downloads/MySQL-4.1/mysql-%{version}.tar.gz
|
||||
Source1: mysql.init
|
||||
Source2: mysql.logrotate
|
||||
@ -12,7 +12,7 @@ Patch1: mysql-libdir.patch
|
||||
Patch2: mysql-errno.patch
|
||||
Patch3: mysql-libtool.patch
|
||||
Patch4: mysql-testing.patch
|
||||
Patch5: mysql-threads.patch
|
||||
Patch5: mysql-no-atomic.patch
|
||||
URL: http://www.mysql.com
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Summary: MySQL client programs and shared libraries.
|
||||
@ -363,6 +363,10 @@ fi
|
||||
%{_datadir}/sql-bench
|
||||
|
||||
%changelog
|
||||
* Fri Apr 8 2005 Tom Lane <tgl@redhat.com> 4.1.11-2
|
||||
- Avoid dependency on <asm/atomic.h>, cause it won't build anymore on ia64.
|
||||
This is probably a cleaner solution for bz#143537, too.
|
||||
|
||||
* Thu Apr 7 2005 Tom Lane <tgl@redhat.com> 4.1.11-1
|
||||
- Update to MySQL 4.1.11 to fix bz#152911 as well as other issues
|
||||
- Move perl-DBI, perl-DBD-MySQL dependencies to server package (bz#154123)
|
||||
|
Loading…
Reference in New Issue
Block a user