Disable gis test; adjust perl requires filtering for rpm 4.9.
This commit is contained in:
parent
6303e84448
commit
5432a5d7e3
@ -12,11 +12,15 @@ Also disable perfschema.binlog_mix and perfschema.binlog_row, which have
|
|||||||
expected output that doesn't match when openssl is in use. Upstream at
|
expected output that doesn't match when openssl is in use. Upstream at
|
||||||
http://bugs.mysql.com/bug.php?id=59091
|
http://bugs.mysql.com/bug.php?id=59091
|
||||||
|
|
||||||
|
Also disable gis, which expects the results of floating-point calculations
|
||||||
|
to match to seventeen digits precision everywhere. Of course they won't.
|
||||||
|
Upstream at http://bugs.mysql.com/bug.php?id=59908
|
||||||
|
|
||||||
|
|
||||||
diff -Naur mysql-5.5.8.orig/mysql-test/t/disabled.def mysql-5.5.8/mysql-test/t/disabled.def
|
diff -Naur mysql-5.5.8.orig/mysql-test/t/disabled.def mysql-5.5.8/mysql-test/t/disabled.def
|
||||||
--- mysql-5.5.8.orig/mysql-test/t/disabled.def 2010-12-03 12:58:24.000000000 -0500
|
--- mysql-5.5.8.orig/mysql-test/t/disabled.def 2010-12-03 12:58:24.000000000 -0500
|
||||||
+++ mysql-5.5.8/mysql-test/t/disabled.def 2010-12-21 11:03:07.288224692 -0500
|
+++ mysql-5.5.8/mysql-test/t/disabled.def 2011-02-03 11:10:31.325627589 -0500
|
||||||
@@ -19,3 +19,8 @@
|
@@ -19,3 +19,9 @@
|
||||||
sum_distinct-big : Bug#56927 2010-11-15 mattiasj was not tested
|
sum_distinct-big : Bug#56927 2010-11-15 mattiasj was not tested
|
||||||
alter_table-big : Bug#37248 2010-11-15 mattiasj was not tested
|
alter_table-big : Bug#37248 2010-11-15 mattiasj was not tested
|
||||||
create-big : Bug#37248 2010-11-15 mattiasj was not tested
|
create-big : Bug#37248 2010-11-15 mattiasj was not tested
|
||||||
@ -25,3 +29,4 @@ diff -Naur mysql-5.5.8.orig/mysql-test/t/disabled.def mysql-5.5.8/mysql-test/t/d
|
|||||||
+sys_vars.plugin_dir_basic : bug#52223 fails for lib64 library directory
|
+sys_vars.plugin_dir_basic : bug#52223 fails for lib64 library directory
|
||||||
+perfschema.binlog_mix : bug#59091 fails with openssl
|
+perfschema.binlog_mix : bug#59091 fails with openssl
|
||||||
+perfschema.binlog_row : bug#59091 fails with openssl
|
+perfschema.binlog_row : bug#59091 fails with openssl
|
||||||
|
+gis : bug#59908 has platform-dependent results
|
||||||
|
16
mysql.spec
16
mysql.spec
@ -1,6 +1,6 @@
|
|||||||
Name: mysql
|
Name: mysql
|
||||||
Version: 5.5.8
|
Version: 5.5.8
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
Summary: MySQL client programs and shared libraries
|
Summary: MySQL client programs and shared libraries
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
URL: http://www.mysql.com
|
URL: http://www.mysql.com
|
||||||
@ -62,8 +62,9 @@ Conflicts: MySQL
|
|||||||
# mysql-cluster used to be built from this SRPM, but no more
|
# mysql-cluster used to be built from this SRPM, but no more
|
||||||
Obsoletes: mysql-cluster < 5.1.44
|
Obsoletes: mysql-cluster < 5.1.44
|
||||||
|
|
||||||
# Working around perl dependency checking bug in rpm FTTB. Remove later.
|
# When rpm 4.9 is universal, this could be cleaned up:
|
||||||
%global __perl_requires %{SOURCE999}
|
%global __perl_requires %{SOURCE999}
|
||||||
|
%global __perllib_requires %{SOURCE999}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
MySQL is a multi-user, multi-threaded SQL database server. MySQL is a
|
MySQL is a multi-user, multi-threaded SQL database server. MySQL is a
|
||||||
@ -208,11 +209,6 @@ CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
|
|||||||
CFLAGS="$CFLAGS -fno-strict-aliasing -fwrapv"
|
CFLAGS="$CFLAGS -fno-strict-aliasing -fwrapv"
|
||||||
# force PIC mode so that we can build libmysqld.so
|
# force PIC mode so that we can build libmysqld.so
|
||||||
CFLAGS="$CFLAGS -fPIC"
|
CFLAGS="$CFLAGS -fPIC"
|
||||||
# MySQL 5.5.8 fails its gis regression test on PPC without -ffloat-store;
|
|
||||||
# filed upstream at http://bugs.mysql.com/bug.php?id=59908
|
|
||||||
%ifarch ppc ppc64
|
|
||||||
CFLAGS="$CFLAGS -ffloat-store"
|
|
||||||
%endif
|
|
||||||
# gcc seems to have some bugs on sparc as of 4.4.1, back off optimization
|
# gcc seems to have some bugs on sparc as of 4.4.1, back off optimization
|
||||||
# submitted as bz #529298
|
# submitted as bz #529298
|
||||||
%ifarch sparc sparcv9 sparc64
|
%ifarch sparc sparcv9 sparc64
|
||||||
@ -606,6 +602,12 @@ fi
|
|||||||
%{_mandir}/man1/mysql_client_test.1*
|
%{_mandir}/man1/mysql_client_test.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 3 2011 Tom Lane <tgl@redhat.com> 5.5.8-8
|
||||||
|
- PPC64 floating-point differences are not masked by -ffloat-store after all,
|
||||||
|
so let's just disable gis regression test till upstream makes it less picky
|
||||||
|
Resolves: #674253
|
||||||
|
- Add __perllib_requires setting to make rpm 4.9 do what we need
|
||||||
|
|
||||||
* Wed Feb 2 2011 Tom Lane <tgl@redhat.com> 5.5.8-7
|
* Wed Feb 2 2011 Tom Lane <tgl@redhat.com> 5.5.8-7
|
||||||
- Work around some portability issues on PPC64
|
- Work around some portability issues on PPC64
|
||||||
Resolves: #674253
|
Resolves: #674253
|
||||||
|
Loading…
Reference in New Issue
Block a user