Update to MySQL 5.0.45. Also fix bzs 241912, 245770.
This commit is contained in:
parent
1e2d80ff8a
commit
2c9ebe036a
@ -1 +1 @@
|
||||
mysql-5.0.37.tar.gz
|
||||
mysql-5.0.45.tar.gz
|
||||
|
@ -1,16 +0,0 @@
|
||||
Crude workaround for upstream bug #27035 ... don't these people even run
|
||||
their own regression tests before making releases?
|
||||
|
||||
|
||||
diff -Naur mysql-5.0.37.orig/mysql-test/r/information_schema.result mysql-5.0.37/mysql-test/r/information_schema.result
|
||||
--- mysql-5.0.37.orig/mysql-test/r/information_schema.result 2007-03-05 14:40:30.000000000 -0500
|
||||
+++ mysql-5.0.37/mysql-test/r/information_schema.result 2007-03-12 11:48:12.000000000 -0400
|
||||
@@ -1096,7 +1096,7 @@
|
||||
group by column_type order by num;
|
||||
column_type group_concat(table_schema, '.', table_name) num
|
||||
varchar(20) information_schema.COLUMNS,information_schema.PROFILING 2
|
||||
-varchar(7) information_schema.PROFILING,information_schema.PROFILING,information_schema.PROFILING,information_schema.ROUTINES,information_schema.VIEWS 5
|
||||
+varchar(7) information_schema.ROUTINES,information_schema.VIEWS 2
|
||||
create table t1(f1 char(1) not null, f2 char(9) not null)
|
||||
default character set utf8;
|
||||
select CHARACTER_MAXIMUM_LENGTH, CHARACTER_OCTET_LENGTH from
|
@ -4,9 +4,9 @@ like /usr/share/mysql-test, we have to hack up the paths in install_test_db.
|
||||
This patch also improves the documentation a tad.
|
||||
|
||||
|
||||
diff -Naur mysql-5.0.33.orig/mysql-test/README mysql-5.0.33/mysql-test/README
|
||||
--- mysql-5.0.33.orig/mysql-test/README 2007-01-09 07:51:08.000000000 -0500
|
||||
+++ mysql-5.0.33/mysql-test/README 2007-02-09 12:27:08.000000000 -0500
|
||||
diff -Naur mysql-5.0.40.orig/mysql-test/README mysql-5.0.40/mysql-test/README
|
||||
--- mysql-5.0.40.orig/mysql-test/README 2007-04-20 10:14:42.000000000 -0400
|
||||
+++ mysql-5.0.40/mysql-test/README 2007-05-23 14:41:03.000000000 -0400
|
||||
@@ -6,6 +6,14 @@
|
||||
actually have a co-existing MySQL installation. The tests will not
|
||||
conflict with it.
|
||||
@ -32,10 +32,10 @@ diff -Naur mysql-5.0.33.orig/mysql-test/README mysql-5.0.33/mysql-test/README
|
||||
|
||||
|
||||
You can create your own test cases. To create a test case, create a new
|
||||
diff -Naur mysql-5.0.33.orig/mysql-test/install_test_db.sh mysql-5.0.33/mysql-test/install_test_db.sh
|
||||
--- mysql-5.0.33.orig/mysql-test/install_test_db.sh 2007-01-09 07:51:07.000000000 -0500
|
||||
+++ mysql-5.0.33/mysql-test/install_test_db.sh 2007-02-09 12:32:00.000000000 -0500
|
||||
@@ -14,18 +14,15 @@
|
||||
diff -Naur mysql-5.0.40.orig/mysql-test/install_test_db.sh mysql-5.0.40/mysql-test/install_test_db.sh
|
||||
--- mysql-5.0.40.orig/mysql-test/install_test_db.sh 2007-04-20 10:14:31.000000000 -0400
|
||||
+++ mysql-5.0.40/mysql-test/install_test_db.sh 2007-05-23 14:39:44.000000000 -0400
|
||||
@@ -26,18 +26,15 @@
|
||||
libexecdir=../libexec
|
||||
|
||||
# Check if it's a binary distribution or a 'make install'
|
||||
@ -47,7 +47,7 @@ diff -Naur mysql-5.0.33.orig/mysql-test/install_test_db.sh mysql-5.0.33/mysql-te
|
||||
- then
|
||||
- execdir=../../sbin
|
||||
- bindir=../../bin
|
||||
- scriptdir=../../bin
|
||||
- scriptdir=../bin
|
||||
- libexecdir=../../libexec
|
||||
+ execdir=/usr/libexec
|
||||
else
|
||||
@ -60,7 +60,7 @@ diff -Naur mysql-5.0.33.orig/mysql-test/install_test_db.sh mysql-5.0.33/mysql-te
|
||||
fix_bin=mysql-test
|
||||
else
|
||||
execdir=../sql
|
||||
@@ -82,7 +79,8 @@
|
||||
@@ -97,7 +94,8 @@
|
||||
|
||||
#for error messages
|
||||
if [ x$BINARY_DIST = x1 ] ; then
|
||||
@ -69,4 +69,4 @@ diff -Naur mysql-5.0.33.orig/mysql-test/install_test_db.sh mysql-5.0.33/mysql-te
|
||||
+EXTRA_ARG="--language=/usr/share/mysql/english/ --character-sets-dir=/usr/share/mysql/charsets/"
|
||||
else
|
||||
basedir=.
|
||||
EXTRA_ARG="--language=../sql/share/english/ --character-sets-dir=../sql/share/charsets/"
|
||||
EXTRA_ARG="--windows"
|
||||
|
@ -1,11 +1,10 @@
|
||||
diff -Naur mysql-5.0.21.orig/scripts/mysql_config.sh mysql-5.0.21/scripts/mysql_config.sh
|
||||
--- mysql-5.0.21.orig/scripts/mysql_config.sh 2006-04-26 14:30:47.000000000 -0400
|
||||
+++ mysql-5.0.21/scripts/mysql_config.sh 2006-05-01 20:45:42.000000000 -0400
|
||||
@@ -85,8 +85,6 @@
|
||||
|
||||
diff -Naur mysql-5.0.28.orig/scripts/mysql_config.sh mysql-5.0.28/scripts/mysql_config.sh
|
||||
--- mysql-5.0.28.orig/scripts/mysql_config.sh 2006-10-24 17:04:01.000000000 -0400
|
||||
+++ mysql-5.0.28/scripts/mysql_config.sh 2006-11-29 17:36:42.000000000 -0500
|
||||
@@ -86,7 +86,6 @@
|
||||
# If installed, search for the compiled in directory first (might be "lib64")
|
||||
pkglibdir='@pkglibdir@'
|
||||
-pkglibdir_rel=`echo $pkglibdir | sed -e "s;^$basedir/;;"`
|
||||
pkglibdir_rel=`echo $pkglibdir | sed -e "s;^$basedir/;;"`
|
||||
-fix_path pkglibdir $pkglibdir_rel lib/mysql lib
|
||||
|
||||
pkgincludedir='@pkgincludedir@'
|
||||
|
@ -4,10 +4,10 @@ which is we avoid the 4-vs-8-byte problem in BDB that formerly required
|
||||
mysql-threads.patch.
|
||||
|
||||
|
||||
diff -Naur mysql-5.0.21.orig/configure.in mysql-5.0.21/configure.in
|
||||
--- mysql-5.0.21.orig/configure.in 2006-04-26 14:31:03.000000000 -0400
|
||||
+++ mysql-5.0.21/configure.in 2006-05-01 20:52:08.000000000 -0400
|
||||
@@ -803,47 +803,6 @@
|
||||
diff -Naur mysql-5.0.28.orig/configure.in mysql-5.0.28/configure.in
|
||||
--- mysql-5.0.28.orig/configure.in 2006-10-24 17:03:51.000000000 -0400
|
||||
+++ mysql-5.0.28/configure.in 2006-11-29 17:39:39.000000000 -0500
|
||||
@@ -814,48 +814,6 @@
|
||||
AC_SUBST(WRAPLIBS)
|
||||
|
||||
if test "$TARGET_LINUX" = "true"; then
|
||||
@ -52,6 +52,7 @@ diff -Naur mysql-5.0.21.orig/configure.in mysql-5.0.21/configure.in
|
||||
- AC_MSG_RESULT($atom_ops)
|
||||
-
|
||||
- AC_LANG_RESTORE
|
||||
|
||||
-
|
||||
AC_ARG_WITH(pstack,
|
||||
[ --with-pstack Use the pstack backtrace library],
|
||||
[ USE_PSTACK=$withval ],
|
||||
|
@ -1,16 +0,0 @@
|
||||
Workaround for recently-introduced SSL breakage, filed as upstream bug
|
||||
#24121 (why is this still not fixed in 5.0.37?)
|
||||
|
||||
|
||||
diff -Naur mysql-5.0.33.orig/sql-common/client.c mysql-5.0.33/sql-common/client.c
|
||||
--- mysql-5.0.33.orig/sql-common/client.c 2007-01-09 07:51:07.000000000 -0500
|
||||
+++ mysql-5.0.33/sql-common/client.c 2007-02-09 12:36:17.000000000 -0500
|
||||
@@ -3017,7 +3017,7 @@
|
||||
mysql->reconnect= *(my_bool *) arg;
|
||||
break;
|
||||
case MYSQL_OPT_SSL_VERIFY_SERVER_CERT:
|
||||
- if (!arg || test(*(uint*) arg))
|
||||
+ if (!arg || test(*(my_bool*) arg))
|
||||
mysql->options.client_flag|= CLIENT_SSL_VERIFY_SERVER_CERT;
|
||||
else
|
||||
mysql->options.client_flag&= ~CLIENT_SSL_VERIFY_SERVER_CERT;
|
@ -4,14 +4,14 @@ pre-5.0.33 value to have some margin for future changes in compiler, glibc,
|
||||
etc. Suspect this number if "execution_constants" regression test fails.
|
||||
|
||||
|
||||
diff -Naur mysql-5.0.33.orig/sql/mysql_priv.h mysql-5.0.33/sql/mysql_priv.h
|
||||
--- mysql-5.0.33.orig/sql/mysql_priv.h 2007-01-09 07:51:48.000000000 -0500
|
||||
+++ mysql-5.0.33/sql/mysql_priv.h 2007-02-09 19:06:51.000000000 -0500
|
||||
@@ -154,7 +154,7 @@
|
||||
diff -Naur mysql-5.0.38.orig/sql/mysql_priv.h mysql-5.0.38/sql/mysql_priv.h
|
||||
--- mysql-5.0.38.orig/sql/mysql_priv.h 2007-03-20 15:12:46.000000000 -0400
|
||||
+++ mysql-5.0.38/sql/mysql_priv.h 2007-04-16 16:09:39.000000000 -0400
|
||||
@@ -175,7 +175,7 @@
|
||||
Feel free to raise this by the smallest amount you can to get the
|
||||
"execution_constants" test to pass.
|
||||
*/
|
||||
-#define STACK_MIN_SIZE 10788 // Abort if less stack during eval.
|
||||
-#define STACK_MIN_SIZE 12000 // Abort if less stack during eval.
|
||||
+#define STACK_MIN_SIZE 16384 // Abort if less stack during eval.
|
||||
|
||||
#define STACK_MIN_SIZE_FOR_OPEN 1024*80
|
||||
|
@ -5,41 +5,72 @@ Also, tweak the Perl test script so that the mysqld daemon gets detached
|
||||
from the calling terminal session. Without this, the ssl_des test hangs up
|
||||
because OpenSSL tries to read a PEM key from /dev/tty.
|
||||
|
||||
Also, tweak the Perl test script to find some files where we install them;
|
||||
without this, the build-time test works but the mysql-test RPM doesn't.
|
||||
|
||||
diff -Naur mysql-5.0.37.orig/Makefile.am mysql-5.0.37/Makefile.am
|
||||
--- mysql-5.0.37.orig/Makefile.am 2007-03-05 14:21:11.000000000 -0500
|
||||
+++ mysql-5.0.37/Makefile.am 2007-03-12 11:19:05.000000000 -0400
|
||||
@@ -124,11 +124,11 @@
|
||||
|
||||
diff -Naur mysql-5.0.40.orig/Makefile.am mysql-5.0.40/Makefile.am
|
||||
--- mysql-5.0.40.orig/Makefile.am 2007-04-20 10:14:34.000000000 -0400
|
||||
+++ mysql-5.0.40/Makefile.am 2007-05-23 12:59:49.000000000 -0400
|
||||
@@ -126,11 +126,11 @@
|
||||
|
||||
test-ps:
|
||||
cd mysql-test ; \
|
||||
- @PERL@ ./mysql-test-run.pl $(force) --ps-protocol
|
||||
+ @PERL@ ./mysql-test-run.pl $(force) --ssl --ps-protocol
|
||||
- @PERL@ ./mysql-test-run.pl $(force) $(mem) --ps-protocol
|
||||
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ssl --ps-protocol
|
||||
|
||||
test-ns:
|
||||
cd mysql-test ; \
|
||||
- @PERL@ ./mysql-test-run.pl $(force)
|
||||
+ @PERL@ ./mysql-test-run.pl $(force) --ssl
|
||||
- @PERL@ ./mysql-test-run.pl $(force) $(mem)
|
||||
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ssl
|
||||
|
||||
test: test-ns test-ps
|
||||
|
||||
diff -Naur mysql-5.0.37.orig/mysql-test/lib/mtr_process.pl mysql-5.0.37/mysql-test/lib/mtr_process.pl
|
||||
--- mysql-5.0.37.orig/mysql-test/lib/mtr_process.pl 2007-03-05 14:40:33.000000000 -0500
|
||||
+++ mysql-5.0.37/mysql-test/lib/mtr_process.pl 2007-03-12 11:17:52.000000000 -0400
|
||||
@@ -161,6 +161,9 @@
|
||||
# became a deamon as well, and was hard to kill ;-)
|
||||
# Need to catch SIGCHLD and do waitpid or something instead......
|
||||
diff -Naur mysql-5.0.40.orig/mysql-test/lib/mtr_process.pl mysql-5.0.40/mysql-test/lib/mtr_process.pl
|
||||
--- mysql-5.0.40.orig/mysql-test/lib/mtr_process.pl 2007-04-20 10:39:41.000000000 -0400
|
||||
+++ mysql-5.0.40/mysql-test/lib/mtr_process.pl 2007-05-23 12:59:49.000000000 -0400
|
||||
@@ -148,6 +148,9 @@
|
||||
{
|
||||
# Child, redirect output and exec
|
||||
|
||||
+ # dunno, it works for me ...
|
||||
+ # Needed to become detached from terminal session
|
||||
+ POSIX::setsid();
|
||||
+
|
||||
$SIG{INT}= 'DEFAULT'; # Parent do some stuff, we don't
|
||||
|
||||
my $log_file_open_mode = '>';
|
||||
diff -Naur mysql-5.0.37.orig/mysql-test/mysql-test-run.pl mysql-5.0.37/mysql-test/mysql-test-run.pl
|
||||
--- mysql-5.0.37.orig/mysql-test/mysql-test-run.pl 2007-03-05 14:21:11.000000000 -0500
|
||||
+++ mysql-5.0.37/mysql-test/mysql-test-run.pl 2007-03-12 11:17:52.000000000 -0400
|
||||
@@ -3906,7 +3906,7 @@
|
||||
diff -Naur mysql-5.0.40.orig/mysql-test/mysql-test-run.pl mysql-5.0.40/mysql-test/mysql-test-run.pl
|
||||
--- mysql-5.0.40.orig/mysql-test/mysql-test-run.pl 2007-04-20 10:14:30.000000000 -0400
|
||||
+++ mysql-5.0.40/mysql-test/mysql-test-run.pl 2007-05-23 13:02:12.000000000 -0400
|
||||
@@ -1465,13 +1465,15 @@
|
||||
|
||||
$exe_ndbd=
|
||||
mtr_exe_maybe_exists("$ndb_path/src/kernel/ndbd",
|
||||
- "$ndb_path/ndbd");
|
||||
+ "$ndb_path/ndbd",
|
||||
+ "/usr/libexec/ndbd");
|
||||
$exe_ndb_mgm=
|
||||
mtr_exe_maybe_exists("$ndb_path/src/mgmclient/ndb_mgm",
|
||||
"$ndb_path/ndb_mgm");
|
||||
$exe_ndb_mgmd=
|
||||
mtr_exe_maybe_exists("$ndb_path/src/mgmsrv/ndb_mgmd",
|
||||
- "$ndb_path/ndb_mgmd");
|
||||
+ "$ndb_path/ndb_mgmd",
|
||||
+ "/usr/libexec/ndb_mgmd");
|
||||
$exe_ndb_waiter=
|
||||
mtr_exe_maybe_exists("$ndb_path/tools/ndb_waiter",
|
||||
"$ndb_path/ndb_waiter");
|
||||
@@ -1572,7 +1574,8 @@
|
||||
# Look for mysql_fix_privilege_tables.sql script
|
||||
$file_mysql_fix_privilege_tables=
|
||||
mtr_file_exists("$glob_basedir/scripts/mysql_fix_privilege_tables.sql",
|
||||
- "$glob_basedir/share/mysql_fix_privilege_tables.sql");
|
||||
+ "$glob_basedir/share/mysql_fix_privilege_tables.sql",
|
||||
+ "$path_share/mysql_fix_privilege_tables.sql");
|
||||
|
||||
if ( ! $opt_skip_ndbcluster and executable_setup_ndb()) {
|
||||
mtr_warning("Could not find all required ndb binaries, " .
|
||||
@@ -3999,7 +4002,7 @@
|
||||
|
||||
if ( defined $exe )
|
||||
{
|
||||
|
87
mysql.spec
87
mysql.spec
@ -1,6 +1,6 @@
|
||||
Name: mysql
|
||||
Version: 5.0.37
|
||||
Release: 2%{?dist}
|
||||
Version: 5.0.45
|
||||
Release: 1%{?dist}
|
||||
Summary: MySQL client programs and shared libraries
|
||||
License: GPL
|
||||
Group: Applications/Databases
|
||||
@ -25,8 +25,6 @@ Patch6: mysql-rpl_ddl.patch
|
||||
Patch7: mysql-rpl-test.patch
|
||||
Patch8: mysql-install-test.patch
|
||||
Patch9: mysql-bdb-link.patch
|
||||
Patch10: mysql-ssl-bugs.patch
|
||||
Patch11: mysql-info-schema.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
BuildRequires: gperf, perl, readline-devel, openssl-devel
|
||||
@ -115,6 +113,7 @@ License: GPL
|
||||
Group: Applications/Databases
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: %{name}-server = %{version}-%{release}
|
||||
Conflicts: MySQL-test
|
||||
|
||||
%description test
|
||||
MySQL is a multi-user, multi-threaded SQL database server. This
|
||||
@ -133,8 +132,6 @@ the MySQL sources.
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
|
||||
libtoolize --force
|
||||
aclocal
|
||||
@ -152,10 +149,6 @@ CFLAGS="$CFLAGS -fno-strict-aliasing -fwrapv"
|
||||
# -ECL 2002-12-19
|
||||
CFLAGS="$CFLAGS -fPIC"
|
||||
%endif
|
||||
# Temporary workaround for gcc bug (bz #193912)
|
||||
%ifarch s390x
|
||||
CFLAGS="$CFLAGS -mtune=z900"
|
||||
%endif
|
||||
CXXFLAGS="$CFLAGS -fno-rtti -fno-exceptions"
|
||||
export CFLAGS CXXFLAGS
|
||||
|
||||
@ -238,16 +231,17 @@ mv ${RPM_BUILD_ROOT}%{_bindir}/mysql_config ${RPM_BUILD_ROOT}%{_libdir}/mysql/my
|
||||
install -m 0755 scriptstub ${RPM_BUILD_ROOT}%{_bindir}/mysql_config
|
||||
|
||||
rm -f ${RPM_BUILD_ROOT}%{_bindir}/comp_err
|
||||
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/comp_err.1*
|
||||
rm -f ${RPM_BUILD_ROOT}%{_bindir}/make_win_binary_distribution
|
||||
rm -f ${RPM_BUILD_ROOT}%{_bindir}/make_win_src_distribution
|
||||
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/make_win_bin_dist.1*
|
||||
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/make_win_src_distribution.1*
|
||||
rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/libmysqlclient*.la
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/binary-configure
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/make_binary_distribution
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/make_sharedlib_distribution
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mi_test_all*
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/*.cnf
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/*.ini
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/ndb-config-2-node.ini
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mysql.server
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/MySQL-shared-compat.spec
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/*.plist
|
||||
@ -255,6 +249,8 @@ rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/preinstall
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/postinstall
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mysql-*.spec
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/mysql-log-rotate
|
||||
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/mysql-stress-test.pl.1*
|
||||
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/mysql-test-run.pl.1*
|
||||
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/ndbd.1*
|
||||
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/ndb_*.1*
|
||||
|
||||
@ -301,9 +297,6 @@ fi
|
||||
if [ $1 -ge 1 ]; then
|
||||
/sbin/service mysqld condrestart >/dev/null 2>&1 || :
|
||||
fi
|
||||
if [ $1 = 0 ] ; then
|
||||
userdel mysql >/dev/null 2>&1 || :
|
||||
fi
|
||||
|
||||
|
||||
%files
|
||||
@ -323,14 +316,20 @@ fi
|
||||
%{_bindir}/mysqldump
|
||||
%{_bindir}/mysqlimport
|
||||
%{_bindir}/mysqlshow
|
||||
%{_bindir}/my_print_defaults
|
||||
|
||||
%{_infodir}/*
|
||||
|
||||
%{_mandir}/man1/mysql.1*
|
||||
%{_mandir}/man1/mysql_config.1*
|
||||
%{_mandir}/man1/mysql_find_rows.1*
|
||||
%{_mandir}/man1/mysql_tableinfo.1*
|
||||
%{_mandir}/man1/mysql_waitpid.1*
|
||||
%{_mandir}/man1/mysqlaccess.1*
|
||||
%{_mandir}/man1/mysqladmin.1*
|
||||
%{_mandir}/man1/mysqldump.1*
|
||||
%{_mandir}/man1/mysqlshow.1*
|
||||
%{_mandir}/man1/my_print_defaults.1*
|
||||
|
||||
%{_libdir}/mysql/mysqlbug
|
||||
%{_libdir}/mysql/mysql_config
|
||||
@ -376,13 +375,11 @@ fi
|
||||
%defattr(-,root,root)
|
||||
%doc support-files/*.cnf
|
||||
|
||||
%{_bindir}/my_print_defaults
|
||||
%{_bindir}/myisamchk
|
||||
%{_bindir}/myisam_ftdump
|
||||
%{_bindir}/myisamlog
|
||||
%{_bindir}/myisampack
|
||||
%{_bindir}/mysql_convert_table_format
|
||||
%{_bindir}/mysql_create_system_tables
|
||||
%{_bindir}/mysql_explain_log
|
||||
%{_bindir}/mysql_fix_extensions
|
||||
%{_bindir}/mysql_fix_privilege_tables
|
||||
@ -408,38 +405,51 @@ fi
|
||||
%{_bindir}/resolve_stack_dump
|
||||
%{_bindir}/resolveip
|
||||
|
||||
/usr/libexec/*
|
||||
/usr/libexec/mysqld
|
||||
/usr/libexec/mysqlmanager
|
||||
|
||||
%{_mandir}/man1/msql2mysql.1.gz
|
||||
%{_mandir}/man1/myisamchk.1.gz
|
||||
%{_mandir}/man1/myisamlog.1.gz
|
||||
%{_mandir}/man1/myisampack.1.gz
|
||||
%{_mandir}/man1/myisam_ftdump.1.gz
|
||||
%{_mandir}/man1/mysql.server.1.gz
|
||||
%{_mandir}/man1/mysql_config.1.gz
|
||||
%{_mandir}/man1/mysql_explain_log.1.gz
|
||||
%{_mandir}/man1/msql2mysql.1*
|
||||
%{_mandir}/man1/myisamchk.1*
|
||||
%{_mandir}/man1/myisamlog.1*
|
||||
%{_mandir}/man1/myisampack.1*
|
||||
%{_mandir}/man1/mysql_convert_table_format.1*
|
||||
%{_mandir}/man1/myisam_ftdump.1*
|
||||
%{_mandir}/man1/mysql.server.1*
|
||||
%{_mandir}/man1/mysql_explain_log.1*
|
||||
%{_mandir}/man1/mysql_fix_extensions.1*
|
||||
%{_mandir}/man1/mysql_fix_privilege_tables.1*
|
||||
%{_mandir}/man1/mysql_install_db.1*
|
||||
%{_mandir}/man1/mysql_secure_installation.1*
|
||||
%{_mandir}/man1/mysql_upgrade.1*
|
||||
%{_mandir}/man1/mysql_zap.1*
|
||||
%{_mandir}/man1/mysqlbinlog.1.gz
|
||||
%{_mandir}/man1/mysqlcheck.1.gz
|
||||
%{_mandir}/man1/mysqlbinlog.1*
|
||||
%{_mandir}/man1/mysqlcheck.1*
|
||||
%{_mandir}/man1/mysqld_multi.1*
|
||||
%{_mandir}/man1/mysqld_safe.1*
|
||||
%{_mandir}/man1/mysqlhotcopy.1.gz
|
||||
%{_mandir}/man1/mysqlimport.1.gz
|
||||
%{_mandir}/man1/mysqlman.1.gz
|
||||
%{_mandir}/man1/mysqlhotcopy.1*
|
||||
%{_mandir}/man1/mysqlimport.1*
|
||||
%{_mandir}/man1/mysqlman.1*
|
||||
%{_mandir}/man1/mysql_setpermission.1*
|
||||
%{_mandir}/man1/mysqltest.1*
|
||||
%{_mandir}/man1/innochecksum.1*
|
||||
%{_mandir}/man1/perror.1*
|
||||
%{_mandir}/man1/replace.1*
|
||||
%{_mandir}/man1/resolve_stack_dump.1*
|
||||
%{_mandir}/man1/resolveip.1*
|
||||
%{_mandir}/man1/safe_mysqld.1*
|
||||
%{_mandir}/man1/my_print_defaults.1*
|
||||
%{_mandir}/man1/mysql_tzinfo_to_sql.1*
|
||||
%{_mandir}/man1/mysql_install_db.1*
|
||||
%{_mandir}/man1/mysqlmanager-pwgen.1*
|
||||
%{_mandir}/man1/mysqlmanagerc.1*
|
||||
%{_mandir}/man8/mysqld.8*
|
||||
%{_mandir}/man8/mysqlmanager.8*
|
||||
|
||||
%{_datadir}/mysql/errmsg.txt
|
||||
%{_datadir}/mysql/fill_help_tables.sql
|
||||
%{_datadir}/mysql/mysql_fix_privilege_tables.sql
|
||||
%{_datadir}/mysql/mysql_system_tables.sql
|
||||
%{_datadir}/mysql/mysql_system_tables_data.sql
|
||||
%{_datadir}/mysql/mysql_test_data_timezone.sql
|
||||
%{_datadir}/mysql/my-*.cnf
|
||||
/etc/rc.d/init.d/mysqld
|
||||
%attr(0755,mysql,mysql) %dir /var/run/mysqld
|
||||
%attr(0755,mysql,mysql) %dir /var/lib/mysql
|
||||
@ -460,7 +470,18 @@ fi
|
||||
%{_bindir}/mysql_client_test
|
||||
%attr(-,mysql,mysql) %{_datadir}/mysql-test
|
||||
|
||||
%{_mandir}/man1/mysql_client_test.1*
|
||||
|
||||
%changelog
|
||||
* Sun Jul 22 2007 Tom Lane <tgl@redhat.com> 5.0.45-1
|
||||
- Update to MySQL 5.0.45
|
||||
Resolves: #246535
|
||||
- Move mysql_config's man page to base package
|
||||
Resolves: #245770
|
||||
- move my_print_defaults to base RPM, for consistency with Stacks packaging
|
||||
- mysql user is no longer deleted at RPM uninstall
|
||||
Resolves: #241912
|
||||
|
||||
* Thu Mar 29 2007 Tom Lane <tgl@redhat.com> 5.0.37-2
|
||||
- Use a less hacky method of getting default values in initscript
|
||||
Related: #233771, #194596
|
||||
|
Loading…
Reference in New Issue
Block a user