Update to MySQL 4.1.12. Get the openssl regression tests to pass.

This commit is contained in:
Tom Lane 2005-07-12 02:22:11 +00:00 committed by Michal Schorm
parent b6945290bc
commit 229de3d260
4 changed files with 21 additions and 32 deletions

View File

@ -1 +1 @@
mysql-4.1.11.tar.gz
mysql-4.1.12.tar.gz

View File

@ -3,17 +3,14 @@ out of shape, so don't do it. Suppressing this has another benefit too,
which is we avoid the 4-vs-8-byte problem in BDB that formerly required
mysql-threads.patch.
If you're wondering about the hack on Docs/Makefile.am, it's to prevent
it from deciding we need to rebuild the docs after patching configure.in.
diff -Naur mysql-4.1.11.orig/configure.in mysql-4.1.11/configure.in
--- mysql-4.1.11.orig/configure.in 2005-04-01 06:36:51.000000000 -0500
+++ mysql-4.1.11/configure.in 2005-04-08 16:16:18.000000000 -0400
@@ -842,43 +842,6 @@
diff -Naur mysql-4.1.12.orig/configure.in mysql-4.1.12/configure.in
--- mysql-4.1.12.orig/configure.in 2005-05-13 07:32:33.000000000 -0400
+++ mysql-4.1.12/configure.in 2005-07-11 12:16:28.000000000 -0400
@@ -862,43 +862,6 @@
AC_SUBST(WRAPLIBS)
if test "$IS_LINUX" = "true"; then
if test "$TARGET_LINUX" = "true"; then
- AC_MSG_CHECKING([for atomic operations])
-
- atom_ops=
@ -54,15 +51,3 @@ diff -Naur mysql-4.1.11.orig/configure.in mysql-4.1.11/configure.in
AC_ARG_WITH(pstack,
[ --with-pstack Use the pstack backtrace library],
[ USE_PSTACK=$withval ],
diff -Naur mysql-4.1.11.orig/Docs/Makefile.am mysql-4.1.11/Docs/Makefile.am
--- mysql-4.1.11.orig/Docs/Makefile.am 2005-04-01 06:36:45.000000000 -0500
+++ mysql-4.1.11/Docs/Makefile.am 2005-04-08 16:47:02.865502712 -0400
@@ -41,7 +41,7 @@
#########################################################################
# The Makefile contains the previous version so we can not use that
-include.texi: ../configure.in
+include.texi:
echo "@c This file is autogenerated by the Makefile" > $@
echo -n "@set mysqlversion " >> $@
grep "AM_INIT_AUTOMAKE(mysql, " ../configure.in | \

View File

@ -1,6 +1,6 @@
Name: mysql
Version: 4.1.11
Release: 4
Version: 4.1.12
Release: 1
Source0: http://dev.mysql.com/get/Downloads/MySQL-4.1/mysql-%{version}.tar.gz
Source1: mysql.init
Source2: mysql.logrotate
@ -64,6 +64,7 @@ Summary: Files for development of MySQL applications.
License: GPL
Group: Applications/Databases
Requires: %{name} = %{version}-%{release}
Requires: openssl-devel
Conflicts: MySQL-devel
%description devel
@ -119,16 +120,16 @@ export CFLAGS CXXFLAGS
--with-openssl \
--without-debug \
--enable-shared \
--with-extra-charsets=complex \
--with-bench \
--localstatedir=/var/lib/mysql \
--with-unix-socket-path=/var/lib/mysql/mysql.sock \
--with-mysqld-user="mysql" \
--with-extra-charsets=all \
--with-innodb \
--with-isam \
--with-berkeley-db \
--enable-local-infile \
--enable-large-files=yes --enable-largefile=yes \
--with-berkeley-db \
--enable-thread-safe-client \
--disable-dependency-tracking \
--with-named-thread-libs="-lpthread"
@ -169,8 +170,6 @@ install -m 0755 scriptstub ${RPM_BUILD_ROOT}%{_bindir}/mysqlbug
mv ${RPM_BUILD_ROOT}%{_bindir}/mysql_config ${RPM_BUILD_ROOT}%{_libdir}/mysql/mysql_config
install -m 0755 scriptstub ${RPM_BUILD_ROOT}%{_bindir}/mysql_config
# Doesn't contain anything
rm -f Docs/manual.ps
rm -fr $RPM_BUILD_ROOT/usr/mysql-test
rm -f ${RPM_BUILD_ROOT}%{_bindir}/*client_test
rm -f ${RPM_BUILD_ROOT}%{_bindir}/comp_err
@ -189,9 +188,6 @@ rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/*.plist
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/preinstall
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/postinstall
# compress manual
bzip2 Docs/manual.txt
mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
echo "%{_libdir}/mysql" > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{name}-%{_arch}.conf
@ -241,7 +237,6 @@ fi
%files
%defattr(-,root,root)
%doc README COPYING
%doc Docs/manual.txt.bz2 Docs/mysqld_error.txt
%{_bindir}/msql2mysql
%{_bindir}/mysql
@ -368,6 +363,15 @@ fi
%{_datadir}/sql-bench
%changelog
* Mon Jul 11 2005 Tom Lane <tgl@redhat.com> 4.1.12-1
- Update to MySQL 4.1.12 (includes a fix for bz#158688, bz#158689)
- Extend mysql-test-ssl.patch to solve rpl_openssl test failure (bz#155850)
- Update mysql-lock-ssl.patch to match the upstream committed version
- Add --with-isam to re-enable the old ISAM table type, per bz#159262
- Add dependency on openssl-devel per bz#159569
- Remove manual.txt, as upstream decided not to ship it anymore;
it was redundant with the mysql.info file anyway.
* Mon May 9 2005 Tom Lane <tgl@redhat.com> 4.1.11-4
- Include proper locking for OpenSSL in the server, per bz#155850

View File

@ -1 +1 @@
0b99001b07cad53f161ec629a6bb24ea mysql-4.1.11.tar.gz
56a6f5cacd97ae290e07bbe19f279af1 mysql-4.1.12.tar.gz