ffd96fa910
ICU patch removed; upstreamed Patch for MySQL Router introduced. Do not build it. CVEs fixed: CVE-2018-3276 CVE-2018-3200 CVE-2018-3137 CVE-2018-3284 CVE-2018-3195 CVE-2018-3173 CVE-2018-3212 CVE-2018-3279 CVE-2018-3162 CVE-2018-3247 CVE-2018-3156 CVE-2018-3161 CVE-2018-3278 CVE-2018-3174 CVE-2018-3282 CVE-2018-3285 CVE-2018-3187 CVE-2018-3277 CVE-2018-3144 CVE-2018-3145 CVE-2018-3170 CVE-2018-3186 CVE-2018-3182 CVE-2018-3133 CVE-2018-3143 CVE-2018-3283 CVE-2018-3171 CVE-2018-3251 CVE-2018-3286 CVE-2018-3185 CVE-2018-3280 CVE-2018-3203 CVE-2018-3155
34 lines
1.4 KiB
Diff
34 lines
1.4 KiB
Diff
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
|
|
index 7c1e82b5..a92ba915 100644
|
|
--- a/mysql-test/CMakeLists.txt
|
|
+++ b/mysql-test/CMakeLists.txt
|
|
@@ -56,6 +56,10 @@ INSTALL(
|
|
ENDIF()
|
|
|
|
|
|
+# Expand some paths in the perl scripts correctly
|
|
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/lib/My/ConfigFactory.pm ${CMAKE_CURRENT_SOURCE_DIR}/lib/My/ConfigFactory.pm @ONLY)
|
|
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/mysql-test-run.pl ${CMAKE_CURRENT_SOURCE_DIR}/mysql-test-run.pl @ONLY)
|
|
+
|
|
IF(NOT ${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_BINARY_DIR})
|
|
# Enable running mtr from build directory
|
|
CONFIGURE_FILE(
|
|
diff --git a/mysql-test/mysql-test-run.pl b/mysql-test/mysql-test-run.pl
|
|
index 8c058527..7acd8534 100755
|
|
--- a/mysql-test/mysql-test-run.pl
|
|
+++ b/mysql-test/mysql-test-run.pl
|
|
@@ -1479,11 +1479,11 @@ sub command_line_setup {
|
|
}
|
|
|
|
# Look for language files and charsetsdir, use same share
|
|
- $path_language = mtr_path_exists("$bindir/share/mysql", "$bindir/share");
|
|
+ $path_language = mtr_path_exists("$bindir/@INSTALL_MYSQLSHAREDIR@", "$bindir/share/mysql", "$bindir/share");
|
|
my $path_share = $path_language;
|
|
|
|
@share_locations =
|
|
- ("share/mysql-" . $mysql_base_version, "share/mysql", "share");
|
|
+ ("@INSTALL_MYSQLSHAREDIR@", "share/mysql-" . $mysql_base_version, "share/mysql", "share");
|
|
|
|
$path_charsetsdir = my_find_dir($basedir, \@share_locations, "charsets");
|
|
|