23 lines
792 B
Diff
23 lines
792 B
Diff
Do not build MySQL Router.
|
||
It is a set of tools and libraries used for the InnoDB cluster.
|
||
|
||
However without MySQL Shell it can't be operated.
|
||
We don't pack the MySQL Shell, so don´t build the router at all.
|
||
|
||
|
||
|
||
I have this confirmed from the mail conversation with the MySQL side:
|
||
"While technically possible, it's practically impossible to set up router without the MySQL Shell."
|
||
|
||
--- mysql-8.0.13/CMakeLists.txt 2018-10-07 10:44:22.000000000 +0200
|
||
+++ mysql-8.0.13/CMakeLists.txt_patched 2018-10-23 03:10:01.490792624 +0200
|
||
@@ -1046,7 +1046,7 @@ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/sql/s
|
||
|
||
# depends on mysql_version.h to exist
|
||
IF(NOT WITHOUT_SERVER)
|
||
- ADD_SUBDIRECTORY(router)
|
||
+# ADD_SUBDIRECTORY(router)
|
||
ENDIF()
|
||
|
||
GET_PROPERTY(CWD_DEFINITIONS DIRECTORY PROPERTY COMPILE_DEFINITIONS)
|