Rebase to version 8.0.41
Resolves: RHEL-76065 RHEL-63022 RHEL-40866
This commit is contained in:
parent
bd8427cbf6
commit
e90a81ec09
@ -1,7 +1,7 @@
|
||||
Index: boost/pool/pool.hpp
|
||||
===================================================================
|
||||
--- boost/pool/pool.hpp (revision 78317)
|
||||
+++ boost/pool/pool.hpp (revision 78326)
|
||||
--- a/boost/pool/pool.hpp (revision 78317)
|
||||
+++ b/boost/pool/pool.hpp (revision 78326)
|
||||
@@ -27,4 +27,6 @@
|
||||
#include <boost/pool/poolfwd.hpp>
|
||||
|
||||
@ -88,8 +88,8 @@ Index: boost/pool/pool.hpp
|
||||
// insert it into the list,
|
||||
Index: libs/pool/test/test_bug_6701.cpp
|
||||
===================================================================
|
||||
--- libs/pool/test/test_bug_6701.cpp (revision 78326)
|
||||
+++ libs/pool/test/test_bug_6701.cpp (revision 78326)
|
||||
--- a/libs/pool/test/test_bug_6701.cpp (revision 78326)
|
||||
+++ b/libs/pool/test/test_bug_6701.cpp (revision 78326)
|
||||
@@ -0,0 +1,27 @@
|
||||
+/* Copyright (C) 2012 Étienne Dupuis
|
||||
+*
|
||||
|
@ -10,8 +10,8 @@ Subject: [PATCH] Update gcc Intel intrinsic usage config. Fixes
|
||||
|
||||
diff --git a/include/boost/multiprecision/cpp_int/intel_intrinsics.hpp b/include/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
||||
index eb4624bb4..37717cd51 100644
|
||||
--- a/include/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
||||
+++ b/include/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
||||
--- a/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
||||
+++ b/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
||||
@@ -19,7 +19,11 @@
|
||||
// If this is GCC/clang, then check that the actual intrinsic exists:
|
||||
//
|
||||
|
@ -1,7 +1,7 @@
|
||||
Avoid errors like:
|
||||
|
||||
| Path length (109) is longer than maximum supported length (108) and will be truncated at /usr/lib64/perl5/vendor_perl/Socket.pm line 880, <GEN16094> line 1.
|
||||
| worker[2] mysql-test-run: *** ERROR: Socket path '/builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.s390x/usr/share/mysql-test/var/tmp/2' too long,
|
||||
| worker[2] mysql-test-run: *** ERROR: Socket path '/builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.s390x/usr/share/mysql-test/var/tmp/2' too long,
|
||||
| it would be truncated and thus not possible to use for connection to MySQL Server. Set a shorter with --tmpdir=<path> option
|
||||
|
||||
===
|
||||
@ -26,7 +26,7 @@ The question is why haven't I encountered this issue until recently ?
|
||||
After the recent tweaks to the testsuite (between 8.0.24 and 8.0.25 release), the generated --tmpdir path changed from
|
||||
| --tmpdir=/builddir/build/BUILD/mysql-8.0.24/x86_64-redhat-linux-gnu/mysql-test/var/tmp/
|
||||
to
|
||||
| --tmpdir=/builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/tmp/
|
||||
| --tmpdir=/builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/tmp/
|
||||
|
||||
===
|
||||
|
||||
@ -39,7 +39,7 @@ BEFORE:
|
||||
AFTER:
|
||||
|
||||
| Installing system database
|
||||
| ### safe_path: /builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/bin//mysqltest_safe_process --verbose -- /builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/libexec/mysqld --no-defaults --initialize-insecure --loose-skip-ndbcluster --tmpdir=/builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/tmp/ --core-file --datadir=/builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/data/ --secure-file-priv=/builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var --innodb_buffer_pool_size=24M --innodb-log-file-size=5M --innodb_autoextend_increment=8 --character-sets-dir=/builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/community-mysql/charsets --loose-auto_generate_certs=OFF --loose-sha256_password_auto_generate_rsa_keys=OFF --loose-caching_sha2_password_auto_generate_rsa_keys=OFF --init-file=/builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/tmp/bootstrap.sql
|
||||
| ### safe_path: /builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/bin//mysqltest_safe_process --verbose -- /builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/libexec/mysqld --no-defaults --initialize-insecure --loose-skip-ndbcluster --tmpdir=/builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/tmp/ --core-file --datadir=/builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/data/ --secure-file-priv=/builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var --innodb_buffer_pool_size=24M --innodb-log-file-size=5M --innodb_autoextend_increment=8 --character-sets-dir=/builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql/charsets --loose-auto_generate_certs=OFF --loose-sha256_password_auto_generate_rsa_keys=OFF --loose-caching_sha2_password_auto_generate_rsa_keys=OFF --init-file=/builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/tmp/bootstrap.sql
|
||||
|
||||
===
|
||||
|
||||
@ -59,21 +59,21 @@ Even though the script warns about the path length, tries to workaround it; it d
|
||||
|
||||
I'm not sure whether the output is synchronous, but even if it wasn'tit still looks weird.
|
||||
|
||||
| + cd /builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test
|
||||
| + cd /builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test
|
||||
| Logging: ./mysql-test-run.pl --verbose --parallel=auto --force --retry=2 --suite-timeout=900 --testcase-timeout=30 --mysqld=--binlog-format=mixed --max-test-fail=5 --report-unstable-tests --clean-vardir --suite=main --mem --skip-test-list=platform-specific-tests.list
|
||||
| Path length (109) is longer than maximum supported length (108) and will be truncated at /usr/lib64/perl5/vendor_perl/Socket.pm line 880.
|
||||
| Too long tmpdir path '/builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/tmp' creating a shorter one
|
||||
| Too long tmpdir path '/builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/tmp' creating a shorter one
|
||||
| - Using tmpdir: '/tmp/XfTFAis2Jl'
|
||||
| > Collecting: main
|
||||
| > testdir: /builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/t
|
||||
| > resdir: /builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/r
|
||||
| > testdir: /builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/t
|
||||
| > resdir: /builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/r
|
||||
| > Collecting: i_main
|
||||
| Removing old var directory
|
||||
| > opt_vardir: /builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var
|
||||
| > Removing /builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/
|
||||
| > opt_vardir: /builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var
|
||||
| > Removing /builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var/
|
||||
| > Removing /dev/shm/var_933_jfTb
|
||||
| > Removing /tmp/XfTFAis2Jl/
|
||||
| Creating var directory '/builddir/build/BUILDROOT/community-mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var'
|
||||
| Creating var directory '/builddir/build/BUILDROOT/mysql-8.0.24-1.fc35.x86_64/usr/share/mysql-test/var'
|
||||
| > Creating /dev/shm/var_933_jfTb
|
||||
| - symlinking 'var' to '/dev/shm/var_933_jfTb'
|
||||
|
||||
@ -82,9 +82,9 @@ I'm not sure whether the output is synchronous, but even if it wasn'tit still lo
|
||||
|
||||
diff --git a/mysql-test/mysql-test-run.pl b/mysql-test/mysql-test-run.pl
|
||||
index 26e6c92c..9d85c6d6 100755
|
||||
--- a/mysql-test/mysql-test-run.pl
|
||||
+++ b/mysql-test/mysql-test-run.pl
|
||||
@@ -3533,17 +3533,6 @@ sub setup_vardir() {
|
||||
--- mysql-8.0.39/mysql-test/mysql-test-run.pl 2024-08-11 01:20:12.207260860 +0200
|
||||
+++ mysql-8.0.39/mysql-test/mysql-test-run.pl_patched 2024-08-11 20:44:42.230145160 +0200
|
||||
@@ -3560,17 +3560,6 @@ sub setup_vardir() {
|
||||
mkpath("$opt_vardir/tmp");
|
||||
mkpath($opt_tmpdir) if ($opt_tmpdir ne "$opt_vardir/tmp");
|
||||
|
||||
@ -92,7 +92,7 @@ index 26e6c92c..9d85c6d6 100755
|
||||
- # UNIX domain socket's path far below PATH_MAX. Don't allow that
|
||||
- # to happen.
|
||||
- my $res =
|
||||
- check_socket_path_length("$opt_tmpdir/mysqld.NN.sock", $opt_parallel);
|
||||
- check_socket_path_length("$opt_tmpdir/mysqld.NN.sock", $opt_parallel, $tmpdir_path_updated);
|
||||
- if ($res) {
|
||||
- mtr_error("Socket path '$opt_tmpdir' too long, it would be ",
|
||||
- "truncated and thus not possible to use for connection to ",
|
||||
|
15
mysql.spec
15
mysql.spec
@ -19,7 +19,7 @@ ExcludeArch: %{ix86}
|
||||
# The last version on which the full testsuite has been run
|
||||
# In case of further rebuilds of that version, don't require full testsuite to be run
|
||||
# run only "main" suite
|
||||
%global last_tested_version 8.0.36
|
||||
%global last_tested_version 8.0.41
|
||||
# Set to 1 to force run the testsuite even if it was already tested in current version
|
||||
%global force_run_testsuite 0
|
||||
|
||||
@ -67,7 +67,7 @@ ExcludeArch: %{ix86}
|
||||
%else
|
||||
%bcond_without bundled_protobuf
|
||||
%endif
|
||||
%global protobuf_bundled_version 3.19.4
|
||||
%global protobuf_bundled_version 24.4
|
||||
|
||||
# Mysql 8.0.21 needs libevent version >2.1 and rhel-7 provides 2.0
|
||||
# Also since Mysql 8.0.18, libzstd is required, but it's not in rhel until version 8
|
||||
@ -88,7 +88,7 @@ ExcludeArch: %{ix86}
|
||||
%endif
|
||||
%global zstd_bundled_version 1.5.5
|
||||
%global libevent_bundled_version 2.1.11
|
||||
%global fido2_bundled_version 1.13.0
|
||||
%global fido2_bundled_version 1.15.0
|
||||
|
||||
# Include files for SysV init or systemd
|
||||
%if 0%{?fedora} >= 15 || 0%{?rhel} >= 7
|
||||
@ -147,7 +147,7 @@ ExcludeArch: %{ix86}
|
||||
%endif
|
||||
|
||||
Name: %{?scl_prefix}mysql
|
||||
Version: 8.0.36
|
||||
Version: 8.0.41
|
||||
Release: 1%{?with_debug:.debug}%{?dist}
|
||||
Summary: MySQL client programs and shared libraries
|
||||
URL: http://www.mysql.com
|
||||
@ -524,9 +524,9 @@ the MySQL sources.
|
||||
|
||||
# Patch Boost
|
||||
pushd boost/boost_$(echo %{boost_bundled_version}| tr . _)
|
||||
%patch111 -p0
|
||||
%patch111 -p1
|
||||
%patch112 -p1
|
||||
%patch113 -p2
|
||||
%patch113 -p1
|
||||
popd
|
||||
|
||||
# check that we have correct versions in bundled(*) Provides above (boost checked with pushd above)
|
||||
@ -1210,6 +1210,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Feb 07 2025 Lukas Javorsky <ljavorsk@redhat.com> - 8.0.41-1
|
||||
- Update to MySQL 8.0.41
|
||||
|
||||
* Wed Jan 03 2024 Lars Tangvald <lars.tangvald@oracle.com> - 8.0.36-1
|
||||
- Update to MySQL 8.0.36
|
||||
|
||||
|
@ -3,3 +3,7 @@ main.subquery_bugs : BUG#0
|
||||
|
||||
# Failing on C9S & RHEL 9 for MySQL release 8.0.33
|
||||
main.subquery_sj_all_bka_nobnl : BUG#0
|
||||
|
||||
# Fails since 8.0.41
|
||||
main.archive : BUG#0
|
||||
main.func_compress : BUG#0
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mysql-boost-8.0.36.tar.gz) = a6c1c009a322b7e7aa2aa607573060414c847c77d48f44a24058ffb89673621f2ebbcc1a4448fa841a87ff721159cc8eaf44a57721c7dc233c130691c16a9d4a
|
||||
SHA512 (mysql-boost-8.0.41.tar.gz) = e5bb314082be6bf037808ea7a2130c8e2b44491a6c54bc3f611d823be5285021d05093afca71c3d33da6dece2bac3a8e24da5198080060407d8c4dbfeeea8a99
|
||||
|
Loading…
Reference in New Issue
Block a user