Update to MySQL 8.0.40
Resolves: RHEL-63024
This commit is contained in:
parent
9b21f1d072
commit
a4abdea5a1
@ -1,7 +1,7 @@
|
|||||||
Index: boost/pool/pool.hpp
|
Index: boost/pool/pool.hpp
|
||||||
===================================================================
|
===================================================================
|
||||||
--- boost/pool/pool.hpp (revision 78317)
|
--- a/boost/pool/pool.hpp (revision 78317)
|
||||||
+++ boost/pool/pool.hpp (revision 78326)
|
+++ b/boost/pool/pool.hpp (revision 78326)
|
||||||
@@ -27,4 +27,6 @@
|
@@ -27,4 +27,6 @@
|
||||||
#include <boost/pool/poolfwd.hpp>
|
#include <boost/pool/poolfwd.hpp>
|
||||||
|
|
||||||
@ -88,8 +88,8 @@ Index: boost/pool/pool.hpp
|
|||||||
// insert it into the list,
|
// insert it into the list,
|
||||||
Index: libs/pool/test/test_bug_6701.cpp
|
Index: libs/pool/test/test_bug_6701.cpp
|
||||||
===================================================================
|
===================================================================
|
||||||
--- libs/pool/test/test_bug_6701.cpp (revision 78326)
|
--- a/libs/pool/test/test_bug_6701.cpp (revision 78326)
|
||||||
+++ libs/pool/test/test_bug_6701.cpp (revision 78326)
|
+++ b/libs/pool/test/test_bug_6701.cpp (revision 78326)
|
||||||
@@ -0,0 +1,27 @@
|
@@ -0,0 +1,27 @@
|
||||||
+/* Copyright (C) 2012 Étienne Dupuis
|
+/* Copyright (C) 2012 Étienne Dupuis
|
||||||
+*
|
+*
|
||||||
|
@ -10,8 +10,8 @@ Subject: [PATCH] Update gcc Intel intrinsic usage config. Fixes
|
|||||||
|
|
||||||
diff --git a/include/boost/multiprecision/cpp_int/intel_intrinsics.hpp b/include/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
diff --git a/include/boost/multiprecision/cpp_int/intel_intrinsics.hpp b/include/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
||||||
index eb4624bb4..37717cd51 100644
|
index eb4624bb4..37717cd51 100644
|
||||||
--- a/include/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
--- a/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
||||||
+++ b/include/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
+++ b/boost/multiprecision/cpp_int/intel_intrinsics.hpp
|
||||||
@@ -19,7 +19,11 @@
|
@@ -19,7 +19,11 @@
|
||||||
// If this is GCC/clang, then check that the actual intrinsic exists:
|
// If this is GCC/clang, then check that the actual intrinsic exists:
|
||||||
//
|
//
|
||||||
|
11
mysql.spec
11
mysql.spec
@ -16,7 +16,7 @@ ExcludeArch: %{ix86}
|
|||||||
# The last version on which the full testsuite has been run
|
# The last version on which the full testsuite has been run
|
||||||
# In case of further rebuilds of that version, don't require full testsuite to be run
|
# In case of further rebuilds of that version, don't require full testsuite to be run
|
||||||
# run only "main" suite
|
# run only "main" suite
|
||||||
%global last_tested_version 8.0.36
|
%global last_tested_version 8.0.40
|
||||||
# Set to 1 to force run the testsuite even if it was already tested in current version
|
# Set to 1 to force run the testsuite even if it was already tested in current version
|
||||||
%global force_run_testsuite 0
|
%global force_run_testsuite 0
|
||||||
# Aditional SELinux rules
|
# Aditional SELinux rules
|
||||||
@ -77,7 +77,7 @@ ExcludeArch: %{ix86}
|
|||||||
%global sameevr %{?epoch:%{epoch}:}%{version}-%{release}
|
%global sameevr %{?epoch:%{epoch}:}%{version}-%{release}
|
||||||
|
|
||||||
Name: mysql
|
Name: mysql
|
||||||
Version: 8.0.39
|
Version: 8.0.40
|
||||||
Release: 1%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Summary: MySQL client programs and shared libraries
|
Summary: MySQL client programs and shared libraries
|
||||||
URL: http://www.mysql.com
|
URL: http://www.mysql.com
|
||||||
@ -399,9 +399,9 @@ the MySQL sources.
|
|||||||
|
|
||||||
# Patch Boost
|
# Patch Boost
|
||||||
pushd boost/boost_$(echo %{boost_bundled_version}| tr . _)
|
pushd boost/boost_$(echo %{boost_bundled_version}| tr . _)
|
||||||
%patch -P111 -p0
|
%patch -P111 -p1
|
||||||
%patch -P112 -p1
|
%patch -P112 -p1
|
||||||
%patch -P113 -p2
|
%patch -P113 -p1
|
||||||
popd
|
popd
|
||||||
|
|
||||||
# generate a list of tests that fail, but are not disabled by upstream
|
# generate a list of tests that fail, but are not disabled by upstream
|
||||||
@ -986,6 +986,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 06 2025 Lukas Javorsky <ljavorsk@redhat.com> - 8.0.40-1
|
||||||
|
- Update to MySQL 8.0.40
|
||||||
|
|
||||||
* Thu Feb 06 2025 Lukas Javorsky <ljavorsk@redhat.com> - 8.0.39-1
|
* Thu Feb 06 2025 Lukas Javorsky <ljavorsk@redhat.com> - 8.0.39-1
|
||||||
- Rebase to version 8.0.39
|
- Rebase to version 8.0.39
|
||||||
|
|
||||||
|
@ -33,3 +33,6 @@ rpl.rpl_fips : BUG#0
|
|||||||
binlog.binlog_mysqlbinlog_linux : BUG#0
|
binlog.binlog_mysqlbinlog_linux : BUG#0
|
||||||
perfschema.idx_session_connect_attrs : BUG#0
|
perfschema.idx_session_connect_attrs : BUG#0
|
||||||
rpl_gtid.mysqldump_bug33630199 : BUG#0
|
rpl_gtid.mysqldump_bug33630199 : BUG#0
|
||||||
|
|
||||||
|
# Failing since MySQL 8.0.40
|
||||||
|
main.time_zone : BUG#0
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mysql-boost-8.0.39.tar.gz) = 2a2785c89b59cb198d1cf383584d453d058352f0d42e485e5315163fd03e404ea4c6281ab9eb0eb7103768057af52a99dd93cb1890b61edada0d27e0ba32ed44
|
SHA512 (mysql-boost-8.0.40.tar.gz) = fcece6e3c09dc4733767effb5c22a55e4add1c9f6b6b911e1eccdd0444f08dc5714b3c8b2a40c85a75a63ff117b6c9881904b6b4732b5ca9bef96de1cb2e284a
|
||||||
|
Loading…
Reference in New Issue
Block a user